The TVDB scraper is currently broken due to upgrade works at TheTVDB site. We hope this issue will be resolved quickly.

  •   
  • 1
  • 64
  • 65
  • 66
  • 67(current)
  • 68
  •   
Release OzWeather - Australian Weather Addon using BOM data
(2019-05-14, 10:47)raspberrypie Wrote: Looks like there is no Alpha channel in the most recent radar currentloop png images (I just checked). Some old png's I found lying around from last year have Alpha channels, and so do all the background overlays I just re-downloaded. Any way to tell the addon to treat black as transparent?
Looking harder, I find there is an Alpha channel in the radar data (full 32 bit pixels). I was confused by opening the files in Irfanview which had the Alpha channel greyed out for recent radar loop png files. But if you looked at another channel, eg Red, for that file then the Alpha channel became available!

So maybe something has changed with Alpha channels in png files that my ancient, hasn't been updated for years kodi doesn't know about. I'll try updating the python image library, and hope this doesn't break something else...
Reply
Good luck @raspberrypie - but yeah, I tested 1.0.1 on a few platforms last night and with the move to https for weatherzone all was working as expected... I am unlikely to consider doing anything like 'black as transparent' at my end...so you'll have to wrangle PIL (PILLOW) etc at your end if need be.
Sorry, no help w/out a *full debug log*
Reply
Any chance of a parameter that prevent the startup notices appearing every 30 min?
I would prefer it only at startup, not each time it updates the weather.
I am not a fan of too much noise in logs Smile
Reply
Not really - I use some common code across various addons to make it all a bit easier, and for some of them that info is useful for those...that said, maybe in a few months when I look to moving them all over to Python 3 I might take the chance to slim down the logging a bit (but I gotta say I personally don't give a hoot what gets logged other than it making things as easy as possible for me to write & maintain the addons...)
Sorry, no help w/out a *full debug log*
Reply
Sad 
(2011-12-14, 06:35)bossanova808 Wrote: <cut>

Hello, thank you for making Oz Weather service for KODI.
I'm using it on Raspberry Pi 2, but I am having problems.

When I go to System > Service settings > Weather > Settings, Change Suburb, I try to enter a postcode or name, it always replies with:

No results found.

I have tried the following:

4562
Tewantin
Doonan
Noosa

Why doesn't it work?

I'm using:

OzWeather 1.0.0.0
LibreELEC (official): 8.2.5 (kernel: Linux 4.9.80)
Build: Kodi 17.6 Git:a9a7a20

Also occasionally I get a pop-in saying 'Oz Weather error - Check log for info'
When I go to System > Event log, the only event is:

Kodi successfully started (dated from last year)

I can't see any way of enabling logging for Oz Weather.

Please help.
Reply
@marco.nadal.75 Please post (to pastebin or similar) a full Kodi debug log - from a clean boot to configuring the addon.  I have just tried all of those with no issues...


Log_file/Advanced (wiki)

(sorry for the slow response, was on holiday!)
Sorry, no help w/out a *full debug log*
Reply
Hi folks,
Wondering if anyone can help - i've been using OzWeather in Kodi 18.2 Git:20190422-f2643566d0 on a Windows 10 box for our office wallboard to display weather info.

For various reasons i'm configuring an Intel NUC running Kubuntu 18.04 to now run this instead, however i keep having errors launching the weather addon..
It's almost like the addon config for postcode/suburb and other settings is being cleared? as they are gone after the error pops up.

Paste bin is here

Hope that's enough inf to assist, let me know if you need anything else!
Reply
(2019-07-11, 13:14)marco.nadal.75 Wrote:
(2011-12-14, 06:35)bossanova808 Wrote: <cut>



I have tried the following:

4562
Tewantin
Doonan
Noosa

Why doesn't it work?

I'm using:

OzWeather 1.0.0.0 
try 1.0.0.1

Image
Reply
Technically it is 1.0.1 that is in the repo.  Not sure why you would not get that one automatically?

Go into you addon_data/weather.ozweather folder - what is the contents of your settings.xml?

An example complete one looks like this - maybe there is an issue writing to that file??


<settings version="2">
    <setting id="ABCQuality" default="true">1000k</setting>
    <setting id="BGDownloadToggle">true</setting>
    <setting id="ExtendedFeaturesToggle">true</setting>
    <setting id="Location1">Ascot Vale, VIC 3032</setting>
    <setting id="Location1UrlPath">/vic/melbourne/ascot-vale</setting>
    <setting id="Location2">Myrtle Bank, SA 5064</setting>
    <setting id="Location2UrlPath">/sa/adelaide/myrtle-bank</setting>
    <setting id="Location3">Lorne, VIC 3232</setting>
    <setting id="Location3UrlPath">/vic/central/lorne</setting>
    <setting id="Radar1">IDR023</setting>
    <setting id="Radar2">IDR00004</setting>
    <setting id="Radar3">IDR022</setting>
</settings>
Sorry, no help w/out a *full debug log*
Reply
Out of the blue this add on has stopped working for me and on each refresh it says “an error has occurred please check the logs” but in the GUI logs there’s nothing. Can anyone tell me where to look?
Reply
You need to post a full debug log for me to look at (if problems persist - usually the issues are temporary issues with the sites being scraped).  So give it a day, if still broken, follow the link in my signature and post a full debug log.
Sorry, no help w/out a *full debug log*
Reply
(2019-10-20, 13:45)ajerazzor Wrote: Out of the blue this add on has stopped working for me and on each refresh it says “an error has occurred please check the logs” but in the GUI logs there’s nothing. Can anyone tell me where to look?

Same exact thing happened to me! Tried reinstalling the app but it throws an error even when trying to select a location. Stopped working same time as you.

Funnily enough, there was an update to open weather just before it crashed but could be anything I suppose. Not around to provide a log unfortunately. Weekend is the earliest I can do.

Could this have anything to do with Team Kodi migrating from Python 2 to Python 3?
Kodi Matrix 18.4 - Aeon MQ8 2.9.0 - madVR - MPC BE - RTX 2080 Ti - i9 9900K - LG C7 OLED - Setup
Reply
I also get “an error has occurred please check the logs” which show python errors.

Since i use Kodi 19 nightly, which i think post 0ct 13 saw python 2 depreciated, all add-ons must be python 3 compatible.
Currently many add-ons, including this one, are not python 3 compatible Sad
I'm a XBMC novice :)
Reply
Working fine here on multiple (Kodi 18) machines.  So will need a full debug log to look at that if problems persist.

I will port to Python 3..indeed have a bunch of addons planned for that...but not until the new year as I am too busy with work before that.  So Kodi 19 and OzWeather is a no go for a bit, sorry!  But it shouldn't be too hard once I get there...from what I can see, anyway!
Sorry, no help w/out a *full debug log*
Reply
this addon needs updating
<requires>
        <import addon="xbmc.python" version="2.25.0"/>
        <import addon="script.module.pil" version="1.1.7"/>
        <import addon="script.module.requests" version="2.19.1"/>
        <import addon="script.module.beautifulsoup4" version="4.3.2"/>       
    </requires>

updates are from weather.yahoo addon.xml

it may have something to do with tring kodi 19 then going back to kodi 18
Reply
  •   
  • 1
  • 64
  • 65
  • 66
  • 67(current)
  • 68
  •   
 
Thread Rating:
  • 5 Vote(s) - 4.6 Average



Logout Mark Read Team Forum Stats Members Help
OzWeather - Australian Weather Addon using BOM data4.65