[Ubuntu] MCE Remote help
#1
First posting on this forum here. So far I've managed to save myself by reading only. Today I've been stranded...
I've got an MCE remote and my power button doesn't shut my HTPC down. I've looked at several forum posts but I can't figure out where to start looking to get this fixed. Basically I want two things:
1. Power button shuts down HTPC
2. Windows button shows OSD

Here is some output I managed to get:

showkey output
Code:
# power button
keycode 142 press
keycode 142 release

# windows button
keycode 226 press
keycode 226 release

XBMC Debugging output
Code:
# Power button
16:10:10 T:6346512   DEBUG: SDLKeyboard: scancode: 96, sym: 009f, unicode: 0000, modifier: 0
16:10:10 T:6346512   DEBUG: GetActionCode: Trying Hardy keycode for 0xf200
16:10:10 T:6346512   DEBUG: Previous line repeats 3 times.
16:10:10 T:6346512   DEBUG: OnKey: 0 (f200) pressed, action is

# Windows button
16:11:18 T:6346512   DEBUG: SDLKeyboard: scancode: ea, sym: 0000, unicode: 0000, modifier: 0
16:11:18 T:6346512   DEBUG: GetActionCode: Trying Hardy keycode for 0xf200
16:11:18 T:6346512   DEBUG: Previous line repeats 3 times.
16:11:18 T:6346512   DEBUG: OnKey: 0 (f200) pressed, action is

In the XBMC Debugging output both buttons present the "f200" number and that confuses me. They should be different in my opinion...

I was running OpenELEC and now I switched to XBMCbuntu Eden beta 2. In OpenELEC the remote was working fine so I started comparing the two. However OpenELEC uses eventlirc stuff which I can't relate to the config of XBMCbuntu which uses just lirc.

I'm running a Shuttle XS35GT, 30GB Kingston disk and 1GB of Kingston memory. Lsusb tells me I have a TopSeed Technology Corp. RF Combo Device remote control which is identical to this one: http://www.topseed.com.tw/gptype.htm

Any help is appreciated!
Reply
#2
http://forum.xbmc.org/showpost.php?p=968...tcount=193

should help you.
Reply
#3
That post is about fixing the resume from suspend problem. My issue is that I can't even power down my XBMC with my remote. I think I therefor need to map this key somehow. It seems to me that XBMC doesn't recognize the button (yet...).
Reply
#4
Got it fixed! Finally found a howto that was somewhat relevant:

http://wiki.xbmc.org/index.php?title=HOW...e_on_Linux

Happy user now! Smile
Reply
#5
Glad to see someone got it working.

However, I wonder if there is a way to get it working without having to install lirc. Lirc provides the daemons and utilities for infra-red remotes in Linux. However, hasn't the same functionality already be incorprated in the Linux kernel (using 3.2.0-3-686-pae at the moment)? My MCE remote works out of the box (not all buttons) without doing any configuration in Linux or XBMC.
Reply



Logout Mark Read Team Forum Stats Members Help
[Ubuntu] MCE Remote help0
This forum uses Lukasz Tkacz MyBB addons.