•   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 68
  •   
[WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app
(2012-07-06, 06:44)SlackMaster Wrote:
(2012-07-05, 08:16)_Mikie_ Wrote: @SlackMaster Valid point. Maybe a chosen number with a "show more" to show everything?

Yea, something like that. Just to help the aesthetics on the dashboard. I like what's been done so far. Looks really nice.

If you added an "Applications" feature like Maraschino has, you might convince me to make the switch. I kind of use Maraschino as a landing page for my whole setup right now and use it for shortcuts to other stuff (like my router). As was stated though, it's not very tablet friendly.

It's nice to see some development on this again though. Cheers to all those who are breathing some life back into this.


(2012-07-05, 18:30)maruchan Wrote: Any chance that CouchPotato functionality will be included at some point? Would be great to have a single interface for managing everything.

The latest one I downloaded has CouchPotato functionality.

which one? the one on the mainsite is 1.0.1 which doesnt have couchpotato
Reply
Go to https://github.com/mbw2001/HTPC-Manager and click the "ZIP" button. That includes all the files you need and has CouchPotato functionality. You'll need to be running CouchPotato v2 for it to work.

So far, I'm loving this unified interface. Some functionality is missing (CouchPotato doesn't let me choose quality, SAB doesn't let me rename downloads, etc.), but for the most part this is really great. Major kudos to all that are involved.
Reply
ah.. there we go.. will try that later..

is there anyway we can set that.. when we have the "recently added shows" or "recently added movies".. the option can be clickable, and we can launch the show or movie right from the link?
Reply
ok.. ran into an issue trying to load up movies right from the xbmc section.. when i try to load up movies or tv shows.. when i click play.. it always prompts me for credentials.. i try using my htpc manager credentials but they dont work.. i dont have any xbmc passwords.. any idea?
Reply
Looks awesome.
Any chance for adding Headphones to it?
Image
Reply
It would be nice to be able to install this on a Synology NAS. Has anyone made a .spk package? There are some instructions on how to make these here: http://forum.synology.com/wiki/index.php...kage_files
Reply
(2012-07-09, 04:52)gman3042 Wrote: ok.. ran into an issue trying to load up movies right from the xbmc section.. when i try to load up movies or tv shows.. when i click play.. it always prompts me for credentials.. i try using my htpc manager credentials but they dont work.. i dont have any xbmc passwords.. any idea?

anybody know why this would happen?
Reply
gman3042:
Still happening with the latest version from my repo?
Is it listing the movies correctly?
Since i have passwords on my own XBMC's I haven't tested without passwords. But as a quick workaround you can try adding passwords to XBMC.
I'll try removing passwords on my XBMC "soon" (as in whenever i get the time) Wink
I made some changes again. Most are hidden in the code but a few changes are visible.

- Search link has been replaced with a search field on the front page. This fields doubles as a filter for XBMC moves, XBMC shows and Squeezebox. So when you enter text it filters the lists. If you press enter it searches.
- Squeezebox addon now has support for Internet Radio stations.
- The frontpage now displays the last 5 downloads.
- Experimental support for multiple XBMC's has been added. It requires manually adding the servers to the configuration file as this:

Code:
xbmc_labels = ["xbmcserver1", "xbmcserver2"]

[xbmcserver1]
xbmc_host =
xbmc_port =
xbmc_username =
xbmc_password =

[xbmcserver2]
xbmc_host =
xbmc_port =
xbmc_username =
xbmc_password =
Reply
gman:

I just checked and on my own version it works fine both with and without passwords.
Are you sure you entered the right ip/hostname and port? I had a similar problem at a point when using the wrong port therefor pointing at another service with another password.
Reply
I added a quick patch to limit the wanted movies list to 5 entries.

I will probably add a settings to change the limit later, however the entire settingssystem could do with a makeover. Perhaps to a database for better support for multiple XBMCs. Until then it can be changed in /interfaces/default/js/dash.js

As for headphones, I don't use it and since there is plenty of work to be done still on the current modules I have no plans for adding it. However if someone else feels like writing the module Ill be more than happy to add it to my repo.
Reply
Mbw2001 - Just updated to your latest commits and the interface no longer loads. It's throwing this error -

Traceback (most recent call last):
File "/home/xbmc/Software/HTPC-Manager/libs/cherrypy/_cprequest.py", line 656, in respond
response.body = self.handler()
File "/home/xbmc/Software/HTPC-Manager/libs/cherrypy/lib/encoding.py", line 188, in __call__
self.body = self.oldhandler(*args, **kwargs)
File "/home/xbmc/Software/HTPC-Manager/libs/cherrypy/_cpdispatch.py", line 34, in __call__
return self.callable(*self.args, **self.kwargs)
File "/home/xbmc/Software/HTPC-Manager/htpc/index.py", line 8, in index
template = Template(file=os.path.join(htpc.template, 'dash.tpl'), searchList=[htpc.settings]);
File "/home/xbmc/Software/HTPC-Manager/libs/Cheetah/Template.py", line 1259, in __init__
self._compile(source, file, compilerSettings=compilerSettings)
File "/home/xbmc/Software/HTPC-Manager/libs/Cheetah/Template.py", line 1546, in _compile
self._fileMtime = os.path.getmtime(file)
File "/usr/lib/python2.7/genericpath.py", line 54, in getmtime
return os.stat(filename).st_mtime
OSError: [Errno 2] No such file or directory: '/interfaces/default/dash.tpl'

It looks like it's not pulling the entire path to the file?
Reply
Hmm... Looks strange. I dont get the error. Neither on my dev server nor on a clean install :/

I think i might be a value in config.cfg thats no longer valid.

Try setting the template and the theme like this:

template = default
theme = default

If it doesnt work try deleting the config.cfg (you will have to setup all the services again) or try copying the file here (remove passes).

Reply
It looks like it was my original initd - I removed the -d from the startup args and it runs fine now.
Reply
Arh... It handles paths differently when daemonizing through commandline.

I'll look into a fix however for now i disabled the -d argument since most people will have it in their initd script.
Reply
Are there any more command line arguments? I'm looking to make a plug-in for this app on unRAID, but since there is no GUI everything has to be done via command line.

Example, --pid-file, --port, --data-dir
Reply
  •   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 68
  •   
 
Thread Rating:
  • 7 Vote(s) - 4.71 Average



Logout Mark Read Team Forum Stats Members Help
[WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app4.717