•   
  • 1
  • 65
  • 66
  • 67(current)
  • 68
  • 69
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
(2014-11-19, 18:31)feliche Wrote:
(2014-09-16, 17:42)feliche Wrote:
(2014-08-28, 18:10)feliche Wrote: Hi,

I´ve problems setting audio and subtitles as default.

I´m spanish and almost all films I have spanish is the main source but I always watch films on english audio with english subtitles.

Has anyone same problem?

Thank you

PD: Sorry english writting mistakes Smile

Hi,

I need someone help me with the subject above.

Anyone has any close idea why would happen?

Thank you

Hi guys,

I really need a hand here.

Anyone?

Thank you

This should work with avsplitter. Simply set your default audio and subtitle order there.
Reply
(2014-11-19, 19:18)Slurm Wrote:
(2014-11-19, 18:31)feliche Wrote:
(2014-09-16, 17:42)feliche Wrote: Hi,

I need someone help me with the subject above.

Anyone has any close idea why would happen?

Thank you

Hi guys,

I really need a hand here.

Anyone?

Thank you

This should work with avsplitter. Simply set your default audio and subtitle order there.

I´ll give it a try.

Thank you
Reply
For those still waiting for madVR integration with DS Player, I posted an extensive guide on how to use MPC-HC with madVR as an external player with Kodi. I still use DS Player on a laptop and enjoy it, but my main HTPC is configured towards maximum picture quality and I prefer madVR as the video renderer. I remain hopeful the video renderer in DS Player will be upgraded in the future.

1843499 (post)
Reply
I don't know if there was an explanation, but I have problem with "Use system filters (DisrecShow merits)" option. When it is cheked video is playing, altough picture doesn't look how I wanted, but when I leave it not checked, then it just doesn't play anything at all.
Reply
Use directshow merits uses ur system's merits, whatever they are. This is not always something completely transparent on Windows, but u can download some of the small programs out there to change it to ur taste, assuming the filter is installed on ur system (few come to mind, as "direct show control" or "Win7DSFilterTweaker").
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Always prefer custom filterconfig / mediaconfig.
Reply
(2014-11-26, 08:27)oldpoem Wrote: Always prefer custom filterconfig / mediaconfig.

Sure, more control, i think the same way, but he was asking, and i know it can be changelling for people, when it starts to fail and u don't know why.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Hello everybody!

Is there a way to change the font to something different than Arial?
I can change the size through the Kodi settings alright and see the result at my videos (so I am sure I am not using external subtitle engine), but when I change the font to some other truetype font I've put on AppData\Roaming\Kodi\media\Fonts\ it still show up Arial.
I even replaced the c:\Program Files (x86)\Kodi\media\Fonts\arial.ttf file with the font of my choice (overwriting the original and naming it again as arial.ttf) and still it was displaying Arial at subtitles.
For the record, I am trying the trebuc.ttf font (Trebuchet MS) that was bundled with Windows.

What am I doing wrong?
Does anybody else have the same problem?

I am using the latest version of aracnoz.
Thanks in advance.
Reply
(2014-11-26, 16:32)Saxtus Wrote: Hello everybody!

Is there a way to change the font to something different than Arial?
I can change the size through the Kodi settings alright and see the result at my videos (so I am sure I am not using external subtitle engine), but when I change the font to some other truetype font I've put on AppData\Roaming\Kodi\media\Fonts\ it still show up Arial.
I even replaced the c:\Program Files (x86)\Kodi\media\Fonts\arial.ttf file with the font of my choice (overwriting the original and naming it again as arial.ttf) and still it was displaying Arial at subtitles.
For the record, I am trying the trebuc.ttf font (Trebuchet MS) that was bundled with Windows.

What am I doing wrong?
Does anybody else have the same problem?

I am using the latest version of aracnoz.
Thanks in advance.
Same here, remember that dsplayer have other subitles options in xbmc settings. So path to arial.ttf can be also different. Because of that I started using external player to display subs correctly.
Reply
(2014-11-26, 16:32)Saxtus Wrote: Is there a way to change the font to something different than Arial?
I can change the size through the Kodi settings alright and see the result at my videos (so I am sure I am not using external subtitle engine), but when I change the font to some other truetype font I've put on AppData\Roaming\Kodi\media\Fonts\ it still show up Arial.
I even replaced the c:\Program Files (x86)\Kodi\media\Fonts\arial.ttf file with the font of my choice (overwriting the original and naming it again as arial.ttf) and still it was displaying Arial at subtitles.
For the record, I am trying the trebuc.ttf font (Trebuchet MS) that was bundled with Windows.

What am I doing wrong?
Does anybody else have the same problem?

I am using the latest version of aracnoz.
Thanks in advance.
This will not really solve the internal subs styling, but I would suggest to use the *awesome* feature added by aracnoz, that enable the native use of xy-vsfilter on dsplayer.

On filtersconfig.xml add the guid from the xy-vsfilter:
PHP Code:
<!-- // adding xy-vsfilter from -->
<!-- // http://code.google.com/p/xy-vsfilter/ or http://www.cccp-project.net/ -->
    
<filter name="xyvsfilter" type="subs">
      <
guid>{9852A670-F845-491B-9BE6-EBD841B8A613}</guid>
      <
osdname>xy-VSFilter</osdname>
    </
filter

On mediasconfig.xml add the <subs filter="xyvsfilter" /> tag into the <rules> you want, for example:

PHP Code:
<!-- // Full lav config, with xy-vsfilter for  the subs. -->
<!-- // I believe those are the default names that comes with the dsplayer installer. -->
    
<rule filetypes="mkv|mp4">
      <
source filter="lavfsplitter" />
      <
splitter filter="lavf_splitter" />
      <
audio filter="lavaudiodec" />
      <
video filter="lavvideodec" />
      <
subs filter="xyvsfilter" />
    </
rule


And this is the one I use, so the subs gets beautifully clear, even on SD content (I also added ffdshow raw filter on filtersconfig):
PHP Code:
<!-- // Haali for source, lav for decoding, ffdshow-raw for simple upscaling to 1080p -->
<!-- //  and then xy-vsfilter for printing the subs on the upscaled video -->
    
<rule filetypes="mkv|mp4">
      <
source filter="haali" />
      <
splitter filter="lavf_splitter" />
      <
audio filter="lavaudiodec" />
      <
video filter="lavvideodec" />
      <
subs filter="xyvsfilter" />
      <
extra>
        <
extra filter="ffdshowrawvideo" />
      </
extra>
    </
rule

And after that, when you play something, you will notice the xy-vsfilter tray icon, where you can click and change the default styling as you want.
If you use dsplayer on a single screen setup, you may need to exit full screen mode to be able to see the tray...



BTW, just noticed that aracnoz ported dsplayer to 14.0 beta4.
Really thanks aracnoz! Big Grin

[]'s
Reply
(2014-11-26, 21:32)le__ Wrote: This will not really solve the internal subs styling, but I would suggest to use the *awesome* feature added by aracnoz, that enable the native use of xy-vsfilter on dsplayer.

Will this allow me to change subtitle language and/or shift subtitle times through the Kodi interface?
Thank you le__.
Reply
(2014-11-26, 22:03)Saxtus Wrote: Will this allow me to change subtitle language and/or shift subtitle times through the Kodi interface?
Thank you le__.
It is possible to change the subs between the embedded subs and the auto-loaded external subtitles (subs that use the same filename, but with different identifier, like "movie.eng.srt" and "movie.ptb.srt", for example) using the OSD menu.

But tried just now on 13.2 (it will take some time to be able to download the 14.0 beta4), and unfortunately it seems that the loading a external subtitle with other filename and the subtitle offset/delay isn't really working, so this isn't in fact a truly complete alternative, sorry. Sad


Edit:
Tried to use the internal subtitle filter and the player was using Trebuchet MS Bold, that i had configured ages ago on previous versions.
Then I tried to change to something else and now it always show as Arial... maybe there's some problem with saving the configuration page on this version, because when I used the configuration set from a previous version, it was actually showing a different font...
Reply
Then the only alternative I've found, is converting my .SRT files to .ASS using my favorite font.

Anyway, thanks for your time.
Reply
(2014-11-26, 21:32)le__ Wrote:
(2014-11-26, 16:32)Saxtus Wrote: Is there a way to change the font to something different than Arial?
I can change the size through the Kodi settings alright and see the result at my videos (so I am sure I am not using external subtitle engine), but when I change the font to some other truetype font I've put on AppData\Roaming\Kodi\media\Fonts\ it still show up Arial.
I even replaced the c:\Program Files (x86)\Kodi\media\Fonts\arial.ttf file with the font of my choice (overwriting the original and naming it again as arial.ttf) and still it was displaying Arial at subtitles.
For the record, I am trying the trebuc.ttf font (Trebuchet MS) that was bundled with Windows.

What am I doing wrong?
Does anybody else have the same problem?

I am using the latest version of aracnoz.
Thanks in advance.
This will not really solve the internal subs styling, but I would suggest to use the *awesome* feature added by aracnoz, that enable the native use of xy-vsfilter on dsplayer.

On filtersconfig.xml add the guid from the xy-vsfilter:
PHP Code:
<!-- // adding xy-vsfilter from -->
<!-- // http://code.google.com/p/xy-vsfilter/ or http://www.cccp-project.net/ -->
    
<filter name="xyvsfilter" type="subs">
      <
guid>{9852A670-F845-491B-9BE6-EBD841B8A613}</guid>
      <
osdname>xy-VSFilter</osdname>
    </
filter

On mediasconfig.xml add the <subs filter="xyvsfilter" /> tag into the <rules> you want, for example:

PHP Code:
<!-- // Full lav config, with xy-vsfilter for  the subs. -->
<!-- // I believe those are the default names that comes with the dsplayer installer. -->
    
<rule filetypes="mkv|mp4">
      <
source filter="lavfsplitter" />
      <
splitter filter="lavf_splitter" />
      <
audio filter="lavaudiodec" />
      <
video filter="lavvideodec" />
      <
subs filter="xyvsfilter" />
    </
rule


And this is the one I use, so the subs gets beautifully clear, even on SD content (I also added ffdshow raw filter on filtersconfig):
PHP Code:
<!-- // Haali for source, lav for decoding, ffdshow-raw for simple upscaling to 1080p -->
<!-- //  and then xy-vsfilter for printing the subs on the upscaled video -->
    
<rule filetypes="mkv|mp4">
      <
source filter="haali" />
      <
splitter filter="lavf_splitter" />
      <
audio filter="lavaudiodec" />
      <
video filter="lavvideodec" />
      <
subs filter="xyvsfilter" />
      <
extra>
        <
extra filter="ffdshowrawvideo" />
      </
extra>
    </
rule

And after that, when you play something, you will notice the xy-vsfilter tray icon, where you can click and change the default styling as you want.
If you use dsplayer on a single screen setup, you may need to exit full screen mode to be able to see the tray...



BTW, just noticed that aracnoz ported dsplayer to 14.0 beta4.
Really thanks aracnoz! Big Grin

[]'s

But you will need to install xy-vsfilter software and not only apply these filters, correct?
Reply
(2014-11-26, 22:53)le__ Wrote: Edit:
Tried to use the internal subtitle filter and the player was using Trebuchet MS Bold, that i had configured ages ago on previous versions.
Then I tried to change to something else and now it always show as Arial... maybe there's some problem with saving the configuration page on this version, because when I used the configuration set from a previous version, it was actually showing a different font...

Welcome to my world...Confused
I can confirm that internal (non-dsplayer) player, actually works with my chosen font, only DSplayer fails to adapt to something else than Arial.
Any idea where DSPlayer saves that setting?
Reply
  •   
  • 1
  • 65
  • 66
  • 67(current)
  • 68
  • 69
  • 95
  •   



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available8
This forum uses Lukasz Tkacz MyBB addons.