• 1
  • 2
  • 3(current)
  • 4
  • 5
  • 38
  Thread Closed
[THREAD CLOSED] Maximinimalism V1.0.6 (Gotham)
@westane: cool. Watch this space.

Comments taken on board, thanks.

Thanks for highlighting the issue with cyrillic fonts. I naively assumed that the font i'm using included them - it clearly doesn't. Apparently the font's author is working on them at the moment. As soon as they're released, I'll update.
Cyrillic is necessary as air .
очень верно :-)
Lovely skin, one thing bugging me though is the difference between the highlighted and non highlighted text. For example in the sidebar, I don't think it's obvious enough which item you're on. Maybe introduce an accent colour?
I love this skin, very nice to see someone more making a fast minimalistic skin that works very good on Pi and ATV2. Smile
And it looks very good, nice job!

Some things though;

* On Gotham I cannot get to skin settings (this even if I have chosen Advanced or Expert in confluence new Gotham settings first). It is not greyed out, but it jumps over it. This is also sometimes (not always) the case if I switch to Frodo from a Gotham install.
I can reproduce this on Pi, ATV2 and OSX.

* Sometimes the skin has broken totally (random characters and setting choices on black background). This has been on "test runs" so I don´t have any info I´m afraid.
This could be a Gotham/Frodo issue I guess. If it happens again I can provide more info (guisettings, xbmc.log) if you need, let me know.

* Additional option for Quit on home screen: "Exit". This is useful on some distros for Pi for example (exit to terminal and/or XBMC restart on some distros)

* i (info) for OSD as stated before, it should be m/menu/ok (I believe). Wink I know it has been said, I am one of those without info button on my TV remote (or… my TV uses it so cannot remap it). I have remapped one of the colored buttons though.

* Video OSD should have play, stop etc I believe. I saw that you deliberately took those away, however some remotes does not have this (i.e AppleTV, some TV remotes etc.) so the OSD is the only choice (depending on mapping of remote of course).

* On my Pi I cannot "browse" in video OSD. Pressing left/right skips video instead so I cannot choose anything. Pressing OK does nothing and all other buttons is still in "video mode" (not "OSD mode").

* No watched status for movies? Maybe I have missed it...

* Pressing "o" (or option on some remotes) on video should show video, audio, codec and playback info etc. I think it tries to do this, but it is programmed into the skin so nothing is visible.

Some small things (not issues):

* There is no System info page. Not a biggie, but can be good sometimes (checking IP etc).

* After playing an episode or movie it defaults back to the left list (where you choose TV, Movies etc.). This is really not an issue, but thought that it might not be deliberate.

It still works good though and I use it daily on 3 different platforms now, but since I cannot get to the skin settings I cannot add a folder for the background fanart. I did trick it by using Frodo first though and it works.

Keep it up, this skin looks great!
- Always looking to improve. Accenting on a white background is not particularly effective I feel - a block item background works but looks a bit overkill. I see from your profile that you're handy with visual design - any chance of a quick mockup of your thoughts?

Cheers! Lots to do, but your feedback is massively appreciated.

- Skin settings: My pre-release test platform are both Frodo. There's nothing clever going on with skin settings - l'll have to download a nightly and see what's what.
- Addition of exit option noted - will be included on next update.
- Watched status for movies is a silly omission - thanks for spotting that!
- Info OSD from OK without keymap fiddling is sorted and will be in the next update
- The 'o' dialog is simply unskinned at the moment. I'm not entirely decided on how that will be handled.
- I'll reconsider the inclusion of OSD controls in light of the valid points you make.

On thing does concern me a bit though - I'm not sure I know what you mean by OSD / Video 'mode'... Are you saying that you are unable to navigate the options on the info screen (to select 'audio settings' for example)?

Extending the custom addon selection is eating my time at the minute, but shooting for an update in the next week or so. At that point, I'll get it on the WIP skin repo.
Cheers Smile

I think you got it right, when I bring up on screen display (with i/info) when watching a video I cannot choose anything such as video/audio and subtitles. All buttons still reacts to the playback.

I have also tested on ATV2 now and it is the same thing.
Another thing, there seems to be no way to reach favorites.

Edit: Should have looked before posting, there is no DialogFavourites.xml, so duh :S
Do you plan to add this?
Short answer on that one is 'yes'. Not sure if it will make the next update though (although you will be able to select from favourites when adding a menu item, along with playlists / folders etc).

Life's getting in the way at the moment, bear with me :-)
(2013-08-21, 21:27)thedeadman Wrote: Life's getting in the way at the moment, bear with me :-)

OMG! There's a bear with you!? Are you okay? You should offer him some honey... Laugh
Update committed to GIT today

- Now playing info now available directly from OK button
- Movie listing tweak (now shows year and resolution)
- Video addon listing layout adjustment
- Exit, suspend, hibernate options added to shutdown menu
- Custom menu shortcut upgrade: Now accepts playlists
- Custom menu shortcut count increased to 8 per video / music

@Westane: The menu shortcut interaction is not quite perfect yet, but the barebones functionality is there. Hope it does what you need.
On my Pi I always get this error message when trying to start XBMC when your skin is set:
ERROR: Control 1 in window 10099 has been asked to focus, but it can't

This keeps XBMC from starting and it hangs on splash screen.
I have not seen this on OSX or ATV2 though.
Will investigate further and see if I can get it fixed.

I also get the following warning (happns on all my platforms but doesn´t seem to matter):
WARNING: CreateFile, successfuly opened </home/pi/.xbmc/addons/skin.maximinimalism-master/1080i/includes_animations.xml> instead of </home/pi/.xbmc/addons/skin.maximinimalism-master/1080i/Includes_animations.xml>
17:49:29 T:3040920272

WARNING: CreateFile, successfuly opened </home/pi/.xbmc/addons/skin.maximinimalism-master/1080i/DialogSeekbar.xml> instead of </home/pi/.xbmc/addons/skin.maximinimalism-master/1080i/DialogSeekBar.xml>
Ok, I think I found the problem regarding "ERROR: Control 1 in window 10099 has been asked to focus, but it can't".
I deleted the following from pointer.xml and now it works:
<defaultcontrol always="true">1</defaultcontrol>

I think that this is old code that snuck in and shouldn´t be there.
Google that error code for more info.

Edit: Well, that error went away, but I cannot start XBMC on Pi when on Gotham. Frodo is fine. So I guess it is a Gotham thing. Smile

Good work on the pointer.xml - you're right, looks like old code that snuck into the Foundation skin. On OSX, it seems to be the source of a random crashing issue that's been driving me slowly nuts so thanks for spotting that!

Warning messages are references to minor filename letter casings, both now fixed.

I've just updated pointer.xml on my GIT using code from Confluence. Does that solve your Gotham issue?
Hey thedeadman.... hehe, weird name. Wink
I must learn to investigate proper before posting...

I have tested on several platforms, and XBMC starts on all things I have tried except Raspbmc (Pi and Gotham does not start).
I am trying to identify what causes the "freeze" on Gotham and Raspbmc.

I will first try your new code from git and see if that helps.

Edit: No go on my Pi.
As I stated, I believe that it is only my Gotham nighlty (Aug 5) on Raspbmc that does not start. All other platforms seems to work.
I uploaded a xbmc.log but I really don´t know if it will help, I couldn´t spot anything.
Perhaps it is the nightly on Raspbmc that causes the problems but I don´t have this problem on other skins though.

xbmc.log (debug): http://pastebin.com/cmsp3jLp
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 38
  Thread Closed
Thread Rating:
  • 20 Vote(s) - 4.3 Average

Logout Mark Read Team Forum Stats Members Help
[THREAD CLOSED] Maximinimalism V1.0.6 (Gotham)4.320