• 1
  • 37
  • 38
  • 39(current)
  • 40
  • 41
  • 119
RaspBMC Kodi/XBMC test builds
(2014-02-19, 20:22)popcornmix Wrote: There were two main reasons for getting dvdplayer working.
Software decode for unsupported SD resolution codecs (e.g. msmpeg-4, DivX 3, sorenson spark)
Full DVD playback with menus

Thanks for your elaborated response. It certainly helps getting an understanding of the current developments.

(2014-02-19, 20:22)popcornmix Wrote: At the moment a goal would be to:
make dvdplayer the default for dvd images
make omxplayer the default for all other files
allow "play using dvdplayer" to be a manual option for software video decode of SD codecs, or as an alternative for a file that plays badly.

That sounds like the best setting given the current situation.

(2014-02-19, 20:22)popcornmix Wrote: Unfortunately xbmc's structure doesn't make it easy to automatically play an unsupported codec with dvdplayer.
You only know for sure that you can't play it once omxplayer has opened the ffmpeg demuxer and got the codec hints out (the filename is not enough).
It would be quite ugly to make omxplayer return an error and then have xbmc retry with dvdplayer (but it's an option).

That I understand... Maybe an alternative solution could be this: Make omxplayer the default player for all non-dvd videos, and put some logic in it to detect if it would be able to play the file correctly once the codec hints are known. And if not, close the file and hand over playback to dvdplayer. This means that we don't have to rely on any info from the database that may not be present or not reliable. This seems something that should be doable without changing the XBMC internals, but it does introduce a dependency between omxplayer and dvdplayer...

(2014-02-19, 20:22)popcornmix Wrote: A longer term goal could be to merge omxplayer and dvdplayer.
Currently OMXPlayer.cpp and DVDPlayer.cpp are quite similar, so use a common file for that.
Once ffmpeg parsing is done either code from DVDPlayerVideo.cpp or OMXPlayerVideo.cpp would be invoked based on codec/resolution and user options.
That would avoid some of the maintenance omxplayer requires (merging changes from DVDPlayer.cpp to OMXPlayer.cpp) but shouldn't harm performance.

Their functionality is indeed very similar (from the user-perspective, I can't judge the internal workings of the two programs), and merging seems like the most obvious goal to prevent maintenance on two very similar products. The suggestion you do here seems to be the best to get the 'best of both', and could prevent dirty hacks like the one I suggested above (launch dvdplayer from omxplayer when required).

Thanks again for your great work on this project and the time you spend helping us out in case of problems.

FYI, last night I tested about 20 dvd's with dvdplayer, and all worked almost perfectly. So far I only found that 'Alles is familie' dvd that makes my poor Pi crash.
I said 'almost perfectly', because trick modes don't work in dvd menus. I spent a lot of time last night watching those anti-piracy commercials, without being able to skip them, or use Fast Forward of any kind. Normally I can use the cursor keys to move around videos, but up/down don't work because those videos are <10m, and left/right only seem to advance 1s. Playing at higher speed (x2, x4 etc.) doesn't seem to work at all in menu videos...
Is there a way to advance to the 'next chapter' when playing menus and videos with dvdplayer? (And to the end of video when in the last chapter?) Maybe my remote is just missing the right buttons for that...
Besides these things, all menus are working great so far. I'll be testing more dvd's the coming days...
Not sure what happend, but as of the 0219 build the DVD menus isn't working, shifted back to 0214 and everything worked again.
Updated firmware?
First of all, I would like to thank you everyone for their supports, development and great apps. I installed the latest XBMC version with instructions given by miappa and I have to say, they were seamless. The channels switch fast, while the entire experience is fantastic.

Not sure this is the right post, how do I skip commercials from recordings, I do not see any button while I'm watching tv that will let me bypass the commercials.

P.S. using MythTv as backend and HDHomeRun for frontend.
Hi - Yes firmware is updated.

(2014-02-21, 02:16)miappa Wrote: Updated firmware?
I´ve had some problems with the firmware update needed for the last updates
- but I believe the problem is sitting in front of the Pi Big Grin

I copied the files from posting 1 to the SD Card. Then I updated to the last version.
System Info was still showing an old Linux Version - not 3.10.30

Then I enabled in RASPBMC Settings : Install and Update Kernel headers. After reboot the Pi was "dead".
I had to do a initctl start XBMC via SSH - otherwise dark screen

So I deleted the last testbuild and made this via SSH :

sudo mv /scripts/upd_sys/ftr.sh /tmp/
sudo rm /scripts/upd_sys/*.sh
sudo mv /tmp/ftr.sh /scripts/upd_sys/
sudo wget http://svn.stmlabs.com/svn/raspbmc/testi...getfile.sh -O /scripts/upd_sys/getfile.sh

then reboot and installing the latest testbuild again

Ok - Pi is starting again without manually help via SSH

But System Info still says: Linux 3.10.21 from Dec 3rd 2013

I´m confused - please help me out Huh
Nothing wrong in asking here, but if this is a general XBMC question you might get more help in the PVR forum.
I don´t know if you have seen this, if not it might help: http://wiki.xbmc.org/index.php?title=Edit_decision_list

Working fine here and as far as I can see it should, with new firmware from 17th.
Working on all iso´s I have (which is not many though).
Perhaps a log + sample file can help, but please check both XBMC version and firmware version to make sure you are on latest on both.

These builds only contains XBMC. Raspbmc and kernel/linux versions are untouched.
It looks like you are on an old build of Raspbmc though, there should be an update available (I am running on 3.10.24 built on 23rd of Dec which should be the latest Raspbmc version).
And firmware updates does not include kernel and linux version.
To check firmware version, run 'vcgencmd version’, latest is from Feb 17.
To try to force a Raspbmc update you can delete the version files, re-download the update script and reboot, but make sure you are on Frodo when you do that.

Thanks for clarification ! I´ll try to update on Frodo and then switching back to last testbuild.
1203 (Dec 03) kernel is the latest kernel for an updated install. 1223 kernel will only be installed with a fresh install or a forced kernel update. You can force a kernel update by deleting /scripts/upd_hist/kver and rebooting
If I have been of help, please add to my reputation as a way of saying thanks, it's free.
Ah, thanks Dilligaf.
forced kernel update worked like a charm !
Hi - firmware info shows:
[email protected]:~$ vcgencmd version
Feb 17 2014 21:35:01
Copyright © 2012 Broadcom
version f5c67bfc77e918b2c89a130bd2682dcab5903490 (clean) (release)

Problems on a lot of dvd's - I would say the same as before the problem was solved.

(2014-02-21, 17:17)miappa Wrote: @jjkongen
Working fine here and as far as I can see it should, with new firmware from 17th.
Working on all iso´s I have (which is not many though).
Perhaps a log + sample file can help, but please check both XBMC version and firmware version to make sure you are on latest on both.
(2014-02-19, 09:37)jeroenz Wrote: I've done some testing last night with this version, and encountered another troublesome DVD. This time it's a dutch chick-flick called 'Alles is Familie'.

I see the problem. I've done some debugging, but the failure is not in any Pi specific code.
CDVDInputStreamNavigator::Read() never returns because ProcessBlock() continually returns NAVRESULT_NOP.
Even when a stop message comes through it hangs because this thread is stuck.

Now as this isn't in Pi specific code I would expect (gotham) xbmc on other platforms to have the same issue.
Did you try playing this dvd on xbmc on pc?
Updated Gotham build, XBMC master from Feb 21 + newclock3 commits + one additional commit.

Some info:
• NC3: Same as last build
• Fix for WOA/WOL crash now in master
• Additional: Updated SQLite version

Firmware from 17th of Feb recommended (Update: Or later, new firmware from 21 Feb avilable.).
Firmware update, recommendations and additional testing (DVDPlayer etc.), see post #1

To install XBMC build, SSH to Pi:
cd .upgrade
wget -O xbmc-13-20140221-nc3.tar.gz http://goo.gl/xY0AfK --no-check-certificate
mkdir -p xbmc-13-20140221-nc3
pv xbmc-13-20140221-nc3.tar.gz | tar xzf - -C xbmc-13-20140221-nc3
cd xbmc-13-20140221-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
Activate new build in "Raspbmc Settings/Nightly…/Switch…”, choose new build + restart XBMC.
Tried with the new build today, updated the firmware - but this version also has big problems with dvd menus.
Log file: http://www.xbmclogs.com/show.php?id=135958

Then i switched back to 0214 - everything again worked as it should - menus both working in dvdplayer and omxplayer.
Logfile for this:

[email protected]:~$ vcgencmd version
Feb 21 2014 17:47:08
Copyright © 2012 Broadcom
version 67f299c3a92a793fb8b8efcaf94f7f553153f89a (clean) (release)
  • 1
  • 37
  • 38
  • 39(current)
  • 40
  • 41
  • 119

Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds15
This forum uses Lukasz Tkacz MyBB addons.