•   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 119
  •   
RaspBMC Kodi/XBMC test builds
(2014-03-13, 17:11)ElectricPim Wrote: You need also a new kernel. 3.10.32 (dpi-update)

I'm running 3.10.33+, dated Mar 7th...
Reply
How do you update kernel firmware? I run the update firmware in first page but that's for GPU?

On xbmc I get Linux 3.10.24, how is suppose to update to kernel 3.10.32? Rpi-update doesn't work in raspbmc, sorry for noob question, but I'm not understanding what update to make to get newer kernel.
Reply
Updated Gotham build, XBMC master from Mar 12 + newclock3 commits + additional commits.

Some info:
• NC3: [dvdplayer] Use inexact seeking like omxplayer
• NC3: [omxcodec] More care with dropping frames quickly
• NC3: Make use of TrueHD fastpath when downmixing (saves about 50% of the CPU required)
• NC3: New test for Airplay and IOS 7 clients
• Additional/SQLite: Updated SQLite version
• Additional/SQLite: Use mmap to accelerate SQLite file accesses
• Additional: Fix memory leakage in python bindings
• Additional: DVD various fixes related to libdvdnav issues and skip to menu

Firmware from March 12 included.
Recommendations, requirements and additional info (DVDPlayer etc.), see post #1

NB!
Firmware is now included in the build and installation process so no need to manually update firmware!
Also, you do not need to use Raspbmc settings to switch build, it will automatically switch build and reboot.

To install XBMC build, SSH to Pi:
Code:
wget -O xbmc-13-20140313-nc3.tar.gz http://goo.gl/uq3tuu --no-check-certificate
pv xbmc-13-20140313-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/xbmc-13-20140313-nc3/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/xbmc-13-20140313-nc3/xbmc-bcm /home/pi/.xbmc-current
cd /home/pi/.upgrade/xbmc-13-20140313-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
sudo reboot
Reply
Nice new script. I have a python script that logs into XBMC. Go to the last post of this thread. Regex the .gz file and link and do all this things that your new script does hehehe.
Image
Reply
Works perfect - THX - no Probs in Streams
Reply
(2014-03-13, 22:36)miappa Wrote: Updated Gotham build, XBMC master from Mar 12 + newclock3 commits + additional commits.

Some info:
• NC3: [dvdplayer] Use inexact seeking like omxplayer
• NC3: [omxcodec] More care with dropping frames quickly
• NC3: Make use of TrueHD fastpath when downmixing (saves about 50% of the CPU required)
• NC3: New test for Airplay and IOS 7 clients
• Additional/SQLite: Updated SQLite version
• Additional/SQLite: Use mmap to accelerate SQLite file accesses
• Additional: Fix memory leakage in python bindings
• Additional: DVD various fixes related to libdvdnav issues and skip to menu

Firmware from March 12 included.
Recommendations, requirements and additional info (DVDPlayer etc.), see post #1

NB!
Firmware is now included in the build and installation process so no need to manually update firmware!
Also, you do not need to use Raspbmc settings to switch build, it will automatically switch build and reboot.

To install XBMC build, SSH to Pi:
Code:
wget -O xbmc-13-20140313-nc3.tar.gz http://goo.gl/uq3tuu --no-check-certificate
pv xbmc-13-20140313-nc3.tar.gz | tar xzf - -C /home/pi/.upgrade
sudo cp /home/pi/.upgrade/xbmc-13-20140313-nc3/{fixup_x.dat,start_x.elf} /boot
ln -sfn /home/pi/.upgrade/xbmc-13-20140313-nc3/xbmc-bcm /home/pi/.xbmc-current
cd /home/pi/.upgrade/xbmc-13-20140313-nc3/xbmc-bcm/xbmc-bin/lib/xbmc/system
cp /usr/local/lib/libdvdcss.so.2.1.0 .
ln -sf libdvdcss.so.2.1.0 libdvdcss.so.2
ln -sf libdvdcss.so.2 libdvdcss.so
sudo reboot

shouldnt have the cd .upgrade in the begining as the previous scripts?
Reply
Nah, doesn´t matter.
I´ll keep the tarball outside the .upgrade directory and less lines in the instruction.
I also updated the delete instruction in post#1.

But it will work though so if you want to you can add it yourself.
Reply
For what I'm understanding of googleing it fixup_x.dat,start_x.elf is for firmware update of GPU.

But in Raspbmc I'm still stuck in kernel 3.10.24, for what I see is there no way of firmare update? Is necessary to someone make a custom kernel from original last one, right?

(2014-03-13, 23:16)miappa Wrote: Nah, doesn´t matter.
I´ll keep the tarball outside the .upgrade directory and less lines in the instruction.
I also updated the delete instruction in post#1.

But it will work though so if you want to you can add it yourself.

Yes, I made with cd .upgrade, because I thought it could be forgotten and worked well.
Next update I will use without the cd .upgrade Wink

Thanks for the excelent work!
Reply
As I have said before, I will not provide any kernel updates here, and no modifications (or as little as possible) to rootfs.
Do you need it though?
Reply
(2014-03-13, 23:24)miappa Wrote: As I have said before, I will not provide any kernel updates here, and no modifications (or as little as possible) to rootfs.
Do you need it though?

Sorry I didn't understood that, no problem. Probably isn't a easy thing to make?
If you can provide any kind of instructions or tutorial I can try to make one for me. To try to update to the latest Hexxeh kernel, right now is already 3.10.33 and on base raspbmc the latest is 3.10.24.

I already tryed the latest kernel 3.10.33 (https://github.com/Hexxeh/rpi-firmware/b...kernel.img), Raspbmc boots, but my keyboard doesn't work, for what I tested, so only with a custom kernel should all work correctly.
Reply
Not that easy if you want to compile your own version, no. You´ll need more things.
But as far as I know rpi-update should work, but I´ll leave that discussion to you and other users (see previous posts in this thread). Wink
But question remains, do you really need it?
Reply
(2014-03-13, 23:41)miappa Wrote: Not that easy if you want to compile your own version, no. You´ll need more things.
But as far as I know rpi-update should work, but I´ll leave that discussion to you and other users (see previous posts in this thread). Wink
But question remains, do you really need it?

For what i tried an checked in raspbmc page rpi-update is disabled in raspbmc... Will try to investigate more.
If brings any improvement to xbmc, it's a good thing to have, but if there's no improvement it's only a nice-to-have...

Also will check better changelog of kernel to see if is a thing that I would need or not.
Compiling in linux is still a new thing to me.

Thanks
Reply
So is RaspberryPi firmware upgrade required to run nightly builds?

I'm on:
Quote:[email protected]:~$ /opt/vc/bin/vcgencmd version
Dec 19 2013 20:51:48
Copyright © 2012 Broadcom
version 3b3def317b15e02d38376c1dff7013e75fc20670 (clean) (release)


I'm guessing the instructions here are still valid?

http://elinux.org/R-Pi_Troubleshooting#U...g_firmware

Based on the previous posts in this thread, I wonder if it's worth updating firmware if, say, the keyboard doesn't even work.

Thanks.
Reply
If you go for the latest build posted just recently the firmware is included.
But you will need some other stuff, see post#1.

Edit: It´s only the GPU firmware that needs updating, it does not affect anything else. And you will need it if you want to run these builds.
Reply
Thanks again miappa!!! I just wanted to clarify that before I hose my existing setup in an effort to fix some of the other issues I'm seeing. I'll give this a whirl and report back!
Reply
  •   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.