•   
  • 1
  • 59
  • 60
  • 61(current)
  • 62
  • 63
  • 119
  •   
RaspBMC Kodi/XBMC test builds
What can I say, it is the same PR... however, I do know that there is at least one commit left in the last build that now have been reverted (Sam´s announcement patch).
Maybe it has an influence, I don´t know, but it is gone from nc3 now so next build will be a little different.

It does work for me, but that is nothing new though. It has been working 100% since Sam´s patch was introduced (≈50/50 before that), it has to do something with network/router/zeroconf/settings etc. If it is placebo I must be the luckiest guy in the world Wink

Edit: Just realized that I didn´t tell the truth... I haven´t updated to 7.1.
Reply
I am seeing a strange version on my raspbmc after I updated to the latest build form here today xbmc-13-20140315.

It shows as XBMC 14 alpha 1 in the system info page.

Can anyone explain this to me please.

Cheers

Chris
Reply
(2014-03-16, 23:09)miappa Wrote: What can I say, it is the same PR... however, I do know that there is at least one commit left in the last build that now have been reverted (Sam´s announcement patch).
Maybe it has an influence, I don´t know, but it is gone from nc3 now so next build will be a little different.

It does work for me, but that is nothing new though. It has been working 100% since Sam´s patch was introduced (≈50/50 before that), it has to do something with network/router/zeroconf/settings etc. If it is placebo I must be the luckiest guy in the world Wink

Edit: Just realized that I didn´t tell the truth... I haven´t updated to 7.1.

Sam's announcement patch worked for me until I updated to 7.1. Hopefully next build then works the same ad build 10.
Reply
@sirhcjw
http://forum.xbmc.org/showthread.php?tid...pid1648465

@haegg78
I have updated to 7.1 myself now and will play around with it when I have time.
I´ll wait for popcornmix to rebase before I make a new build since Memphiz PR has been updated.
Reply
(2014-03-17, 12:49)miappa Wrote: I´ll wait for popcornmix to rebase before I make a new build since Memphiz PR has been updated.
Rebased.
Reply
@popcornmix, I think Memphiz PR has been updated too (see xbmc/network/Zeroconf.h), maybe it doesn´t matter(?).
Reply
(2014-03-17, 14:12)miappa Wrote: @popcornmix, I think Memphiz PR has been updated too (see xbmc/network/Zeroconf.h), maybe it doesn´t matter(?).

I deleted and reapplied latest version of Mephiz' PR when I rebased. Is it not correct?
Reply
I compared this to this and noticed a difference (edit: double checked as it was updated last night).
Did you pick it directly from Memphiz branch?
Reply
(2014-03-17, 15:03)miappa Wrote: I compared this to this and noticed a difference (edit: double checked as it was updated last night).
Did you pick it directly from Memphiz branch?

Could you point out the difference? They look the same to me...
Reply
Wow, do I feel stupid. It was cut off differently in the diff. :S
My apologies popcornmix...

I´ll try to push an updated build tonight.
Reply
(2014-03-17, 15:15)miappa Wrote: Wow, do I feel stupid. It was cut off differently in the diff. :S
My apologies popcornmix...

I´ll try to push an updated build tonight.
So if I'm skim reading correctly your current test build doesn't include the Airplay fix but the next one will ? I'm looking forward to trying that - the fix seemed to work for me on Mac OS. Smile

PS xbmc-13-20140311-nc3 has been working REALLY nicely for me...very fast and polished feeling, no problems at all.
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
It does include it, but there were at least one old patch that might have cause issues (now reverted).
Reply
Hmm. I've just gone from xbmc-13-20140311-nc3 which has been completely stable for me since the day it came out to xbmc-13-20140315-nc3 which crashes on me first time every time I boot.

Some time after the Pulse 8 CEC notification pops up but before the full home screen appears XBMC crashes returning to the "Relax XBMC will restart shortly" screen, the strange thing is when it restarts itself it launches ok the second time, however if I do a full reboot it will again crash the first time it tries to load after the reboot and succeed the second time.

I've looked at the debug log in the failed attempt and there are no obvious errors - the log just stops at the point where the crash occurs, when I compare it to the log from the second launch where it goes right through there is no obvious difference up until the point where the crash occurs. I've attached both logs below.

First XBMC launch after boot where it crashes back to the please relax screen:

http://paste.debian.net/88173/

Second XBMC launch after the please relax screen where it does finish loading:

http://paste.debian.net/88174/

After reverting back to xbmc-13-20140311-nc3 it is working normally on first boot again.
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
Crashen when:
Code:
14:15:23  42.035313 T:2735731776  NOTICE: PrimeWire: Service: Loading sqlite3 as DB engine
14:15:23  42.075954 T:2735731776  NOTICE: PrimeWire: Service: Resetting...
14:15:23  42.148483 T:2735731776  NOTICE: PrimeWire: Service starting...

Can you try to rename .xbmc to see if it is related to an addon?

Edit:
Wait... See discussion here (avahi): 4414 (PR)
Maybe this is the cause and the updated version will help. Wait until next build instead and test.
Reply
(2014-03-17, 16:49)miappa Wrote: Edit:
Wait... See discussion here (avahi): 4414 (PR)
Maybe this is the cause and the updated version will help. Wait until next build instead and test.
So you think the avahi daemon has not yet started when the relevant code in XBMC calls it, which triggers the bug ? And it doesn't crash the second time because the daemon has started by then ?

Is there an easy place in the raspbmc startup I can add a 10-15 second delay before launching XBMC to test this theory ?
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
  •   
  • 1
  • 59
  • 60
  • 61(current)
  • 62
  • 63
  • 119
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.4 Average



Logout Mark Read Team Forum Stats Members Help
RaspBMC Kodi/XBMC test builds4.415
This forum uses Lukasz Tkacz MyBB addons.