•   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
#91
(2013-12-09, 15:29)AddonScriptorDE Wrote:
(2013-12-06, 00:32)locoguano Wrote: Under Linux... Though I have Chrome set up to play Netflix and it works when just using the browser... when I launch from XBMC I get the "Wrong browser type" page.
(2013-12-07, 05:24)tymanthius Wrote:
(2013-12-06, 00:32)locoguano Wrote: Under Linux... Though I have Chrome set up to play Netflix and it works when just using the browser... when I launch from XBMC I get the "Wrong browser type" page.

I just installed, and I'm getting this also.
(2013-12-09, 07:45)jawilljr Wrote: Another Linux user...getting wrong browser and OS. If I close XBMC and open Chrome the user agent works.

Debug Log
To all linux/pipelight users: You need to change your user-agent! It's all mentioned on the pipelight homepage.
Please have a look at it. It doesn't really have anything to do with my addon. Thanks...
Easiest way should be to use an extension like this!

When using the "Use own user profile" setting in Chrome Launcher, you (of course) need to setup the user-agent for that profile, too.
For troubleshooting, you can disable kiosk mode via the (NetfliXBMC) addon settings...

I am using this User Agent, which is the recomended one from this FAQ. That FAQ is linked from here.

Below is the output from Pipelights Dignostic site.

Quote:Pipelight diagnostic:

Please select the Plugin you want to test:

User agent (Javascript)
Checking for Windows user agent ...okay
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1
Please note: not every user agent works on every site, try multiple ones if something doesn't work!

Silverlight (as seen by a website)
Checking for Silverlight ...okay
Version: 5.1.20513.0

Result
Result from all tests ...okay
You are ready to use Silverlight

Please use the RECOMMENDED User Agent.

As I said User Agent Switcher works if I close XBMC and manually Chrome browser. It does NOT work with your Addon.
Reply
#92
(2013-12-09, 19:20)Samz Wrote: Moved to XBMC just for this plugin, I'm confused on how to install this. All I get is the repository.addonscriptorde-beta.zip which contains an xml. Did install this via XBMC but don't see any difference.

Could someone guide on the steps to take to get this working?

Running on Windows

Thanks and apologies for noob question
Hi, i hope (and i'm sure) you will have a great time with xbmc. Smile
You need to install the zip via the xbmc addon manager.
Then, goto: System -> Add-ons -> Get Add-ons -> AddonScriptorDE's Testing Repo -> Video Add-ons -> NetfliXBMC -> Install.
If the repo is empty, try a "Force refresh" via the context menu (key 'c')...

(2013-12-09, 20:47)jawilljr Wrote:
(2013-12-09, 15:29)AddonScriptorDE Wrote:
(2013-12-06, 00:32)locoguano Wrote: Under Linux... Though I have Chrome set up to play Netflix and it works when just using the browser... when I launch from XBMC I get the "Wrong browser type" page.
(2013-12-07, 05:24)tymanthius Wrote: I just installed, and I'm getting this also.
(2013-12-09, 07:45)jawilljr Wrote: Another Linux user...getting wrong browser and OS. If I close XBMC and open Chrome the user agent works.

Debug Log
To all linux/pipelight users: You need to change your user-agent! It's all mentioned on the pipelight homepage.
Please have a look at it. It doesn't really have anything to do with my addon. Thanks...
Easiest way should be to use an extension like this!

When using the "Use own user profile" setting in Chrome Launcher, you (of course) need to setup the user-agent for that profile, too.
For troubleshooting, you can disable kiosk mode via the (NetfliXBMC) addon settings...

I am using this User Agent, which is the recomended one from this FAQ. That FAQ is linked from here.

Below is the output from Pipelights Dignostic site.

Quote:Pipelight diagnostic:

Please select the Plugin you want to test:

User agent (Javascript)
Checking for Windows user agent ...okay
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1
Please note: not every user agent works on every site, try multiple ones if something doesn't work!

Silverlight (as seen by a website)
Checking for Silverlight ...okay
Version: 5.1.20513.0

Result
Result from all tests ...okay
You are ready to use Silverlight

Please use the RECOMMENDED User Agent.

As I said User Agent Switcher works if I close XBMC and manually Chrome browser. It does NOT work with your Addon.
Okay, so the User-Agent itself is not the problem. Chrome has problems to remember it.
Some tips / possible reasons for this behavior (i mentioned before):
- Have you tried this extension? It's simple to setup and working fine here for me.
- Are you using the "Use own user profile" setting in Chrome Launcher? Then, Chrome gets launched with complete new settings. So you need to setup the User-Agent for this profile, too.
- Have you tried disabling kiosk mode (NetfliXBMC -> Settings -> Advanced)? Then, Chrome gets started normally so you can setup everything.
Reply
#93
(2013-12-10, 00:32)AddonScriptorDE Wrote:
(2013-12-09, 19:20)Samz Wrote: Moved to XBMC just for this plugin, I'm confused on how to install this. All I get is the repository.addonscriptorde-beta.zip which contains an xml. Did install this via XBMC but don't see any difference.

Could someone guide on the steps to take to get this working?

Running on Windows

Thanks and apologies for noob question
Hi, i hope (and i'm sure) you will have a great time with xbmc. Smile
You need to install the zip via the xbmc addon manager.
Then, goto: System -> Add-ons -> Get Add-ons -> AddonScriptorDE's Testing Repo -> Video Add-ons -> NetfliXBMC -> Install.
If the repo is empty, try a "Force refresh" via the context menu (key 'c')...

(2013-12-09, 20:47)jawilljr Wrote:
(2013-12-09, 15:29)AddonScriptorDE Wrote: To all linux/pipelight users: You need to change your user-agent! It's all mentioned on the pipelight homepage.
Please have a look at it. It doesn't really have anything to do with my addon. Thanks...
Easiest way should be to use an extension like this!

When using the "Use own user profile" setting in Chrome Launcher, you (of course) need to setup the user-agent for that profile, too.
For troubleshooting, you can disable kiosk mode via the (NetfliXBMC) addon settings...

I am using this User Agent, which is the recomended one from this FAQ. That FAQ is linked from here.

Below is the output from Pipelights Dignostic site.

Quote:Pipelight diagnostic:

Please select the Plugin you want to test:

User agent (Javascript)
Checking for Windows user agent ...okay
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1
Please note: not every user agent works on every site, try multiple ones if something doesn't work!

Silverlight (as seen by a website)
Checking for Silverlight ...okay
Version: 5.1.20513.0

Result
Result from all tests ...okay
You are ready to use Silverlight

Please use the RECOMMENDED User Agent.

As I said User Agent Switcher works if I close XBMC and manually Chrome browser. It does NOT work with your Addon.
Okay, so the User-Agent itself is not the problem. Chrome has problems to remember it.
Some tips / possible reasons for this behavior (i mentioned before):
- Have you tried this extension? It's simple to setup and working fine here for me.
- Are you using the "Use own user profile" setting in Chrome Launcher? Then, Chrome gets launched with complete new settings. So you need to setup the User-Agent for this profile, too.
- Have you tried disabling kiosk mode (NetfliXBMC -> Settings -> Advanced)? Then, Chrome gets started normally so you can setup everything.

#1: I would rather use the recommended User Agent Switcher,

#2: Neither setting (Use own profile) works.

#3: Neither setitng (whether Kisok mode is disabled or not) works
Reply
#94
Edit: Posted in wrong thread, I'm an idiot . . . .
Reply
#95
(2013-12-08, 08:20)hauntvictim Wrote:
(2013-12-07, 19:36)hstegeman Wrote: See post 1, you have to make use of the testing repo.

Yes, I did download the testing repo.... Still unable to launch the app

Figured out the force refresh issue. Have Chrome installed and the add-on installed, when I go to browse any episode however nothing happens when I select an episode. Any hints? Maybe I am over looking something?

(2013-12-10, 05:52)hauntvictim Wrote:
(2013-12-08, 08:20)hauntvictim Wrote:
(2013-12-07, 19:36)hstegeman Wrote: See post 1, you have to make use of the testing repo.

Yes, I did download the testing repo.... Still unable to launch the app

Figured out the force refresh issue. Have Chrome installed and the add-on installed, when I go to browse any episode however nothing happens when I select an episode. Any hints? Maybe I am over looking something?

Chrome isn't working for me on OSX but Safari is. Love the add-on going to play around with it tonight thanks man.
Reply
#96
v1.1.0:
- Fixed category "Viewing Activity" for multi-profile accounts

(2013-12-10, 03:43)jawilljr Wrote:
(2013-12-10, 00:32)AddonScriptorDE Wrote:
(2013-12-09, 20:47)jawilljr Wrote: I am using this User Agent, which is the recomended one from this FAQ. That FAQ is linked from here.

Below is the output from Pipelights Dignostic site.


Please use the RECOMMENDED User Agent.

As I said User Agent Switcher works if I close XBMC and manually Chrome browser. It does NOT work with your Addon.
Okay, so the User-Agent itself is not the problem. Chrome has problems to remember it.
Some tips / possible reasons for this behavior (i mentioned before):
- Have you tried this extension? It's simple to setup and working fine here for me.
- Are you using the "Use own user profile" setting in Chrome Launcher? Then, Chrome gets launched with complete new settings. So you need to setup the User-Agent for this profile, too.
- Have you tried disabling kiosk mode (NetfliXBMC -> Settings -> Advanced)? Then, Chrome gets started normally so you can setup everything.

#1: I would rather use the recommended User Agent Switcher,
From your linked post: "You can for example use the following ones..."
If you are not even trying my tips, i can't really help you. Sorry...

(2013-12-10, 03:43)jawilljr Wrote: #3: Neither setitng (whether Kisok mode is disabled or not) works
It must work this way! With disabled kiosk mode, Chrome gets normally started. You can then do everything:
Install/configure whatever extension you want to change the user-agent. Or change the user-agent in any other way. There are a lot.
Have you really tried to set it up with disabled kiosk mode?

It's working fine for me and multiple other users. So the problem can not be related to my addon...

(2013-12-10, 04:10)tymanthius Wrote: I have an issue, but I'm not sure if it's PleXBMC, Plex, or XBMC.

I'm running Ubuntu 12.04, PMS is on the same machine as XBMC.

I set XBMC to use user profiles, then created one for me, my wife, and my daughter. Set each one to use their own Plex account. But Plex doesn't seem to register watched status for anyone but me (mine is the main plex account for this PMS).

So they get no resume of stopped shows, and the unwatched list doesn't populate across to other clients.

I have auth on local networks set up.

Any ideas?
Sorry, i never used Plex/PleXBMC and don't really know anything about it.
I just tested different XBMC profiles connected to different Netflix profiles, and it's working fine.
"My List" is showing up and continuing shows is also working.

Only thing i noticed is that the category "Viewing Activity" was not working with multiple accounts. Fixed it.

(2013-12-10, 05:52)hauntvictim Wrote: Chrome isn't working for me on OSX but Safari is. Love the add-on going to play around with it tonight thanks man.
Mm, no message appears? Does starting Chrome via Chrome Launcher (standalone) work for you?
And you installed Chrome to the default "Applications" folder?

Just wondering because i would prefer using Chrome because of the kiosk (fullscreen) mode.
But nice it's working for you somehow...
Reply
#97
I'm having the same issues with Linux and Chrome, the user agent doesn't work when launching from XBMC. However, if from the error page I navigate to any content in Netflix in the same kiosk mode browser window, it works smoothly. Just the page opening directly from XBMC doesn't work. Disabling kiosk mode doesn't help.

After importing a tv show into the library, in the list of all the episodes, would it be possible to get the check marks for episodes already watched?

Thanks for the great Add-on!
Reply
#98
(2013-12-10, 19:07)plait Wrote: I'm having the same issues with Linux and Chrome, the user agent doesn't work when launching from XBMC. However, if from the error page I navigate to any content in Netflix in the same kiosk mode browser window, it works smoothly. Just the page opening directly from XBMC doesn't work. Disabling kiosk mode doesn't help.
Okay, strange! Thanks for the detailed info. Now we know it's some other mysterious problem.
Sounds like the User-Agent does not get changed quick enough. Please try other addons/extensions or any other manual way the change the UA.
Maybe not all addons/extensions do it same way / at the same time. If you don't get it running with any other addon/extension/whatever, you can try some dirty workaround:
Disable the single-user account setting (even if you only have one profile). Then, another url is opened before the actual playback. Maybe it will then work for you.
If this is working, we know what causes the problem and how to bypass it, so i can try to find a better solution.

(2013-12-10, 19:07)plait Wrote: After importing a tv show into the library, in the list of all the episodes, would it be possible to get the check marks for episodes already watched?
I had a look at the episode listing again, and it's possible to get the watched state for each epsiode.
But, as far as i know, it's not possible to pass it when adding videos to the library.
Reply
#99
AddonScriptorDE...I think I found the problem, or at least hopefully a solution to help make it work in Linux.

When I run try to watch a movie with chrome from the command line as follows:

Code:
google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --kiosk "http://movies.netflix.com/WiPlayer?movieid=60031686"

Even though I have my useragent working...Chrome comes back with the Wrong/Browser error. But this works:

Code:
/usr/bin/google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --user-agent="Mozilla/5.0 --kiosk (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1" --kiosk "http://movies.netflix.com/WiPlayer?movieid=60031686"

Netflix played the movie "Christmas Vacation" right away.

The only parameter I added was the "user-agent" parameter.

I also tired the second command line with my useragent switcher disabled and it worked

I also noticed that you have a userAgent defined in 'default.py' for the netflixbmc addon.

Code:
userAgent = "Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0"

Maybe you can change the function 'getFullPath()' in the Chrome Launcher addon to accept a useragent? I'd change it myself, but I have a very limited knowledge of Python.

Hope this helps
Reply
(2013-12-10, 05:52)hauntvictim Wrote: Chrome isn't working for me on OSX but Safari is. Love the add-on going to play around with it tonight thanks man.
Mm, no message appears? Does starting Chrome via Chrome Launcher (standalone) work for you?
And you installed Chrome to the default "Applications" folder?

Just wondering because i would prefer using Chrome because of the kiosk (fullscreen) mode.
But nice it's working for you somehow...
[/quote]

Yes, using Chrome via the Launcher works for kiosk mode. I do get an "unsupported bowser message".
Also as you do updates do we need to re-download the repo and install it? Just curious.
Reply
v1.1.1:
- Added custom User-Agent parameter on linux when launching chrome

(2013-12-11, 05:59)jawilljr Wrote: AddonScriptorDE...I think I found the problem, or at least hopefully a solution to help make it work in Linux.

When I run try to watch a movie with chrome from the command line as follows:

Code:
google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --kiosk "http://movies.netflix.com/WiPlayer?movieid=60031686"

Even though I have my useragent working...Chrome comes back with the Wrong/Browser error. But this works:

Code:
/usr/bin/google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --user-agent="Mozilla/5.0 --kiosk (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1" --kiosk "http://movies.netflix.com/WiPlayer?movieid=60031686"

Netflix played the movie "Christmas Vacation" right away.

The only parameter I added was the "user-agent" parameter.

I also tired the second command line with my useragent switcher disabled and it worked

I also noticed that you have a userAgent defined in 'default.py' for the netflixbmc addon.

Code:
userAgent = "Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0"

Maybe you can change the function 'getFullPath()' in the Chrome Launcher addon to accept a useragent? I'd change it myself, but I have a very limited knowledge of Python.

Hope this helps
Thanks! Smile This is really strange. I already tried this before, but it had no effect on me. Also tested with:
Code:
google-chrome --user-agent="TEST" "http://whatsmyuseragent.com/"
But the default UA was shown. I also deactivated my User-Agent extension, but still no luck.

I now did some more testing because of your reported success with it. Found some possible reason/solution. But also had no luck with the suggested "--single-process" parameter.
I tested it on another system - and it WORKED! Smile
Then started troubleshooting: I deinstalled the UA extension - no success. Deinstalled the only other extension (some proxy thing) - and it WORKED there too.

Thanks again for mentioning it - i would never have tried it again. I hope the addon is now working fine for you too.
New Linux/Pipelight/UserAgent instructions...

(2013-12-11, 06:35)hauntvictim Wrote:
(2013-12-11, 06:35)addonscriptorde Wrote:
(2013-12-10, 05:52)hauntvictim Wrote: Chrome isn't working for me on OSX but Safari is. Love the add-on going to play around with it tonight thanks man.
Mm, no message appears? Does starting Chrome via Chrome Launcher (standalone) work for you?
And you installed Chrome to the default "Applications" folder?

Just wondering because i would prefer using Chrome because of the kiosk (fullscreen) mode.
But nice it's working for you somehow...

Yes, using Chrome via the Launcher works for kiosk mode. I do get an "unsupported bowser message".
Chrome should be official supported on OSX. I changed something in v1.1.1, maybe it's now working for you too.
Or do you have some User-Agent changing extension running under OSX for some reason?

(2013-12-11, 06:35)hauntvictim Wrote: Also as you do updates do we need to re-download the repo and install it? Just curious.
No, you don't need to do anything. Thats the reason for a repo: The addons get updated automatically...
Reply
hauntvictim,

OK, I installed YOUR recommended user agent switcher. How do you set it up to work with Netflix? I always keep getting this error code:

Quote:Error Code: N8109

That is without XBMC running, in other words only using Chrome.

In my opinion, all that is needed to be done is to modify the below function:

Code:
def getFullPath(path, url, useKiosk, userAgent):
    profile = ""
    if useOwnProfile:
        profile = '--user-data-dir="'+profileFolder+'" '
    kiosk = ""
    if useKiosk=="yes":
        kiosk = '--kiosk '
    if userAgent:
        userAgent = '--user-agent="'+userAgent+'" '
    return '"'+path+'" '+profile+userAgent+'--start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run '+kiosk+'"'+url+'"'

so that it returns the below string:

Code:
/usr/bin/google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --user-agent="Mozilla/5.0 --kiosk (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1" --kiosk "http://movies.netflix.com/WiPlayer?movieid=60031686"

In other words add the --user-agent parameter to the 'return' statement.

I would modify the code, but I am busy the next two days, and my Python experience is limited. If the addons were written in 'C' that might be different..LOL
Reply
hauntvictim

Please disregard my last post...I didn't notice that you already added a useragent string to the function...sorry.

BTW it seems to work better. Will test more.

Thanx!!
Reply
Hi,

Love the plugin! Have been using the Windows 8 Netflix app and launching it using an AutoHotKey script from inside XBMC until now. This is a far nicer approach.

Unfortunately, I'm getting a plugin failed error when I go to play an episode. After the error chrome loads up in Kiosk mode just fine. I think it's related to the Windows Utility you included as it's not properly focusing the Netflix window (I have to click to make it focus) and the cursor isn't hidden.

System:
Windows 8.1 Pro
XBMC 12.2 Frodo

I THINK this is the error but not sure what it means:

Code:
4:15:35 T:1832   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.WindowsError'>
                                            Error Contents: [Error 193] %1 is not a valid Win32 application
                                            Traceback (most recent call last):
                                              File "C:\Users\Michael Smith\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 665, in <module>
                                                playVideo(url)
                                              File "C:\Users\Michael Smith\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 375, in playVideo
                                                subprocess.Popen(utilityPath, shell=False)
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\subprocess.py", line 623, in __init__
                                                errread, errwrite)
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\subprocess.py", line 833, in _execute_child
                                                startupinfo)
                                            WindowsError: [Error 193] %1 is not a valid Win32 application
                                            -->End of Python script error report<--

Any help in getting this fixed would be great!

Thanks,

Mike
Reply
v1.1.2:
- Added xdotool (Linux) & cliclick (OSX) integration
- Windows: Default controls are now also mappable via the Control Utility
v1.1.3:
- Fixed NetfliXBMC_Utility.exe for 32Bit systems
v1.1.4:
- Fixed "Use Control Utility" setting

If you have xdotool (Linux) / cliclick (OSX) installed, the mouse gets hidden and the silverlight player focused so you need no mouse anymore.

(2013-12-12, 16:34)mcs347 Wrote: Hi,

Love the plugin! Have been using the Windows 8 Netflix app and launching it using an AutoHotKey script from inside XBMC until now. This is a far nicer approach.

Unfortunately, I'm getting a plugin failed error when I go to play an episode. After the error chrome loads up in Kiosk mode just fine. I think it's related to the Windows Utility you included as it's not properly focusing the Netflix window (I have to click to make it focus) and the cursor isn't hidden.

System:
Windows 8.1 Pro
XBMC 12.2 Frodo

I THINK this is the error but not sure what it means:

Code:
4:15:35 T:1832   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.WindowsError'>
                                            Error Contents: [Error 193] %1 is not a valid Win32 application
                                            Traceback (most recent call last):
                                              File "C:\Users\Michael Smith\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 665, in <module>
                                                playVideo(url)
                                              File "C:\Users\Michael Smith\AppData\Roaming\XBMC\addons\plugin.video.netflixbmc\default.py", line 375, in playVideo
                                                subprocess.Popen(utilityPath, shell=False)
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\subprocess.py", line 623, in __init__
                                                errread, errwrite)
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\subprocess.py", line 833, in _execute_child
                                                startupinfo)
                                            WindowsError: [Error 193] %1 is not a valid Win32 application
                                            -->End of Python script error report<--

Any help in getting this fixed would be great!

Thanks,

Mike
Hi, you're right.
The error is related to the Control Utility. I now compiled it for 32Bit systems - please try if it's now working for you...
Reply
  •   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.