•   
  • 1
  • 51
  • 52
  • 53(current)
  • 54
  • 55
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
Posting this here for future reference and anyone who might find it useful. It helped me fix my audio issues with chrome:

http://www.avidandrew.com/watch-hulu-ama...linux.html

I haven't tried any of the other plugins yet or netflix desktop, but those aspects of the article seem interesting too.
Reply
(2014-08-19, 16:26)jadel Wrote: Nice, I wonder if this would be possible on openelec.
If I had that with remote control it would be great.

Yip - same here.

Any idea if this works (well) on OpenELEC?

I'd like to simply add the HTML5 package to my setup.
Reply
anyone had success using windows + this addon + unified remote?

maybe even xbmc remote?

Can't make them to work together Sad
Reply
(2014-09-02, 01:58)kieppie Wrote:
(2014-08-19, 16:26)jadel Wrote: Nice, I wonder if this would be possible on openelec.
If I had that with remote control it would be great.

Yip - same here.

Any idea if this works (well) on OpenELEC?

I'd like to simply add the HTML5 package to my setup.

OpenELEC doesn't ship with a web browser. I've seen one plugin that provides chromium support... I assume the browser is packaged with the addon. If that were re-purposed with chrome beta, then you could, conceivably, use this plugin on openelec.
Reply
Anyone using this with OSX? Running chrome beta and html 5 streaming is working great (much improved as non hardware accelerated silver light was too much for my mac mini).









However, it no longer seems to focus on chrome, although the video plays and loads properly, cmd+Q now seems to quit/crash the non focused xbmc - which is very weird.
Reply
Linux, Chrome unstable and html5 works fine. But I noticed that videos are bit choppy. By enabling fps display in Chrome I see that many of the videos are 24fps so I set the refresh rate with xrandr to 24 and now it is much smoother.

To automate it I added xrandr in the script:

Code:
$ diff -Naur default.py.orig default.py
--- default.py.orig    2014-09-03 14:04:57.465665937 +0300
+++ default.py    2014-09-03 11:56:11.288390330 +0300
@@ -455,6 +455,7 @@
         xbmc.executebuiltin("RunPlugin(plugin://plugin.program.chrome.launcher/?url="+urllib.quote_plus(url)+"&mode=showSite&kiosk="+kiosk+"&userAgent="+urllib.quote_plus(userAgent)+")")
         try:
             xbmc.sleep(5000)
+            subprocess.Popen('env DISPLAY=:0 /usr/bin/xrandr --output HDMI-0 --mode 1920x1080 --refresh 24', shell=True)
             subprocess.Popen('xdotool mousemove 9999 9999 click 1', shell=True)
             if linuxFullscreen:
                 subprocess.Popen('xdotool key f', shell=True)

If I wan't to return it back to 60Hz after Chrome is closed, where should I put it in?
Does netflix api show anywhere the fps so refresh rate could be passed to xrandr?
Or could the FPS be get from Chrome somehow while playing the video?
Reply
Running 1.2.9 I'm getting regular script errors like these:

17:08:08 T:6584 ERROR: Control 50 in window 10025 has been asked to focus, but it can't
17:08:10 T:2612 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'urllib2.URLError'>
Error Contents: <urlopen error [Errno 11004] getaddrinfo failed>
Traceback (most recent call last):
File "C:\Users\user\AppData\Roaming\XBMC\addons\plugin.video.netflixmbc\default.py", line 918, in <module>
index()
File "C:\Users\user\AppData\Roaming\XBMC\addons\plugin.video.netflixmbc\default.py", line 94, in index
if login():
File "C:\Users\user\AppData\Roaming\XBMC\addons\plugin.video.netflixmbc\default.py", line 539, in login
content = opener.open(urlMain+"/Login").read()
File "C:\Program Files (x86)\XBMC\system\python\Lib\urllib2.py", line 404, in open
response = self._open(req, data)
File "C:\Program Files (x86)\XBMC\system\python\Lib\urllib2.py", line 422, in _open
'_open', req)
File "C:\Program Files (x86)\XBMC\system\python\Lib\urllib2.py", line 382, in _call_chain
result = func(*args)
File "C:\Program Files (x86)\XBMC\system\python\Lib\urllib2.py", line 1214, in http_open
return self.do_open(httplib.HTTPConnection, req)
File "C:\Program Files (x86)\XBMC\system\python\Lib\urllib2.py", line 1184, in do_open
raise URLError(err)
URLError: <urlopen error [Errno 11004] getaddrinfo failed>
-->End of Python script error report<--
17:08:10 T:6584 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.netflixbmc/
17:08:10 T:6584 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.netflixbmc/) failed
Reply
(2014-04-15, 23:52)Dixon Butz Wrote:
(2014-04-15, 21:27)ullms Wrote:
(2014-04-15, 03:11)Dixon Butz Wrote: Nope. With WASAPI on I get error code N8157-3142
Works with direct sound fine.

WASAPI works but you have to turn off "Keep Audio Device Alive" under Audio settings. Had that issue also until I turned that off.

Good catch thx!

In my case, I still got that error, even with "Keep Audio Device Alive" unchecked. It only worked when I changed Audio Output Device to DirectSound, while leave Passthrough as WASAPI.

NOTE: this is with IE 11 on Win 7, not Chrome. I will try it tomorrow with Chrome.
Reply
It seems that this PlugIn doesn't work with a german Netflix Account.
It always replys "You are not logged in. Check your credentials and/or restart the addon!"

Can anyone confirm this?

..::edit::.. Here is an logfile, if needed: http://pastebin.com/xm62XESt
Reply
Wink 
Today Netflix started in Germany.

I'am running XBMCbuntu and after some hours of testing, i got netflix germany working!

I have only two problems:

a) i have no sound in chrome (my only audio device is an spdif out)
b) i use an mce remote to control xbmc. is there a way to add an xdotool mapping for pressing "stop" on the remote mapped to alt+f4?

Thx.
Reply
(2014-09-16, 23:31)CyberLine Wrote: I'am running XBMCbuntu and after some hours of testing, i got netflix germany working!
How? Is there even any special configuration necessary?
Need help? Check out my XBMC Frodo Guide. It contains full featured guides to Sickbeard and CouchPotato as well.

Image
Reply
(2014-09-16, 14:29)CM000n Wrote: It seems that this PlugIn doesn't work with a german Netflix Account.
It always replys "You are not logged in. Check your credentials and/or restart the addon!"

Can anyone confirm this?

I have a US Netflix account but live in Germany. I used the plugin to access German Netflix yesterday with no issues. No special configuration is necessary, although you should make sure you have the correct "language" value (mine is "en-DE") in the settings.xml file.
Reply
I also can confirm that Netflix Germany works without any changes to the addon.

But got some problems with my XBMCbuntu and Netflixbmc. The Videos does start and plays fine. Problem is, there is no sound and the video is only in the upper left corner of the screen.

Openbox start's with chrome-launcher so it should be full screen.

Also my Remote doesn't do anything. It still focuses XBMC. I'm useing the Hama MCE Remote with the eventclient programm.

Any ideas to get this working? I'd love to change sky with netflix Smile

Too bad most Videostreaming sites don't offer propper linux support, or even better plugins for XBMC...
cd /pub/ && cat Beer
Reply
Mhm... I don't get it to work. Installed and configured it, it launches okay - but as soon as I try to access any kind of content, it just keeps hanging on "Working". This occurs everywhere - it doesn't matter if I click on "HD Movies", "Genres" (I can advance to the genre list, but as soon as I select a genre, xbmc/kodi hangs itself up), "All Movies", etc. - it just keeps on showing "Working". If I try to cancel this, XBMC/Kodi crashes.
Need help? Check out my XBMC Frodo Guide. It contains full featured guides to Sickbeard and CouchPotato as well.

Image
Reply
Having a strange problem. I've searched this entire thread but haven't found anyone else having it.

I've got the add-on installed and working with Chrome on my Windows system. I can use my Logitech Harmony remote to play, pause, skip ahead, skip back... but I can't QUIT the playback. The "Back" button does nothing. The only way to stop it is by hitting Numpad-0 on my keyboard (the default exit key).

I tried the "Control Utility" but clicking the button does absolutely nothing. No editor launches, nothing happens.

How do I manually edit the default keys to reassign them to the basic MCE remote keys instead?
Reply
  •   
  • 1
  • 51
  • 52
  • 53(current)
  • 54
  • 55
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.