•   
  • 1
  • 63
  • 64
  • 65(current)
  • 66
  • 67
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-08-15, 00:53)Milhouse Wrote: New OpenELEC Helix build: #0814
[

I updated to this from a 6 week old Milhouse helix build - this one crashes XBMC every time as soon as I hit Play when using Spotify on an Ipad (IOS7) and AirPlay. The old version worked fine about 95% of the time (5% - wouldn't play anything until rebooted, usualy after hitting pause).

I have debug enabled for xbmc.log and just get this:

12:13:03 7983.183105 T:2856318032 ERROR: DeleteFile - cant delete file </storage/.xbmc/temp/airtunes_album_thumb.jpg>. trying lower case </storage/.xbmc/temp/airtunes_album_thumb.jpg>
12:13:03 7983.187012 T:2856318032 DEBUG: CAnnouncementManager - Announcement: OnVolumeChanged from xbmc
12:13:03 7983.187500 T:2856318032 DEBUG: GOT ANNOUNCEMENT, type: 64, from xbmc, message OnVolumeChanged


That jpg file doesn't exist.

Any ideas?

Thanks,

Paul
http://netlir.dk/rbej/builds/MilhouseVH/...01188d.tar works. Testing which build breaks it..
http://netlir.dk/rbej/builds/MilhouseVH/...c12231.tar - fail

http://netlir.dk/rbej/builds/MilhouseVH/...720ff6.tar - works

http://netlir.dk/rbej/builds/MilhouseVH/...49048a.tar - works


So something broke between 1208 and 1308.

Cheers,

Paul
regarding newclock4 build #0813b. How can I force using dvdplayer?

I have an ISO of a DVD (including menu etc.) that starts playing in 4:3 instead of 16:9. However, when I STOP (not PAUSE) and resume it, it plays in 16:9: I suppose dvdplayer is used at start and omxplayer when resumed. I have made a sample of the movie, but how can I force openelec to use dvdplayer to play it?
(2014-08-15, 06:58)whiffyfuzzball Wrote: I updated to this from a 6 week old Milhouse helix build - this one crashes XBMC every time as soon as I hit Play when using Spotify on an Ipad (IOS7) and AirPlay. The old version worked fine about 95% of the time (5% - wouldn't play anything until rebooted, usualy after hitting pause).

I think this PR causes it. I've commented on the PR. We'll see what author thinks.
(2014-08-15, 12:20)Bohlendach Wrote: regarding newclock4 build #0813b. How can I force using dvdplayer?

I have an ISO of a DVD (including menu etc.) that starts playing in 4:3 instead of 16:9. However, when I STOP (not PAUSE) and resume it, it plays in 16:9: I suppose dvdplayer is used at start and omxplayer when resumed. I have made a sample of the movie, but how can I force openelec to use dvdplayer to play it?

Bring up codec info ('o' key).
If the codec is like "omx-mpeg2" then you are using omxplayer.
If the codec is like "mmal-mpeg2" then you are using dvdplayer with hardware acceleration
If the codec is like "ff-mpeg2" then you are using dvdplayer with software decode.

If you go to settings/video/acceleration you can disable "auto" and either enable or disable "omxplayer" to force a specific player.

But, if you believe the behaviour is incorrect (with either player), then post the sample and I'll investigate it.
(2014-08-15, 12:30)popcornmix Wrote:
(2014-08-15, 12:20)Bohlendach Wrote: regarding newclock4 build #0813b. How can I force using dvdplayer?

I have an ISO of a DVD (including menu etc.) that starts playing in 4:3 instead of 16:9. However, when I STOP (not PAUSE) and resume it, it plays in 16:9: I suppose dvdplayer is used at start and omxplayer when resumed. I have made a sample of the movie, but how can I force openelec to use dvdplayer to play it?

Bring up codec info ('o' key).
If the codec is like "omx-mpeg2" then you are using omxplayer.
If the codec is like "mmal-mpeg2" then you are using dvdplayer with hardware acceleration
If the codec is like "ff-mpeg2" then you are using dvdplayer with software decode.

If you go to settings/video/acceleration you can disable "auto" and either enable or disable "omxplayer" to force a specific player.

But, if you believe the behaviour is incorrect (with either player), then post the sample and I'll investigate it.

It seems that the problem is when going from the menu to play the movie. I have send a PM with a link to the file. Same behaviour with omxplayer 'on' or 'off'.

I do not have a keyboard attached to my raspberry pi, and the 'o'-key on the xbmc-remote-keyboard (iPad) don't do the trick.
(2014-08-15, 13:32)Bohlendach Wrote: It seems that the problem is when going from the menu to play the movie. I have send a PM with a link to the file. Same behaviour with omxplayer 'on' or 'off'.

Thanks. It matches PC xbmc behaviour in initial menu, but when movie starts playing it appears to be 4:3 (on pi) rather than 16:9 (on PC). Will investigate.

EDIT:
Okay, think I've got a fix - may sure you test next newclock4 build.
(2014-08-15, 05:43)steve1977 Wrote: Ok, so the Helix "fix" is only for the treatment of mysql?

No, I'm just making the point that if you are using MySQL (ie. a shared database) then you can't so easily mix builds using different db schemas as one client will be using v89 and the other(s) v88, so updates to v88 won't be seen by v89 and vice versa.

Of course if you understand the consequences and don't mind then sure, you can mix & match clients with different schemas while using MySQL. Eventually when you upgrade your v88 clients to v89 all will be good again.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Great, downloading your latest image now and will give it a go. Will the Amber skin okayish work or do I now have to switch back to Confluence?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
(2014-08-15, 15:58)steve1977 Wrote: Great, downloading your latest image now and will give it a go. Will the Amber skin okayish work or do I now have to switch back to Confluence?

You'll have to let us all know on that one, as I don't use Amber (using stock Confluence makes life so much simpler, if a little less flashy!)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Amber works fine. I've been using it for as long as I can remember.
PVR windows will be broken in almost any skin. I know none that does yet support the new PVR window rewrite in Helix (besides confluence ofc)
Will keep you updated on the skin.

Unfortunately, something went wrong when updating. I copied the tar file into the update folder and restarted. It executed the update, but now I am stuck with the Kodi 14.0 Helix splash screen. It gets there, but then doesn't do anything anymore.

I can re-install Gotham from backup or just with a fresh install. Any other ideas or suggestions?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
(2014-08-15, 16:58)steve1977 Wrote: I can re-install Gotham from backup or just with a fresh install. Any other ideas or suggestions?

It would be great if you could debug the issue. Maybe it's hanging on a network connection, or taking a while as it upgrades the databases - check what progress there is in /storage/.xbmc/temp/xbmc.log.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 63
  • 64
  • 65(current)
  • 66
  • 67
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.