•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 20
  •   
[AirPlay][Warning] Don't update to iOS8 if you want AirPlay
(2014-11-15, 22:36)flobor Wrote: I've installed kodi 14beta2 for windows on my Windows 8.1 system, but airplay doesn't work.
I test differents apps on my iphone 6 IOS 8.1 :
netflix apps : nothing happen when i switch to kobi airplay
youtube : nothing happen when i switch to kobi airplay
other video apps : kobi play video, i have no sound and a black screen with noise video.
I think you need to read back through the thread a few pages before asking the same questions everyone has already asked many times which have been answered many times.

Youtube and Netflix are known not to work and will never work in the foreseeable future, although for different reasons.

Kobi I've never heard of. You need to test apps that are known to support non-DRM video playback. One example I can give is video podcasts playing from Instacast, which does work. Another is youtube through Safari.
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
(2014-10-27, 12:07)Memphiz Wrote: Ha that testbuild is missing the srcvers by accident if you ask me. DBMandrake can you verify that this change really speeds up video target detection?
Finally got a chance to try this. Can't detect any difference I'm afraid, either for better or worse. Sad

Now granted I didn't try the actual oct 5th build - what I did was remove the srcvers variable from the announcement on my existing 13.2 custom build so that the only thing that has changed from my current setup is that one variable. I think you'll agree that any difference in detection must be in the announcement as both Gotham and Helix have the same 10 second refresh, correct ?

What I did notice is that whether it is detected as video immediately or not is highly erratic in the first place. I have both a Mac running my 13.2 build, and a Raspberry Pi on the network running the latest Raspbmc which has the 0xF7 fix in it - both broadcasting the exact same announcements, and before I even made any changes to srcvers I noticed that most of the time the Mac was immediately being detected as video while the Pi was detected as audio for up to 10 seconds.

This was on two iOS 8 devices even after they were rebooted with wifi turned off. Then for no good reason the Mac then started being detected as audio for up to 10 seconds. After removing srcvers I saw instances of both instant video detection and slow video detection...

So I have to wonder whether AussieFries switched back and forth between the two test builds multiple times and tested a sufficient number of times on each (including rebooting iOS devices) to draw a firm conclusion, as my results for speed of detection as video were very erratic with or without srcvers...

The Pi was never detected as video immediately but the Mac often was even with identical announcements. Perhaps a small difference in the refresh behaviour between Apple's Bonjour and Avahi ?
Kodi 18.3 - Mid 2007 Mac Mini, 4GB, 2TB HD, Windows 7 SP1
Kodi 18.3 - Vero4k, Raspberry Pi 2. OSMC.
Reply
(2014-11-16, 00:11)DBMandrake Wrote: ...So I have to wonder whether AussieFries switched back and forth between the two test builds multiple times and tested a sufficient number of times on each (including rebooting iOS devices) to draw a firm conclusion, as my results for speed of detection as video were very erratic with or without srcvers...

The Pi was never detected as video immediately but the Mac often was even with identical announcements. Perhaps a small difference in the refresh behaviour between Apple's Bonjour and Avahi ?

First of all thank you very much for your time and efforts to test Kodi versions with and without srcvers.

I have used the Oct 5th build for a considerable amount of time on a daily basis and I noticed its AirPlay availability behavior seemed more consistent than that of later builds. To me it seemed running multiple Kodi instances (not necessarily simultaneously) on the network makes AirPlay availability even more erratic and so I haven't tested both setups the way you describe it.

Whatever caused the difference, I'm a happy Kodi 14 Beta 2 user now. DBMandrake and Memphiz, thanks again for your great work!
Reply
Hello,

following the kodi.log:

kodi.log

Hopefully this will help to find the issue.

Thanks
kaminkehrer

Hello,

following a small extract from the kodi.log:

regards
kaminkehrer

Quote:...
T:140385433077888 INFO: AIRPLAY: Cleaning up photoassetcache
13:32:02 T:140385433077888 INFO: AIRPLAY Server: Successfully initialized
13:32:02 T:140384608966400 DEBUG: CZeroconfAvahi::doPublishService identifier: servers.jsonrpc-tpc type: _xbmc-jsonrpc._tcp name:Kodi (vdrmb2) port:9090
13:32:02 T:140384625751808 DEBUG: CZeroconfAvahi::doPublishService identifier: servers.airplay type: _airplay._tcp name:Kodi (vdrmb2) port:36667
13:32:02 T:140384160184064 NOTICE: Thread TCPServer start, auto delete: false
13:32:02 T:140384151791360 NOTICE: Thread AirPlayServer start, auto delete: false
13:32:02 T:140384608966400 DEBUG: CZeroconfAvahi::addService() named: Kodi (vdrmb2) type: _xbmc-jsonrpc._tcp port:9090
13:32:02 T:140384625751808 DEBUG: CZeroconfAvahi::addService() named: Kodi (vdrmb2) type: _airplay._tcp port:36667
...
Reply
I am dearly missing the video element of airplay with my current (XBMC Gotham 13.1) build (windows 7). :-( iOS 8.1

Can anyone recommend a platform/version where it's all working OK? I would even consider making my PC dual-boot and installing OpenElec of some kind if it works..
My band - www.myspace.com/seabasskid
My systems - MEDIASERVER: ASRock 330, 1.6GHz DualCore Atom, GeForce9400 ION, 2GB ram
STAND-ALONE: Raspberry Pi2 MODEL B, OSMC Kodi15.2 compiled: Sept 27th 2015
XboxLive Gamertag - SkillipEvolver
Reply
Hello,

and last extract from config:
Quote:...
vdrmb2 userdata # grep irplay *
grep: Database: Is a directory
grep: PictureIcon: Is a directory
grep: Thumbnails: Is a directory
grep: addon_data: Is a directory
guisettings.xml: <airplay>true</airplay>
guisettings.xml: <airplayios8compat default="true">true</airplayios8compat>
guisettings.xml: <airplaypassword default="true"></airplaypassword>
guisettings.xml: <airplayvolumecontrol default="true">true</airplayvolumecontrol>
guisettings.xml: <useairplaypassword default="true">false</useairplaypassword>
grep: keymaps: Is a directory
grep: library: Is a directory
grep: peripheral_data: Is a directory
grep: playlists: Is a directory
...

Quote:...
vdrmb2 settings # grep irplay *
settings.xml: <category id="airplay" label="1273" help="36602">
settings.xml: <setting id="services.airplay" type="boolean" label="1270" help="36343">
settings.xml: <setting id="services.airplayvolumecontrol" type="boolean" parent="services.airplay" label="1269" help="36541">
settings.xml: <dependency type="enable" setting="services.airplay">true</dependency>
settings.xml: <setting id="services.useairplaypassword" type="boolean" parent="services.airplay" label="1272" help="36344">
settings.xml: <dependency type="enable" setting="services.airplay">true</dependency>
settings.xml: <setting id="services.airplaypassword" type="string" parent="services.useairplaypassword" label="733" help="36345">
settings.xml: <dependency type="enable" setting="services.useairplaypassword">true</dependency>
settings.xml: <setting id="services.airplayios8compat" type="boolean" parent="services.airplay" label="1268" help="36549">
settings.xml: <dependency type="enable" setting="services.airplay">true</dependency>
...

Regards
kaminkehrer
Reply
@kaminkehrer - you are missing airtunes support (which is mendatory since ios5 or so). Are you sure you have libshairplay installed during compilation of Kodi? Looks like a buildproblem with gentoo to me. You can verify the logs - you would see something announced on port 36666 in your 13.2 log but not in your kodi.log (its airtunes - _raop.something).

We are using this revision of the lib atm:

https://github.com/xbmc/xbmc/tree/master...bshairplay (its revision 139d5ef + the patches in my link)
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
Hello Memphiz,

libshairport is already installed:
Quote:vdrmb4 libshairport # eix libshairport
[I] media-libs/libshairport [1]
Available versions: (**)9999 {static-libs}
Installed versions: 9999(01:40:19 PM 11/10/2014)(-static-libs)
Homepage: https://github.com/amejia1/libshairport
Description: Emulates an AirPort Express for the purpose of streaming music from iTunes and compatible iPods

[1] "gen2vdr-local-repo" /usr/local/portage
...
vdrmb4 lib # pwd
/usr/lib
vdrmb4 lib # ll libshairport.so*
lrwxrwxrwx 1 root root 21 Nov 10 13:40 libshairport.so -> libshairport.so.2.0.0
lrwxrwxrwx 1 root root 21 Nov 10 13:40 libshairport.so.2 -> libshairport.so.2.0.0
-rwxr-xr-x 1 root root 56032 Nov 10 13:40 libshairport.so.2.0.0
...


As you can see I use the following git: https://github.com/amejia1/libshairport

This works fine with xbmc 13.2.

Is it possible that it has something to do with the directory that I used for kodi?

My xbmc 13.2 is installed by using emerge in gentoo.
The kodi v14 I have installed manually in "/opt/XBMC" Directory and I also start the binary from this directory:
Quote:XBMC_DIR="/opt/XBMC/appl"
XBMC_EXEC="${XBMC_DIR}/bin/kodi"

The xbmc 13.2 is placed in:
Quote:vdrmb4 xbmc-git # which xbmc
/usr/bin/xbmc

My Idea is that I have to change something in the Makefile possibly?!?

Regards
Reply
Hello,

I'm a bit confused regarding libshairport and libshairplay.
In my installation log I can find:
Quote:checking shairplay/raop.h usability... no
checking shairplay/raop.h presence... no
checking for shairplay/raop.h... no
configure: == Could not find libshairplay. ==

But I can't find any thing else regarding libshairport.

Regards
kaminkehrer
Reply
this is really getting offtopic ... can you open a new thread with your compile issue? (libshairport is not used in current master anymore. You need libshairplay).
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
Apple AirPlay works fine for me using my iPhone 6 plus on Apple TV 2
Reply
Hello,

it works now, not perfect but it works.

I've got some help from "R2D2" from htpc-forum to install the following:
Quote:cd /opt/XBMC
git clone git://github.com/juhovh/shairplay.git
cd shairplay
./autogen.sh
./configure --prefix=/usr
make
make install

THANKS !!!

Regards
kaminkehrer
Reply
I have no problems using Airplay on IOS 8.1 from my iPhone 4s on a Windows 8.1 and Windows 7 staight out of the box.
Reply
(2014-11-18, 14:15)RavRob Wrote: I have no problems using Airplay on IOS 8.1 from my iPhone 4s on a Windows 8.1 and Windows 7 staight out of the box.

Which box ? A xbmc 13 or kodi 14 beta ?
Reply
Hi guys.

Here's my experience with Kodi Beta on Android and iPhone 5/iOS8.1:

- Initially XMBC (localhost) is recognized as video device properly and videos/music play fine without any problems.
- After being idle for awhile and trying to connect again - it is recognized as audio only device and only sound is playing.

It gets solved after disabling/enabling AirPlay in Kodi settings a few times.
Reply
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 20
  •   
 
Thread Rating:
  • 1 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
[AirPlay][Warning] Don't update to iOS8 if you want AirPlay41
This forum uses Lukasz Tkacz MyBB addons.