disable xbmc remote events while subprocess popen is active
I am working on a feature in youtube plugin to open chrome full screen for DRM. I have irxevent sending keyboard events to browser.

However the play button is still being captured and acted on by xbmc. This results in multiple browser tabs open.

I tried call LIRC.Stop but does not make difference.

I removed the play event from my irxevent script so its not that.

I am on Ubuntu 14.04 with a MCE remote using lirc not kernel module

Any advice appreciated including pointers for debugging further

I managed to resolve this myself. LIRC.Stop was indeed doing what it was supposed to. Unfortunately XOrg was registering my remote as a keyboard / mouse as well, so regardless of the LIRC support being turned off, Xorg was still generating equivalent keyboard events.

Thanks to this post:


I now have a well behaved feature which does not trigger the IR

I added the following to /usr/share/X11/xorg.conf.d/90-mce_usb.conf and restarted X Windows. I then added the LIRC.Stop and LIRC.Start to my
browser python script and all is well.

Section "InputClass"
Identifier "Ignore MCE_USB as Keyboard input"
MatchProduct "Media Center Ed. eHome Infrared Remote Transceiver (0609:0334)"
MatchIsKeyboard "true"
Option "Ignore" "true"

Section "InputClass"
Identifier "Ignore Second MCE_USB as Keyboard input"
MatchProduct "MCE IR Keyboard/Mouse (mceusb)"
MatchIsKeyboard "true"
Option "Ignore" "true"
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
disable xbmc remote events while subprocess popen is active00