•   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 56
  •   
WIP Windows DirectX 11 upgrade test thread
#76
yep in red/cyan i get broken gui and video
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#77
(2015-02-23, 20:41)afedchin Wrote: @Martijn, @poplap, @m910q
One more test to try determine possible reason of issue.
Nothing changed.
Here's the log: Debug log
Reply
#78
(2015-02-24, 20:38)m910q Wrote: Nothing changed.
Here's the log: Debug log
I've not seen in your log what you changed video setting to choose HQ scalers as I asked for.
Reply
#79
(2015-02-24, 18:48)Martijn Wrote: yep in red/cyan i get broken gui and video
So, the dxva renderer doesn't support default backbuffer format as I expected. But why? And why drivers still report what format supported? Seems like drivers support it but cannot work with it. Strange.
Workaround which I implemented in current branch should solve the issue. Still need to determine which drivers has this issue because workaround causes an extra shader execution.
Reply
#80
So I Did the test like you wanted, the video did not play back at first, but when I changed the window in some way be it going fullscreen/windowed or moving it around it started working.

Log: http://pastebin.com/ALYcGvBD

(PS Holy crap man thats a gui bug from hell lol)
Raspberry Pi Model B 2 1024MB @ 1.0Ghz w/OSMC
--Decommissioned-- Raspberry Pi Model B 512MB @ 1.0Ghz w/ 3TB USB Drive Running Open Media Vault
Reply
#81
(2015-02-24, 03:13)poplap Wrote: So when I first open the OSD it has Bicubic selected and a blank screen, as I switch though the options they all work except DXVA and Auto (Bicubic works though so I think it might be a GUI bug but I am not sure).

(Same issue as Martijn)
It's the exact same for me.
Log with scale changing: Debug log
Log was taken when starting from a working Bicubic scaling.
Reply
#82
New build:

Fixed:
  • Added workaround to fix dxva rendering on some systems.
  • Fixed GUI in anaglyph stereo mode.
  • Fixed overlay rendering.
  • Rebased to current master to include current fixes.

Download link in the first post.
Reply
#83
Works for me.
Did a clean install, everything seems fine.
Thanks!
Reply
#84
@m910q
I'm glad to hear this. But Debug Log still be helpfull for me Smile
Reply
#85
Sure thing.
Here's a debug log for a clean install, just playing the file: Debug log
Reply
#86
So everything seems to work well, tested with the same advanvesettings and DXVA set as the render, as well as setting everything back to default settings. I will say when playing the 3D clip it is really slow to start (a second or two) and lags for a few frames before playing smoothly. I have never messed around with 3D movies so I'm not sure if this is normal.

Log with advancesettings + DXVA Render: http://pastebin.com/GKMeGQ8j

Log Default settings: http://pastebin.com/vgbVuafC
Raspberry Pi Model B 2 1024MB @ 1.0Ghz w/OSMC
--Decommissioned-- Raspberry Pi Model B 512MB @ 1.0Ghz w/ 3TB USB Drive Running Open Media Vault
Reply
#87
@m910q
Thanks.

@poplap
Thank you too. As for issue with 3D movie it is normal for this test movie with dxva decoder.
Reply
#88
drag & drop the kodi window from one GPU to another crashes it. (it's a 3 screens setup with 2 GPUs)

log: http://1drv.ms/1LEdiqP
crashlog: http://1drv.ms/1BVBfu3
stacktrace: http://1drv.ms/1BVBlBN
Reply
#89
(2015-02-25, 21:51)thecYrus Wrote: drag & drop the kodi window from one GPU to another crashes it. (it's a 3 screens setup with 2 GPUs)
Neither your GeForce 210 or GeForce 9800 GT supports DirectX 11.
But I guess it could still be a bug in the feature detection.
Reply
#90
i doubt that kodi requires DirectX 11 feature-level GPUs. Should work without problems on older versions as well. Actually it works quite good here on individual screens. It's just that the current build doesn't handle GPU "remove" events. (DXGI_ERROR_DEVICE_REMOVED)
Reply
  •   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 56
  •   
 
Thread Rating:
  • 6 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
Windows DirectX 11 upgrade test thread3.56