•   
  • 1
  • 66
  • 67
  • 68(current)
  • 69
  • 70
  • 271
  •   
Release skin helper service
(2015-11-17, 00:47)marcelveldt Wrote: ...
Can you please -again- grab the latest Git version and test ? Offcourse first flush the persistant cache. If it's still not working I'd like to see the log again because I added some info that can help me track down the issue.
There's no problem for me DL the latest skinhelper again. I wrote a bash-script to do that, the only thing, I have to do then, is to restart Kodi Wink It is for OpenElec, but should work on any Linux-distro. I'll upload it to github, maybe someone find it useful.

To the artist-problem:
It shows VariousArtists again. I disabled all the other debug-logging and here are the skin.helper-entries:
Code:
08:40:43 T:2420110400  NOTICE: Thread PAPlayer start, auto delete: false
08:40:43 T:2889552960  NOTICE: Skin Helper Service --> Kodi_Monitor: sender xbmc - method: Player.OnPlay  - data: {"item":{"id":26974,"type":"song"},"player":{"playerid":0,"speed":1}}
08:40:44 T:2923107392  NOTICE: Skin Helper Service --> setMusicPlayerDetails: {u'album': u'Die Hit-Giganten - Best Of Party Hits', u'artist': [u'Scooter'], u'title': u'Maria (I Like It Loud)', u'label': u'Maria (I Like It Loud)', u'albumid': 124, u'displayartist': u'Scooter', u'type': u'song', u'id': 26974}
08:40:44 T:2923107392  NOTICE: Skin Helper Service --> getMusicArtworkByName artist: Scooter  - track: Maria (I Like It Loud)  -  album: Die Hit-Giganten - Best Of Party Hits
08:40:44 T:2923107392  NOTICE: Skin Helper Service --> getMusicArtworkByName found match in local DB --> [{u'album': u'Die Hit-Giganten - Best Of Party Hits', u'songid': 26974, u'file': u'/var/media/INTENSO/music/Sampler/VA.-.Die.Hit.Giganten.-.diverse/Die Hit-Giganten - Best Of Party Hits/CD 1/21.-.Scooter.-.Maria (I Like It Loud).mp3', u'artist': [u'Scooter'], u'track': 21, u'albumartistid': [878, 2440], u'title': u'Maria (I Like It Loud)', u'label': u'Maria (I Like It Loud)', u'albumid': 124, u'artistid': [2485], u'albumartist': [u'Collection: Die Hit-Giganten', u'Various Artists'], u'displayartist': u'Scooter'}]
08:40:44 T:2923107392  NOTICE: Skin Helper Service --> getMusicArtworkByDbId dbid: 124  type: albums

PS: I pm'ed you in addition to this problem
Thx
Reply
(2015-11-17, 01:51)marcelveldt Wrote:
(2015-11-16, 22:56)Dumyat Wrote: Just installed 1.0.13 from the Git, but appears to be doing the same as before, ie getting artwork for current item playing, but nothing else when scrolling up/down channel list. Take it no changes on the code that I posted earlier required?

Edit: Now the artwork I was getting for the current item playing disappears after like 1-2 secs

I looked into it and bad news... It is not going to work. Kodi doesn't support it, the script cannot access the infolabels on the OSD channels/guide.
If you want to get it working you can try out the webservice provided by the script, see the readme.
Ahhh, that is a shame. Sad Well, I tried using the same code for the webservice that I used on the DialogFullScreenInfo.xml file, but I'm getting pretty much the same result as I initially had, ie artwork is there for current item playing, but not when you scroll up/down the channel list. Only thing that is slightly different now is when I physically change channel, artwork also changes, which it didn't do previously. So kind of half way to achieving what I'm looking for at the moment, but just not catching for every channel when scrolling the channel list. This is the code I used. Is there anything obvious that I need to change here?
PHP Code:
<control type="image">
            <
visible>VideoPlayer.Content(LiveTV)</visible>
            <
left>1000</left>
            <
top>520</top>
            <
width>210</width>
            <
height>300</height>
            <
texture fallback="new_pvr/blue/fallback/fallback_tvposter.png">http://localhost:52307/getpvrthumb&title=$INFO[VideoPlayer.Title]&amp;channel=$INFO[VideoPlayer.Channel]&amp;type=poster</texture>
        
</control

Cheers for the feedback
Reply
Marcel, I am using the latest git, and from time to time, The helper is stop working, in my HTPC I don't do much except of watching some local tv-shwos...
so I guess there are some basic functions that make the script fail.
I see it when the "view changer" is stop working, or the backup\restore, or the widget "next episodes" is stuck... restart to kodi solve the problem most of the times.
I want to help to diagnose it.. any idea? does the debug log need to be on?
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
@tomer
(2015-11-16, 18:30)marcelveldt Wrote: In the settings for the addon itself enable verbose debug logging and that should fill your kodi log with all info.
...
from another post. It should help marcelveldt, solving your problem, if you upload your logfile on e.g. pastebin and post the link here.
Reply
(2015-11-17, 12:13)Solo0815 Wrote: @tomer
(2015-11-16, 18:30)marcelveldt Wrote: In the settings for the addon itself enable verbose debug logging and that should fill your kodi log with all info.
...
from another post. It should help marcelveldt, solving your problem, if you upload your logfile on e.g. pastebin and post the link here.

10x.. but I already enabled it.. and as you can see I have the most comments in this thread and most of them have link to pastebin lol :]
so I'm just consulting Marcel if he can direct me to something specific that can help me find the problem.
anyway, I'll keep my eyes on it, and let my HTPC run for few days and will search for errors in the log file.
Thanks anyway about your comment :]
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
Quote:... and as you can see I have the most comments in this thread and most of them have link to pastebin lol :]
Sorry, I haven't read the whole thread and didn't count your posts Big GrinBig GrinBig Grin
Reply
(2015-11-17, 11:10)tomer953 Wrote: Marcel, I am using the latest git, and from time to time, The helper is stop working, in my HTPC I don't do much except of watching some local tv-shwos...
so I guess there are some basic functions that make the script fail.
I see it when the "view changer" is stop working, or the backup\restore, or the widget "next episodes" is stuck... restart to kodi solve the problem most of the times.
I want to help to diagnose it.. any idea? does the debug log need to be on?

In that case another script is blocking the python interface. Last time I saw this happening was when there was an issue with the TvTunes addon but I've also seen it with the CU LRC Lyrics addon.

Just look for an addon that is locking up. Once the python interface is stuck you won't be able to launch any python scripts, including skin helper
Reply
(2015-11-17, 14:40)Solo0815 Wrote:
Quote:... and as you can see I have the most comments in this thread and most of them have link to pastebin lol :]
Sorry, I haven't read the whole thread and didn't count your posts Big GrinBig GrinBig Grin
To Count?
lol :-P

(2015-11-17, 14:59)marcelveldt Wrote:
(2015-11-17, 11:10)tomer953 Wrote: Marcel, I am using the latest git, and from time to time, The helper is stop working, in my HTPC I don't do much except of watching some local tv-shwos...
so I guess there are some basic functions that make the script fail.
I see it when the "view changer" is stop working, or the backup\restore, or the widget "next episodes" is stuck... restart to kodi solve the problem most of the times.
I want to help to diagnose it.. any idea? does the debug log need to be on?

In that case another script is blocking the python interface. Last time I saw this happening was when there was an issue with the TvTunes addon but I've also seen it with the CU LRC Lyrics addon.

Just look for an addon that is locking up. Once the python interface is stuck you won't be able to launch any python scripts, including skin helper
ok, I'll try to find it out too.
as I released my skin, a lot of users told me that some things is not working (things that calls the helper) - so I told them to reset, and most of the time it helps.
so I guess that something very common is blocking the script.
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2015-11-17, 16:23)tomer953 Wrote: as I released my skin, a lot of users told me that some things is not working (things that calls the helper) - so I told them to reset, and most of the time it helps.
so I guess that something very common is blocking the script.

Yep, in that case something is blocking the python scripts to open. Take a look at your logs if you can find something.
Reply
(2015-11-17, 10:28)Dumyat Wrote: Ahhh, that is a shame. Sad Well, I tried using the same code for the webservice that I used on the DialogFullScreenInfo.xml file, but I'm getting pretty much the same result as I initially had, ie artwork is there for current item playing, but not when you scroll up/down the channel list. Only thing that is slightly different now is when I physically change channel, artwork also changes, which it didn't do previously. So kind of half way to achieving what I'm looking for at the moment, but just not catching for every channel when scrolling the channel list. This is the code I used. Is there anything obvious that I need to change here?
PHP Code:
<control type="image">
            <
visible>VideoPlayer.Content(LiveTV)</visible>
            <
left>1000</left>
            <
top>520</top>
            <
width>210</width>
            <
height>300</height>
            <
texture fallback="new_pvr/blue/fallback/fallback_tvposter.png">http://localhost:52307/getpvrthumb&title=$INFO[VideoPlayer.Title]&amp;channel=$INFO[VideoPlayer.Channel]&amp;type=poster</texture>
        
</control

Cheers for the feedback

Well, if you want to use this for the OSD channel list, you can't use VideoPlayer.Title but you'll have to use the container labels from the DialogPVRChannelsOSD... Something like Container(10).ListItem.Title should work
Reply
(2015-11-17, 09:47)Solo0815 Wrote: To the artist-problem:
It shows VariousArtists again. I disabled all the other debug-logging and here are the skin.helper-entries:
PS: I pm'ed you in addition to this problem
Thx

I finally managed to fix this Big Grin

I've been testing for several hours now with both real albums and compilations and now it's finally working fine.
Can you grab the latest Git ?

BTW: It will also work with online radio streams (that provide the title) and the extrafanart is also filled (artist slideshow replacement)
Reply
(2015-11-18, 00:15)marcelveldt Wrote: Well, if you want to use this for the OSD channel list, you can't use VideoPlayer.Title but you'll have to use the container labels from the DialogPVRChannelsOSD... Something like Container(10).ListItem.Title should work
Haha, seems a good nights sleep can work wonders sometimes Smile
Tried this a couple of times last night, but still couldn't get it to work. Tried again this morning with a fresh mind and made a very slight change from Container(10).ListItem.Title to Container(11).ListItem.Title and all is good, everything now working as expected......Marvellous! Smile

Thanks very much for your help Smile
Cheers
Reply
(2015-11-18, 00:18)marcelveldt Wrote:
(2015-11-17, 09:47)Solo0815 Wrote: To the artist-problem:
It shows VariousArtists again. I disabled all the other debug-logging and here are the skin.helper-entries:
PS: I pm'ed you in addition to this problem
Thx

I finally managed to fix this Big Grin
It is working! Cool Thanks again, good work
Reply
Problem with applying saved theme, causes terminal never ending hang

13:29:08 T:2204 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.UnicodeEncodeError'>
Error Contents: 'ascii' codec can't encode character u'\xe9' in position 39: ordinal not in range(128)
Traceback (most recent call last):
File "C:\Users\danrach\AppData\Roaming\Kodi\addons\script.skin.helper.service\resources\lib\ColorThemes.py", line 239, in onClick
loadColorTheme(themeFile)
File "C:\Users\danrach\AppData\Roaming\Kodi\addons\script.skin.helper.service\resources\lib\ColorThemes.py", line 298, in loadColorTheme
xbmc.executebuiltin("Skin.SetString(%s,%s)" % (setting, skinsetting[2]))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 39: ordinal not in range(128)
-->End of Python script error report<--
Reply
Hi Marcel,

I'm using background integration in skinshortcuts with the following :

PHP Code:
<background label="smartshortcuts" condition="System.HasAddon(script.skin.helper.service)">||BROWSE||plugin://script.skin.helper.service/?action=backgrounds</background> 

It seems it fills the list with also the first 2 items :

- Image
- Multi-images

Regarding Multi-image, I have been reported it as not working so tested myself and also didn't get it to work.
I think we have to browse a folder containing the pictures to cycle but nothing is showing.
I believe this should work with a single image control and the script makes them to cycle Inside it (like Library backgrounds provided by the script ?)

Is there something I'm missing or just broken ?
Thanks.

EDIT : Nevermind, seems it's provided by SkinShortcuts when <backgroundbrowse> tag is used. Will check ...
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
  •   
  • 1
  • 66
  • 67
  • 68(current)
  • 69
  • 70
  • 271
  •   
 
Thread Rating:
  • 18 Vote(s) - 4.56 Average



Logout Mark Read Team Forum Stats Members Help
skin helper service4.5618