XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares
I'm in the same boat as nokatze. I'm running OSMC on a Raspberry Pi B+ and Windows10. I've tried everything i can think of and / or Google and i'm still getting wonky behavior. To be more specific if i add a video source i can browse and see my shared folders just fine; the problem being is that *usually* they don't show the contents being about a dozen or so video files. If something does show up its usually the first three items in the folder which, incidently, i am able to play back fine from the movie library section even whilst getting the 'invalid argument could not connect to network store' message when navigating the videos > files section. There was one brief, shining moment where everything showed up properly in the videos section and then a moment later it was gone, meaning the videos > files > shared folder contents were once again blank and i was bombarded by 'argument invalid' errors. Now the interesting part is if i continuously select the shared folder from the UI i will usually get 'invalid argument' message, however if i just keep selecting it i'll either get an empty folder or i'll get the first three, and at one point, four items from the list which i can play back.

So on the OSMC side here are the paths that i've tried, and honestly they mostly all have the same 'works some of the time but not usually' result, although interestingly if something makes it into the 'movie' library I can *always* play it back-

smb://hostname/Videos/ (this path occurs when using browse rather than manual entry)
smb://user:[email protected]/Users/Me/Videos/
smb://user:[email protected]/Videos/

As i write this i'm realizing i never tried a fully qualified path so i'll probably try that tonight. Something like-
smb;//user:[email protected]/C:/Users/Me/Videos/

Now over to the Windows side-
1. Create Homegroup
2. Join Homegroup
3. Create local user
4. Share folders, the go into advanced sharing on the folder and tick off the 'Share this folder' box
5. Increase IRPStackSize in registry (key didn't exist, had to add, made the value 15 or thereabouts)
6. Increase size parameter from 1 to 3 in registry

Things i haven't done as they seem silly although i might later on tonight just to see what happens-
1. Disable firewall
2. Disable defender
I've resorted to installing Open Media Vault in a Hyper-V because of this issue. Works great!
Having same problem myself, usb(3) shared external hdd on win10, any linux device including OSMC, on rpi2, and any android based OS for phones.
I Can access all my internal drives shares but not usb shares.

Tested the same setup on a laptop with clean install of win10 AFAIK, might have been an upgrade, it had not problems sharing usb shares for linux based devices, my phone was able to access it without an issue...although untested osmc.

So I wonder if a clean install will fix this very very odd issue....
Password protected sharing just in general doses not work and thats no myth its a fact but don't ask for an explanation. Smb is a dark art that some have no problems with and others not; i find when fixing problems its inconsistent settings throughout the network and everyone says mine is 100% consistent but hey ho, not stirring the pot just some insight from my experience from windows 95 release on floppy disk (about 25 of the suckers) till now.
Just out of curiosity, the people that are having this problem, what build/version of win10 are you running?

To find out type in start menu, system info, and open system information, and look for the item, version, if you've just upgraded from win7/8/.1
It will be 10240 for the first month or until you remove the windows.old folder in C:\

Then should be 10586 or higher (10586 is the Nov2015 update, which was major update iirc)

I'm on 10240..currently
and the laptop i tested on is 10586...

I don't plan on going back to win7 as my version is broken anyway...so i might just move over 10586 to test and I'll report back here

This is only for USB shares, if your internal storage is also inaccessible from OSMC/openelec or other any linux based platform for kodi you have a different problem.
Ok Reporting back on my finding and a possible FIX for some.

I have fixed the issue with Linux not being able to access windows 10 USB shares ONLY.

So I been battling for few days with this, finally resorting to M$ tech chat support which didn't really help as he suggested everything I had already tried on my own prior to contacting and ended in him saying I need to reinstall which is just a big MEH to me.
follow this for fix: **NB**!!


Quote:Event ID 2011 — Shared Folders (SMB) Server Configuration

Raise the IRPStackSize parameter for the server

The IRPStackSize parameter specifies the number of stack locations in I/O request packets (IRPs) that are used by Windows. You should increase this number for certain transports or for file system drivers.

To perform this procedure, you must have membership in Administrators, or you must have been delegated the appropriate authority.

Caution: Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.

To increase IRPStackSize for the server:

Click Start, click Run, type regedit, and then click OK.
Locate and then click to select the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanserver\Parameters
On the Edit menu, point to New, and then click DWORD Value.(32bit)
Type IRPStackSize, and then press Enter.
Right-click IRPStackSize, and then click Modify.
In the Value data box, type the desired value, and then click OK.

Although the chat did make me realise I hadn't correctly named the reg Dword 32bit key, it is case sensitive, so I had irpstacksize in lower case where as it needs to be in partly uppercase as such; IRPStackSize
I used the value of 29 hexadecimal

YOU NEED TO RESTART after adding and setting the dword.

fixing that and restarting randomly decided to try it later and it worked (didn't think it would make difference)

I am on windows10 build 10586.104

Hope this helps other
Cheers! Smile
Charun, this totally solved my sharing problems. Thanks very much!
Glad you all have this working its a process i seem to get mine working quite easy but depends on the setup.
It definitely looks like this was the cause of the problem and is only seemed to affect USB3 drives as my internal drives and USB2 drives worked fine.

I did that major Win10 service pack upgrade from 1511 to version 1607 sometime in the last few weeks but I know it was all still working exactly 3 weeks ago. so either that or some recent windows updates jacked it all up.

80% of the problems were fixed by setting IRPStackSize to Hex 29 value, and Kodi 16.1 allowed me to add my shares as sources using file manager in settings. But I couldn't set the share types there to movies/TV/etc so I deleted them.

Unfortunately when I then went to add them under Videos-Files and told it to browse to the same PC the shares are on it times out and says "Invalid Argument" without showing any of my shares. This is I think the same error I was getting before no matter what method I used to connect, so I'm better off, just not quite 100% fixed yet.

So what does this IRPStackSize value of 29 mean and what values are safe to try ? I s bigger better or is smaller better ? My drives are all USB3 except one.

Answered my own question here...

The IRPStackSize is a parameter that specifies the number of stack locations in I/O request packets (IRPs) that are used by the operating system. Each stack uses 36 bytes of memory for each receive buffer and you can increase the IRPStackSize, through the Windows registry for some transports, media access control (MAC) drivers, or for file system drivers. The default value of the IRPStackSize parameter is 15.

So I guess I'll try upping it to 50 from 29.
I'm keen to try and replicate this issue, as it seems the common issue is with accessing media/files/whatever from a USB storage of some description?
Media_Center_Master (wiki) || First_time_user (wiki) || Kodi Store || T-shirts: Villian, Protest, Graffiti, Emoji, Black on Black, K-18L
I am using both an KDLINKS A300 with Factory firmware and a Samsung Galaxy Tab A 10.1 running stock Kodi 16.1 to test this.

Kodi from my laptop works fine using local drive shares but I need to see if I can add the remote USB 3.0 shares so we have additional data.

Changing the IRPStackSize to 29 worked after I rebooted and tried to go through Kodi System-->File Manager and add the shares.
It also worked fine in the SMB Android tool "ShareFinder" so I could find the shares and see the files.
I then removed those shares in Kodi and went through Videos-->files to add folders/sources and it failed.
At that point I assumed it must need more resources of some sort as it failed with "Invalid Argument"

I then changed the IRPStackSize to 50 and rebooted.
I still could not add them through Videos-->files and then tried to go back to System-->File Manager and add the shares but it still fails with "Invalid Argument"
Using the ShareFinder App it now says "OxC00000205" error like it did before changing the IRPStackSize.

VERY VERY frustrated as there is no reason I should have to spend hours and hours troubleshooting because Microsoft decided to "help us" by changing things again.

I still think the 1607 update (Service Pack) is related but it fails to install on either of my laptops for a comparison.

I will change back to a value of 29 but don't have high hopes to even get back that limited functionality as there is obviously something else that needs changed.
After changing the value back from 50 to 29 again I tried using Kodi 16.1 from my windows laptop and it seemed to work just fine with the USB3 shares.

On a whim I decided to try it on my Samsung tablet again while the library was scanning/updating on my laptop and it too seemed to work.

I added the 6 sources to my tablet and let it begin updating it's library and tried using my KDLINKS A300 and it also is now working and rebuilding it's libraries.

I am very happy that it all appears to be working but All i did was change back to yesterday's config that was failing so I'm not very confident it will continue to work or that a real fix has been implemented.

Maybe accessing the SMB shares from my windows laptop did something to make them available to my other SMB devices ? That's the only think i didn't try yesterday that I tried today, and I tried it today BEFORE trying my Android devices after the reboot and change to 29.

I'll keep watching the posts here but happy in the mean time that it is working Smile
deleted, posted in wrong thread.

Logout Mark Read Team Forum Stats Members Help
XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares0
This forum uses Lukasz Tkacz MyBB addons.