•   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 146
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-02-15, 22:20)Negativ Wrote: Hi,

very great what have been achieved on the Raspberry Pi 2 but i've a problem with the Krypton builds for the original Raspberry Pi. If i want to upgrade from openelec 6.0.1 to Krypton the screen stays black after the upgrade. I can see the first bootscreen and then nothing. It seem's to bee running because i can access is with samba but not with a network remote. I tried different builds but everytime the same behavior.

Best regards

Add the following to advancedsettings.xml:

Code:
<loglevel>2</loglevel>
then upload your kodi.log after trying to start Kodi.

If Kodi is crashing, upload your crashlog (see note #4 in first post).

What will most likely work is for you to rename your .kodi folder ("mv .kodi .kodi.bak") as either an add-on, setting or database is preventing normal startup.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Sometimes I have some strange artifacts in Live-TV preview while browsing the channel view. This happen only with 1080i TV channels but not with 720p channels.

When this happen I made a screenshot kodi-send --action="TakeScreenshot" but it looks clear. It seams that the artifacts ony occours at the player output. So I don't know if this is VDR releated or not.

In the debug log starts the problem more or less here "19:09:41 183.112793 T:1789916064"

I'm using a Raspberry Pi2 with lates build and VDR from here. I'm not sure but I think the problem start's with build #0212 or #0213 when I made a clean new installation. My stetup is always the same. I use MMAL videoplayer hardware acceleration.

FrenetMenta give my the hint in VDR section that it looks like MMAL doesn't deinterleace the video in preview mode
(2016-02-16, 00:16)herrmeier01 Wrote: Sometimes I have some strange artifacts in Live-TV preview while browsing the channel view. This happen only with 1080i TV channels but not with 720p channels.

I will need some clue as to what you are seeing. Can you capture it with a photo or video recording from a phone camera?
Here is a video of the disruption.
By the way when I want to make the video I found out the problem only occurs when I have activated Hyperion service for ambilight.
When it is switched of it seams that the problem will not occurs
(2016-02-16, 01:19)herrmeier01 Wrote: Here is a video of the disruption.
By the way when I want to make the video I found out the problem only occurs when I have activated Hyperion service for ambilight.
When it is switched of it seams that the problem will not occurs

Best leave it off for now. I'm not sure if addons using render capture need updating for VideoPlayer.
It's not obvious to me what is causing that effect.

Any different with omxplayer enabled/disabled?
Any different with deinterlace enabled/disabled?
Any different with overclock enabled/disabled?
(2016-02-16, 00:16)herrmeier01 Wrote: I'm using a Raspberry Pi2 with lates build and VDR from here.

You can find more up to date versions of vdr-addon here: http://milhouse.openelec.tv/builds/addon...n/?C=M;O=D
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Any different with omxplayer enabled/disabled?
-> no, problem stil happen
Any different with deinterlace enabled/disabled?
-> no, problem stil happen
Any different with overclock enabled/disabled?
-> no, problem stil happen

Here is a dedicated debug only with part activate Hyperion and get the problem http://pastebin.com/raw/8P8GCu5c
New OpenELEC Krypton build #0215: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.1 #1 Mon Feb 15 22:03:08 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Feb 15 2016 20:18:22
Copyright (c) 2012 Broadcom
version dc2c1aba32c7469e82a87be0d5d921aa9233e60d (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160215220215-#0215-ga9bb95e [Build #0215]

# vcdbg log msg 2>&1 | grep DTOK
001729.478: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (a9bb95e0, changelog) and tip of XBMC master (0871790e, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.4.y
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest dcadec master (0e074384, ahead +139)
  • Includes latest kodi-platform master (92583ef9, ahead +2)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (2927ce04, ahead +9)
  • Includes latest p8-platform master (38343e0a)
  • Includes latest addons: peripheral.joystick (fc605f4b, +46), pvr.argustv (9459a485, +9), pvr.demo (32952941, +8), pvr.dvblink (ff02fe16, +10), pvr.dvbviewer (d10f17c6, +7), pvr.filmon (76625cc8, +9), pvr.hdhomerun (0df8d29f, +13), pvr.hts (95b98abb, +45), pvr.iptvsimple (baaae159, +11), pvr.mediaportal.tvserver (39e89190, +33), pvr.mythtv (da0a6f50, +12), pvr.nextpvr (8c6e7ea7, +11), pvr.njoy (13bd96fd, +7), pvr.pctv (b321e302, +9), pvr.stalker (4da8913c, +10), pvr.vbox (83f95b9c, +15), pvr.vdr.vnsi (894555c6, +12), pvr.wmc (8327f887, +10)
  • Includes commits from service.openelec.settings/, ahead +1 (OpenELEC)
  • Include [env] e7cbe9cb: xf86-video-intel: explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 2f83a1cf: xf86-video-intel: bump to 8b8c9a36 (fixes segfault when refreshrate changing)
  • Include [env] 3a6268c9: VAAPI: Enable EGL
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] 858f6461: xf86-video-intel: bump to 371219c
  • Include [env] compare: ffmpeg: Additional Jarvis 2.8.x patches
  • Include [env] patch: Clean Kodi view cache on startup
  • Include [env] patch: Enable other binary addons
  • Include [env] patch: Add experimental splash video
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: kodi: peripheral.joystick binary addon
  • Include [env] PR:4500: kodi: update to 17.0
  • Include [env] PR:4537: [scripts] Add PKG_SOURCE_NAME for non-standard package tarballs
  • Include [env] PR:4661: stripping changes
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] PR:7030: CNetwork - implement IPv6
  • Include [pkg] PR:8254: FIX: Only handle 3D bitmap subs in TAB
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8807: Controller input
  • Include [pkg] PR:8822: Implement ignore url options in CFileItemList
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9112: [confluence] [PVR] small adjustments
  • Include [pkg] PR:9145: [PVR] Recordings window: Fix recordings in nested folders not displayed
Build Highlights:
  1. Reintroduce PR8807 with improved touchscreen detection - please test & report
  2. Fix identification of PVR recordings, and nested recordings
  3. Add touchscreen multitouch support
  4. Stop building pvr.dvblink and pvr.dvbviewer while without API 4.2.0 support
Build Details:
  1. XBMC:
    • [cmake] Fix finding FXC.exe on Windows (PR:9135, 1 commit, 2 files changed)
    • [addons] fixes/cleanup (PR:9136, 5 commits, 38 files changed)
    • RenderManager: Maintain counters correctly (PR:9134, 1 commit, 1 file changed)
    • Fix limited songs query (for MySQL) and improve efficiency of GetSongs (PR:9081, 2 commits, 4 files changed)
    • video: fix false positive identification of pvr recordings (PR:9141, 1 commit, 1 file changed)
    • [gui] new infobool Window.Is() (PR:8985, 1 commit, 2 files changed)
  2. pvr.hdhomerun:
  3. newclock5:
    • New commits in this build:
      • Fix Raspberry-Pi build (e49a39c4)
      • Don't default CPU to host processor if toolchain file is given (382a4a1a)
      • Make MMAL mandatory for Raspberry-Pi (a64b9f4a)
      • Add documentation for Raspberry Pi (9dd2d248)
      • Add toolchain file checks (8e8b23cd)
      • Update README.raspberrypi for Raspberry Pi 2 (37345e8a)
      • Build cpluff with verbose compile output (96cb310b)
      • cmake: Add libs vcsm and containers (bb29ab0d)
      • touch panel to display adjustment - support multitouch (e69325d5)
  4. kernel 4.4.y:
    • New commits in this build:
      • bcm2835-sdhost: Restore ATOMIC flag to PIO sg mapping (e7221b6c)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: Enable pvr addons, disable pvr updates
    • Added: [pkg] PR:8807: Controller input
    • Added: [pkg] PR:9145: [PVR] Recordings window: Fix recordings in nested folders not displayed
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-02-16, 01:35)Milhouse Wrote:
(2016-02-16, 00:16)herrmeier01 Wrote: I'm using a Raspberry Pi2 with lates build and VDR from here.

You can find more up to date versions of vdr-addon here: http://milhouse.openelec.tv/builds/addon...n/?C=M;O=D

Thanks you Milhouse. I upgrade to this newer version. Problem still exists but I'm now more up to date now...
@garbear: I keep seeing the following entries repeat in kodi.log every 10 seconds:
Code:
00:42:22  25.598433 T:1963257856  NOTICE: Found a non joystick : use it as standard kodi input device - /dev/input/event0
00:42:22  25.621536 T:1963257856  NOTICE: Found a non joystick : use it as standard kodi input device - /dev/input/event1
00:42:22  25.641310 T:1963257856  NOTICE: Found a non joystick : use it as standard kodi input device - /dev/input/event2

I don't have anything connected to the RPi2 except HDMI, an IR USB dongle and USB flash drive.

Maybe this is just a diagnostic, but in case it's not I thought I'd let you know...

Full log: http://sprunge.us/FTHj (I briefly enabled debugging but no additional information is logged)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-02-15, 22:21)zaphod24 Wrote:
(2016-02-15, 22:12)ksooo Wrote:
(2016-02-13, 13:38)MikeB2013 Wrote: Your reading is correct. There is no "DefaultTransporter" folder.

Top level Default (in this case), inside more folders (each of which has recordings),

Mike

Should be fixed once https://github.com/xbmc/xbmc/pull/9145 got merged

Thank you! I look forward to testing this when it is in a build.

Everything is working again with PVR and folders/grouping. Thanks!
I have noticed with some of my 3D MVC mkv files that playback is jerky and video/audio totally out of sync with VideoPlayer.
With OMXPlayer, everything is fine.
I have tested with latest build and also with build #0104.

Here is and exerpt of the video :
https://onedrive.live.com/redir?resid=C1...file%2cmkv

And the logs :
http://xbmclogs.com/pts2mfxmr
(2016-02-15, 23:14)Milhouse Wrote:
(2016-02-15, 22:20)Negativ Wrote: Hi,

very great what have been achieved on the Raspberry Pi 2 but i've a problem with the Krypton builds for the original Raspberry Pi. If i want to upgrade from openelec 6.0.1 to Krypton the screen stays black after the upgrade. I can see the first bootscreen and then nothing. It seem's to bee running because i can access is with samba but not with a network remote. I tried different builds but everytime the same behavior.

Best regards

Add the following to advancedsettings.xml:

Code:
<loglevel>2</loglevel>
then upload your kodi.log after trying to start Kodi.

If Kodi is crashing, upload your crashlog (see note #4 in first post).

What will most likely work is for you to rename your .kodi folder ("mv .kodi .kodi.bak") as either an add-on, setting or database is preventing normal startup.

Thank you milhouse for your answer but i have tried it today again with the 0215 build and it now works. I don't know why i tried it yseterday with a fresh install an d it didn't worked.
But it works now Wink

Best regards
Maybe because the Kodi servers have been DDOS'd for the last day or so and something reacted badly to that.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Anyone who is using the analogue/headphone socket on the Pi, please try the new sigma-delta audio driver.
You need these settings in config.txt
Code:
disable_pvt=1
force_turbo=1
audio_pwm_mode=2
audio_sdm_mod_order=2
More details here: https://www.raspberrypi.org/forums/viewt...9&t=136445

(be aware that force_turbo in conjunction with over_voltage may set your warranty bit - disable overclock first if you care).

That will need a manual firmware update for now - but that will be in tonight's build.
  •   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 146
  •   
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.