•   
  • 1
  • 50
  • 51
  • 52(current)
  • 53
  • 54
  • 171
  •   
WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
Yesterday I downloaded Alpha 22 and did a clean install. Set all of the options and started importing my movies. Movies imported fine and everything was working as it should. The first movie I tried to scrape via cmd line it sat there for about 15 minutes saying updating library. I closed it and started it normally. When I hit update library it sits there saying "Performing Preliminary Tasks (Gathering Data)" forever. I let it sit there for 1 hour and still nothing. If you close it, it says cancelling processes and closes as it should. Then I tried to update just sections of the movies database and it half works. I'm able to update my documentaries (119 titles) and standup (32 items) with no problems. Anytime I try to update my main movies (1,890 titles) it just stays at gathering data.

I deleted the profiles folder and copy/paste my working profile from alpha 21 into alpha 22 folder, it upgraded the database and loaded like normal. Same problem with updating movies. I disabled "Clean database after update" and no changes. Went back to alpha 21 and it updates all of my collections without a problem. Tried a reload on all movies and no errors. Deleted profile from alpha 21 and started over. Everything works as it should. I looked into the logs and noticed this:

Code:
EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <AfterUpdateDB_Movie>

to me that's saying it doesn't know what to do after updating movies? Which seems to be the case. I saw that you uploaded alpha 23 and just finished trying it out. Same troubles from alpha 22. Unfortunately I deleted alpha 22 and the logs, but since 23 is doing the EXACT same thing I'll just upload the log for it:

http://pastebin.com/gkScRrpV

Here is my profiles folder minus the db:

https://www.dropbox.com/s/89mfdwy1ayb4ho...s.zip?dl=0

Please let me know if there is anything more that you need.
Reply
(2016-09-21, 17:21)Fail$tyle420 Wrote: Yesterday I downloaded Alpha 22 and did a clean install. Set all of the options and started importing my movies. Movies imported fine and everything was working as it should. The first movie I tried to scrape via cmd line it sat there for about 15 minutes saying updating library. I closed it and started it normally. When I hit update library it sits there saying "Performing Preliminary Tasks (Gathering Data)" forever. I let it sit there for 1 hour and still nothing. If you close it, it says cancelling processes and closes as it should. Then I tried to update just sections of the movies database and it half works. I'm able to update my documentaries (119 titles) and standup (32 items) with no problems. Anytime I try to update my main movies (1,890 titles) it just stays at gathering data.

I deleted the profiles folder and copy/paste my working profile from alpha 21 into alpha 22 folder, it upgraded the database and loaded like normal. Same problem with updating movies. I disabled "Clean database after update" and no changes. Went back to alpha 21 and it updates all of my collections without a problem. Tried a reload on all movies and no errors. Deleted profile from alpha 21 and started over. Everything works as it should. I looked into the logs and noticed this:

Code:
EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <AfterUpdateDB_Movie>

to me that's saying it doesn't know what to do after updating movies? Which seems to be the case. I saw that you uploaded alpha 23 and just finished trying it out. Same troubles from alpha 22. Unfortunately I deleted alpha 22 and the logs, but since 23 is doing the EXACT same thing I'll just upload the log for it:

http://pastebin.com/gkScRrpV

Here is my profiles folder minus the db:

https://www.dropbox.com/s/89mfdwy1ayb4ho...s.zip?dl=0

Please let me know if there is anything more that you need.

Code:
[RunGeneric] No generic modules defined <AfterUpdateDB_Movie>
means only that no module is enabled or available that has a trigger/function/interface that has to be run after update db for movies.

I can't see any error in your log. So I don't know what the problem is :-(
The latest alpha and also alpha 22 has been working for me...
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-09-21, 21:34)DanCooper Wrote:
(2016-09-21, 17:21)Fail$tyle420 Wrote: Yesterday I downloaded Alpha 22 and did a clean install. Set all of the options and started importing my movies. Movies imported fine and everything was working as it should. The first movie I tried to scrape via cmd line it sat there for about 15 minutes saying updating library. I closed it and started it normally. When I hit update library it sits there saying "Performing Preliminary Tasks (Gathering Data)" forever. I let it sit there for 1 hour and still nothing. If you close it, it says cancelling processes and closes as it should. Then I tried to update just sections of the movies database and it half works. I'm able to update my documentaries (119 titles) and standup (32 items) with no problems. Anytime I try to update my main movies (1,890 titles) it just stays at gathering data.

I deleted the profiles folder and copy/paste my working profile from alpha 21 into alpha 22 folder, it upgraded the database and loaded like normal. Same problem with updating movies. I disabled "Clean database after update" and no changes. Went back to alpha 21 and it updates all of my collections without a problem. Tried a reload on all movies and no errors. Deleted profile from alpha 21 and started over. Everything works as it should. I looked into the logs and noticed this:

Code:
EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <AfterUpdateDB_Movie>

to me that's saying it doesn't know what to do after updating movies? Which seems to be the case. I saw that you uploaded alpha 23 and just finished trying it out. Same troubles from alpha 22. Unfortunately I deleted alpha 22 and the logs, but since 23 is doing the EXACT same thing I'll just upload the log for it:

http://pastebin.com/gkScRrpV

Here is my profiles folder minus the db:

https://www.dropbox.com/s/89mfdwy1ayb4ho...s.zip?dl=0

Please let me know if there is anything more that you need.

Code:
[RunGeneric] No generic modules defined <AfterUpdateDB_Movie>
means only that no module is enabled or available that has a trigger/function/interface that has to be run after update db for movies.

I can't see any error in your log. So I don't know what the problem is :-(
The latest alpha and also alpha 22 has been working for me...

This is just weird. I'm gonna try a virtual machine with ember and see if I can figure anything out. Thanks for the help Dan!
Reply
(2016-09-05, 01:39)zerocool_ie Wrote: enjoy Sun&Bass Dan Smile

One for you when you get back: actor scraping doesn't work for Judgement Night (1993)
https://www.themoviedb.org/movie/6-judgment-night

Code:
2016-09-05 00:30:38.0613,EmberAPI.HTTP,EmberAPI.HTTP.DownloadFile,6,ERROR,DownloadFile    <>,"EXCEPTION OCCURRED:System.UriFormatException: Invalid URI: The URI is empty.
   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at System.Net.WebRequest.Create(String requestUriString)
   at EmberAPI.HTTP.DownloadFile(String URL, String LocalFile, Boolean ReportUpdate, String Type, String WebURL)*   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at System.Net.WebRequest.Create(String requestUriString)
   at EmberAPI.HTTP.DownloadFile(String URL, String LocalFile, Boolean ReportUpdate, String Type, String WebURL)"
2016-09-05 00:30:38.0613,EmberAPI.Themes,EmberAPI.Themes.LoadFromWeb,6,WARN,Theme NOT downloaded: ,
2016-09-05 00:30:38.1188,EmberAPI.HTTP,EmberAPI.HTTP.DownloadFile,6,ERROR,DownloadFile    <>,"EXCEPTION OCCURRED:System.UriFormatException: Invalid URI: The URI is empty.
   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at System.Net.WebRequest.Create(String requestUriString)
   at EmberAPI.HTTP.DownloadFile(String URL, String LocalFile, Boolean ReportUpdate, String Type, String WebURL)*   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Uri..ctor(String uriString)
   at System.Net.WebRequest.Create(String requestUriString)
   at EmberAPI.HTTP.DownloadFile(String URL, String LocalFile, Boolean ReportUpdate, String Type, String WebURL)"
2016-09-05 00:30:38.1188,EmberAPI.Trailers,EmberAPI.Trailers.LoadFromWeb,6,WARN,Trailer NOT downloaded: ,
2016-09-05 00:30:38.2428,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,6,TRACE,[ModulesManager] [RunGeneric] [Start] <Sync_Movie>,
2016-09-05 00:30:38.2428,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,6,TRACE,[ModulesManager] [RunGeneric] Run generic module <Kodi>,
2016-09-05 00:30:38.2428,Ember_Media_Manager.frmMain,Ember_Media_Manager.frmMain.bwMovieScraper_DoWork,6,TRACE,[Movie Scraper] [Done] Scraping Judgment Night (1993),
2016-09-05 00:30:38.2428,Ember_Media_Manager.frmMain,Ember_Media_Manager.frmMain.bwMovieScraper_DoWork,6,TRACE,[Movie Scraper] [Done] Scraping,
2016-09-05 00:30:38.3269,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_33_UpdateInfo_Movie.MoveNext,7,TRACE,"[APIKodi] [server2] UpdateInfo_Movie: ""Judgment Night"" | Start syncing process...",
2016-09-05 00:30:38.5280,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_27_SearchMovie.MoveNext,39,TRACE,"[APIKodi] [server2] [SearchMovie] ""\\NAS\movies\720p\Judgment Night (1993)\Judgment Night (1993) 720p.h264.ac3.hdtv.mkv"" | OK, found in host database! [ID:11767]",
2016-09-05 00:30:39.6128,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_33_UpdateInfo_Movie.MoveNext,46,TRACE,"[APIKodi] [server2] UpdateInfo_Movie: ""Judgment Night"" | Updated on host",
2016-09-05 00:30:39.6318,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,46,TRACE,[ModulesManager] [RunGeneric] [Start] <Notification>,
2016-09-05 00:30:39.6318,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,46,WARN,[ModulesManager] [RunGeneric] No generic modules defined <Notification>,
2016-09-05 00:30:40.0381,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <Notification>,
2016-09-05 00:30:40.0381,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <Notification>,

I've found a bug in TMDB scraper that does not allow to scrape movies if no IMDB is available and TMDB-ID < 10 ... and your movie has ID 6 Tongue
Has been fixed for Alpha 24: Commit
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-09-22, 09:59)DanCooper Wrote: I've found a bug in TMDB scraper that does not allow to scrape movies if no IMDB is available and TMDB-ID < 10 ... and your movie has ID 6 Tongue
Has been fixed for Alpha 24: Commit

The Man.
The Legend.
Dan Cooper.

thanks as always! Smile
3x R-Pi3 LibreELEC v9.2 Beta 2 | Transparency! | Flirc cases
Storage Synology DS411 | 4 x WD RED 6TB
Software MariaDB 10.2.29 | Filebot | Ember Media Manager
wiki (wiki) | First time user (wiki) | Debug_Log (wiki) | mysql (wiki) | artwork (wiki)
Reply
(2016-09-21, 22:13)Fail$tyle420 Wrote: [This is just weird. I'm gonna try a virtual machine with ember and see if I can figure anything out. Thanks for the help Dan!

Well I'm at a loss. I started up a virtual machine and loaded it up, importing movies works as should, but updating still causes it to get stuck. I was thinking that maybe it was a bad nfo or something, but it doesn't make sense that alpha 21 works just fine. The only damn thing I can think of is to load up an older version of windows 10 in a VM and see what happens. I guess I'm stuck with alpha 21 for the time being Sad
Reply
(2016-09-22, 19:43)Fail$tyle420 Wrote:
(2016-09-21, 22:13)Fail$tyle420 Wrote: [This is just weird. I'm gonna try a virtual machine with ember and see if I can figure anything out. Thanks for the help Dan!

Well I'm at a loss. I started up a virtual machine and loaded it up, importing movies works as should, but updating still causes it to get stuck. I was thinking that maybe it was a bad nfo or something, but it doesn't make sense that alpha 21 works just fine. The only damn thing I can think of is to load up an older version of windows 10 in a VM and see what happens. I guess I'm stuck with alpha 21 for the time being Sad

Sounds strange. I've changed some things in Scanner API, but that was only some triggers to update the lists on-the-fly instead of run an new DB call after updating.
Any new information inside the log?
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-09-22, 19:46)DanCooper Wrote: Sounds strange. I've changed some things in Scanner API, but that was only some triggers to update the lists on-the-fly instead of run an new DB call after updating.
Any new information inside the log?

I have no idea man. Looking at the logs, it doesn't show anything different from what I uploaded last time, other than showing the time I started scanning and when I closed it which lasted about 48 minutes. No errors or anything. It's weird that I can update my smaller paths (Documentaries and stand up), but not my main movies. All of the modules, clean library, adding/removing paths, reloading all movies, everything else works just fine. I'm gonna test with a small portion of my movies and slowly add more in until I see something. I'll keep you updated!
Reply
Ok, so I copied a portion of my movies over to another drive and added that path into ember. Did an update and it took 8 min EXACTLY to do an update on 359 movies. So, doing the math it should take approx 43 minutes to scan my entire library. I updated my main movies and it took 3 hours and 24 minutes to update a library of 1895 titles, BUT IT WORKED! Tried it on my VM and the exact same thing. The ONLY thing that I can think of that has changed on my system is that I did a format for anniversary update for windows 10, but that doesn't explain why 21 works, but 22/23 don't. The next thing I'm gonna try is putting original RTM of windows 10 in a VM and try that out. I could understand if I screwed something up while building this, but it's your download that I'm running lol.

Gonna go bald by the end of the weekend!
Reply
To my English speaking friends: Please correct this sentence... ;-)

Messagebox Title: Rewrite NFOs of locked items
Text: Locked state now will also be saved in NFO. Do you want rwrite all NFOs of your actually locked items?


Thanks!
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-09-23, 20:43)DanCooper Wrote: To my English speaking friends: Please correct this sentence... ;-)

Messagebox Title: Rewrite NFOs of locked items
Text: Locked state now will also be saved in NFO. Do you want rwrite all NFOs of your actually locked items?


Thanks!

Messagebox is fine
Text: Locked state will now be saved in NFO. Do you want to rewrite all NFOs of locked items?
Reply
(2016-09-23, 21:32)Fail$tyle420 Wrote:
(2016-09-23, 20:43)DanCooper Wrote: To my English speaking friends: Please correct this sentence... ;-)

Messagebox Title: Rewrite NFOs of locked items
Text: Locked state now will also be saved in NFO. Do you want rwrite all NFOs of your actually locked items?


Thanks!

Messagebox is fine
Text: Locked state will now be saved in NFO. Do you want to rewrite all NFOs of locked items?
Thank you Big Grin
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
Hi,
When I change a poster in ember media and then in my kodi, I update media info I cant see the new poster. Somebody could help me please?
Thanks
Reply
(2016-09-25, 00:03)mierdatuti Wrote: Hi,
When I change a poster in ember media and then in my kodi, I update media info I cant see the new poster. Somebody could help me please?
Thanks

In Kodi are you choosing to refresh your movie? Select the movie and choose info, then refresh/reload and it should show up. If not, give it about 24-48 hours and it will take.
Reply
In my experience, when you change a poster in EMM and want it to replace the one in Kodi, refresh doesn't always ...or rarely fixes the issue.

You can use Texturecache Utility to auto push it in a 2 seconds OR you can simply select the movie, context menu, manage, delete...and on rescan, it'll update to the new one. OR, if you have Artwork Downloader installed, you can go to the movie, context menu, manage, Artwork Downloader: Manual, and your new poster will be the 1st option.
Reply
  •   
  • 1
  • 50
  • 51
  • 52(current)
  • 53
  • 54
  • 171
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52