•   
  • 1
  • 103
  • 104
  • 105(current)
  • 106
  • 107
  • 171
  •   
WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
(2017-07-27, 16:23)komplex Wrote: With subtitles i've noticed that unless it has language set it doesn't get recognized by Ember
It sees
PHP Code:
Text
ID                                       
3
Format                                   
UTF-8
Codec ID                                 
S_TEXT/UTF8
Codec ID
/Info                            UTF-8 Plain Text
Language                                 
English
Default                                  : No
Forced                                   
No 

But not
PHP Code:
Text
ID                                       
3
Format                                   
UTF-8
Codec ID                                 
S_TEXT/UTF8
Codec ID
/Info                            UTF-8 Plain Text
Default                                  : Yes
Forced                                   
No 

Thx for your information. I've added a entry on our bug tracker to check that: Link
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
Just on the subtitle thing too, if you have a lot of videos with audio or subtitles set to und or you want to remove unwanted audio/subtitles or set their language https://www.htpc-tools.de/mkv-optimizer/ is a handy tool
Reply
(2017-07-27, 15:39)DanCooper Wrote: For the search results list we use the search results from IMDB: Link
As you can see, the title is "Arthur 3: la guerre des deux mondes". At this point we don't parse the details page for each search result, that would take much too long. Only if you select an entry or while full scraping we parse the details page with all information and AKA titles.
When I use that link, I get 'Arthur 3: The War of the Two Worlds', which is what I want, and not the original language title that you get. Maybe the imdb page knows I'm in the US and only shows me the english title?
Quote:Image

I don't want the AKA title so why does the 'Manual IMDB Entry' field mysteriously does more work and gets it?

I currently have 'Force Title Language' set to USA.
Quote:Image

If I change it to blank, the search results still shows the original title, BUT the manual imdb entry now shows the original title instead of the AKA USA title.
Quote:Image

If we look at the imdb AKA section...
Quote:Image
It looks like:
  • Seach will return the 'original title'
  • IMDB manual entry will use the Forced language option and return the matching AKA title
BUT how do I get the World-wide english title, which for me, is the same title used on IMDB for this movie? In the Force Title Language dropdown, there is no option for World-wide. Leaving it blank results in the original title and not the world-wide title.
Reply
Hello,
i have a folder X:\shows\
where are all my tv shows inside.
I have on folder inside which i wanna exclude in emm but its not working.
I can set the name in emm but when i chose the folder the "cross" in ember stays red.
Are there any known issues excluding folders in emm?

best regards
Reply
(2017-07-27, 18:18)sherlock_homeless Wrote: Hello,
i have a folder X:\shows\
where are all my tv shows inside.
I have on folder inside which i wanna exclude in emm but its not working.
I can set the name in emm but when i chose the folder the "cross" in ember stays red.
Are there any known issues excluding folders in emm?

best regards

Copy the path into the text field and press the green + button to add the path to the "Excluded Directories" list. The red X button is only to remove a path from the list.

Image
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
There is a movie called "...and justice for all." on imdb. I scraped with Ember and it wasn't showing up in Kodi (it stars Al Pacino, so I checked his actor page just to make sure it wasn't just showing up named something else). I re-named it "and justice for all" in Ember and then re-scraped with Kodi.. Still not showing up.

I have a sql database for Kodi for sharing my library. Do I need to reset that to get it to show up, or is it some kind of bug in Kodi?
Reply
I just tried scraping the movie you mention.

I first named it ...And Justice for All (1979) and Kodi did not see it. Probably the leading "." makes it hidden to Kodi

I then named it And Justice for All (1979) and scraped first time.

I use Win10, v17.3 and TMDB is the scraper and used Kodi as the scraper.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
I think there is a bug about MPAA.

If you use this setting:

MPAA→ON
Certifications→ON→limit→USA
Use certifications for MPAA→ON
Only if no MPAA is found→ON

Then if no MPAA found, in NFO:

Certification is filled with found value (ex: USA:Approved)
MPAA data remains empty instead of being filled with USA:Approved


BUT if you use the same setting just replacing this one:

Certifications→ON→limit→France

Then if no MPAA found, in NFO:

Certification is still filled with found value (ex: France:U)
But MPAA data is properly filled with France:U

Movie tested: 12 Angry Men

NFO certification and MPAA data cleaned up before each test with a refresh in EMM.

How is that?

Same issue if you try to force with these settings:
MPAA→OFF
Certifications→ON→limit→USA
Use certifications for MPAA→ON
Only if no MPAA is found→OFF
  • Windows 10 x64
  • Kodi 17.6
Reply
(2017-07-28, 11:25)fred_gaou Wrote: I think there is a bug about MPAA.

If you use this setting:

MPAA→ON
Certifications→ON→limit→USA
Use certifications for MPAA→ON
Only if no MPAA is found→ON

Then if no MPAA found, in NFO:

Certification is filled with found value (ex: USA:Approved)
MPAA data remains empty instead of being filled with USA:Approved


BUT if you use the same setting just replacing this one:

Certifications→ON→limit→France

Then if no MPAA found, in NFO:

Certification is still filled with found value (ex: France:U)
But MPAA data is properly filled with France:U

Movie tested: 12 Angry Men

NFO certification and MPAA data cleaned up before each test with a refresh in EMM.

How is that?

Same issue if you try to force with these settings:
MPAA→OFF
Certifications→ON→limit→USA
Use certifications for MPAA→ON
Only if no MPAA is found→OFF

Yes, it's a bug.
We use a converting table if the certification limit is set to "USA":

Code:
Public Shared Function USACertToMPAA(ByVal sCert As String) As String
        If String.IsNullOrEmpty(sCert) Then Return String.Empty

        Select Case sCert.ToLower
            Case "usa:g"
                Return "Rated G"
            Case "usa:pg"
                Return "Rated PG"
            Case "usa:pg-13"
                Return "Rated PG-13"
            Case "usa:r"
                Return "Rated R"
            Case "usa:nc-17"
                Return "Rated NC-17"
        End Select
        Return String.Empty
    End Function

As you can see the value "usa:approved" and "usa:not-approved" will not be considered and the result will be an empty string. The certifications "approved" and "not approved" are very old MPAA ratings from a time before MPAA also recommended the age for each movie. I will fix the bug in this way:

Code:
Public Shared Function USACertToMPAA(ByVal sCert As String) As String
        If String.IsNullOrEmpty(sCert) Then Return String.Empty

        Select Case sCert.ToLower
            Case "usa:g"
                Return "Rated G"
            Case "usa:pg"
                Return "Rated PG"
            Case "usa:pg-13"
                Return "Rated PG-13"
            Case "usa:r"
                Return "Rated R"
            Case "usa:nc-17"
                Return "Rated NC-17"
            Case "usa:approved"
                Return "Approved"
            Case "usa:not-approved"
                Return "Not Approved"
            Case Else
                Return sCert
        End Select
    End Function


Has been fixed for next release: Github
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
Request

When we use Trakt scraper to get personal rating, it overwrites IMDB values like:

Code:
<rating>6</rating>
<votes>1</votes>

instead of

Code:
<rating>7.4</rating>
<votes>186313</votes>

So we loose those extra IMDB values in EMM and Kodi.

Personal rating should create a special NFO data field like <userrating> that could be sync with KI with the userrating entry in movie and movie_view tables in Kodi DB.

The workaround that will work faster than EMM+Trakt is too disable Trakt scraper and use Trakt addon in Kodi to sync watched state and user rating values.
  • Windows 10 x64
  • Kodi 17.6
Reply
(2017-07-28, 13:14)fred_gaou Wrote: Request

When we use Trakt scraper to get personal rating, it overwrites IMDB values like:

Code:
<rating>6</rating>
<votes>1</votes>

instead of

Code:
<rating>7.4</rating>
<votes>186313</votes>

So we loose those extra IMDB values in EMM and Kodi.

Personal rating should create a special NFO data field like <userrating> that could be sync with KI with the userrating entry in movie and movie_view tables in Kodi DB.

The workaround that will work faster than EMM+Trakt is too disable Trakt scraper and use Trakt addon in Kodi to sync watched state and user rating values.

With version of Ember do you use? Ember Alpha 1.4.8.0 Alpha 23.3 writes the value to the new <userrating> node.
I think <userrating> is only supported by Kodi 16 and higher. So all older versions of Ember can only use the <rating> and <votes> nodes for user rating.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2017-07-28, 13:14)fred_gaou Wrote: Request

Requests in forum will be ignored. We have a bug tracker for that and I can't remember hundreds of requests in my brain. The brain will be reset each weekend!
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
Help!! I just updated from 1.4.72 beta to 1.4.8.0 beta and now when I run Ember Media Manager all my artwork is gone, what did I do wrong??
Reply
(2017-07-28, 13:40)the_beast_1234 Wrote: Help!! I just updated from 1.4.72 beta to 1.4.8.0 beta and now when I run Ember Media Manager all my artwork is gone, what did I do wrong??

Case 1: you've not enabled it to show (we've changed that setting):
Image

Case 2: you've not enabled that file names in Settings => Movies => Files and Sources => File Naming that the images have. Fix it and run Tools => Reload all Movies to rescan the folders
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
Case 1 it was, thank you for the assist and the super quick reply. Smile
Reply
  •   
  • 1
  • 103
  • 104
  • 105(current)
  • 106
  • 107
  • 171
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52