Due to maintenance, our forum will be offline for a short while on Monday June 1st, around 22:00 UTC.

  •   
  • 1
  • 113
  • 114
  • 115(current)
  • 116
  • 117
  • 232
  •   
Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2016-10-29, 13:32)Siutsch Wrote: [cut]

So: what's the benefit of this special 3D Kodi build, which indeed can decode iso MVC files, but only if reduced to a HSBS FullHD file, compared to the HSBS files I already have from many 3D movies?

Thanks for an explanation and again sorry, if this was already answered.
Short version, you can get a full HD 3D output with this specific Kodi version, so that's the benefit. If it doesn't work with the setup you're using, then there is something to be fixed. The Intel HD 4600 is capable to do it.
Kodi 18.2 RC [MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics] Windows 10 - 1903 [3840x2160/60Hz]
4k video trough HDMI 2.0a port direct to LG Oled 55EF950V (with 2018 panel) HDR [success] HD audio through HDMI 1.4 port direct to NR1606 receiver
Kodi [4k/60Hz success] [i3D 4k success] HDR done by Kodi [no support]
Reply
Well, I just tried to install the 28-October-2016 Windows MVC Build. I can tell you that this build plays MVC 3D fine with appropriate HD Audio (Dolby Atmos, DTS-X, etc.). However I still have the problem where skipping through a 3D Movie with a Dolby Atmos Soundtrack only can slow up or hang up the movie (DTS-X and all other HD Soundtracks work fine). This problem is only with 3D movies with Atmos Soundtracks and I have only tested with 3D MKV files. It's the same problem I notice with the September 22nd Build.

Now the real problem with the 28-October-2016 Windows MVC Build is that you cannot install any Add-Ons or Updates from the internet. All attempts to install updates fail, even though the add-ons were easily downloaded. I tried to install the 28-October-2016 Build three times, all with the same results. I even tried to change the Read/Write privileges of the installed Kodi folders/files to no avail. When I went back to the September 22nd Build I was easily able to install add-ons without failure. Something has changed with the installation of this build. Has anyone else had this experience?
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
Upgrading any add-on currently fails on Windows with the current beta 5 master. Since afdchin's mvc is based on this build, the same problem occurs here.
Reply
(2016-10-30, 00:52)bollstedt Wrote: Upgrading any add-on currently fails on Windows with the current beta 5 master. Since afdchin's mvc is based on this build, the same problem occurs here.

Hmmm. Thanks for the explanation and confirmation of my problem with the recent build.
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
(2016-10-29, 14:06)p750mmx Wrote:
(2016-10-29, 13:32)Siutsch Wrote: [cut]

So: what's the benefit of this special 3D Kodi build, which indeed can decode iso MVC files, but only if reduced to a HSBS FullHD file, compared to the HSBS files I already have from many 3D movies?

Thanks for an explanation and again sorry, if this was already answered.
Short version, you can get a full HD 3D output with this specific Kodi version, so that's the benefit. If it doesn't work with the setup you're using, then there is something to be fixed. The Intel HD 4600 is capable to do it.

Hmm.
What you mean with a "full HD 3D output" is 1920x1080 and with both movies (for both eyes) reduced to side by side (HSBS)?

I thought, both movies with full resolution can be send completely to the output device, like if you use a Bluray player or so.

But if I set "Decode the stereo stream from 3D files" in the settings, then I can choose only from hou, hsbs, analgyph and these things, so both available full hd movies within the MVC streams will always be reduced to one full hd movie.
Whether I choose this setting or not, my beamer don't recognize a 3D movie in auto mode, only with choosing this, I got a HSBS file and have to set to this setting manually.

Still I do not understand the bebefit of this special version.

Perhaps someone can explain this a bit more ...

Thanks.
Reply
(2016-10-30, 10:27)Siutsch Wrote:
(2016-10-29, 14:06)p750mmx Wrote:
(2016-10-29, 13:32)Siutsch Wrote: [cut]

So: what's the benefit of this special 3D Kodi build, which indeed can decode iso MVC files, but only if reduced to a HSBS FullHD file, compared to the HSBS files I already have from many 3D movies?

Thanks for an explanation and again sorry, if this was already answered.
Short version, you can get a full HD 3D output with this specific Kodi version, so that's the benefit. If it doesn't work with the setup you're using, then there is something to be fixed. The Intel HD 4600 is capable to do it.

Hmm.
What you mean with a "full HD 3D output" is 1920x1080 and with both movies (for both eyes) reduced to side by side (HSBS)?

I thought, both movies with full resolution can be send completely to the output device, like if you use a Bluray player or so.

But if I set "Decode the stereo stream from 3D files" in the settings, then I can choose only from hou, hsbs, analgyph and these things, so both available full hd movies within the MVC streams will always be reduced to one full hd movie.
Whether I choose this setting or not, my beamer don't recognize a 3D movie in auto mode, only with choosing this, I got a HSBS file and have to set to this setting manually.

Still I do not understand the bebefit of this special version.

Perhaps someone can explain this a bit more ...

Thanks.

Under Display > Stereoscopic 3D > Preferred Mode should be set to Hardware based (check you have everything set up like hdmkv's first post - the screen in question is the 11th picture in the imgur part). Make sure all the options are set up as in this post - it doesn't sound like you have everything set up correctly if it is asking you what format to use as if set up correctly, it should just output it properly without even asking you which format to use.

If you have all this set up properly, the video will play back in frame packing (not Top / Bottom or Side By Side or anything else where the resolution is less) just as it would from a bluray player (or your PS3).

Hope that helps
Reply
(2016-10-30, 12:32)woronczak Wrote:
(2016-10-30, 10:27)Siutsch Wrote:
(2016-10-29, 14:06)p750mmx Wrote: Short version, you can get a full HD 3D output with this specific Kodi version, so that's the benefit. If it doesn't work with the setup you're using, then there is something to be fixed. The Intel HD 4600 is capable to do it.

Hmm.
What you mean with a "full HD 3D output" is 1920x1080 and with both movies (for both eyes) reduced to side by side (HSBS)?

I thought, both movies with full resolution can be send completely to the output device, like if you use a Bluray player or so.

But if I set "Decode the stereo stream from 3D files" in the settings, then I can choose only from hou, hsbs, analgyph and these things, so both available full hd movies within the MVC streams will always be reduced to one full hd movie.
Whether I choose this setting or not, my beamer don't recognize a 3D movie in auto mode, only with choosing this, I got a HSBS file and have to set to this setting manually.

Still I do not understand the bebefit of this special version.

Perhaps someone can explain this a bit more ...

Thanks.

Under Display > Stereoscopic 3D > Preferred Mode should be set to Hardware based (check you have everything set up like hdmkv's first post - the screen in question is the 11th picture in the imgur part). Make sure all the options are set up as in this post - it doesn't sound like you have everything set up correctly if it is asking you what format to use as if set up correctly, it should just output it properly without even asking you which format to use.

If you have all this set up properly, the video will play back in frame packing (not Top / Bottom or Side By Side or anything else where the resolution is less) just as it would from a bluray player (or your PS3).

Hope that helps

Thanks for that explnation. Smile

For prefered mode I only have:

- Same as movie
- Over / Under
- Side by side
- Analgyph red / cyan
- Analgyph green / magenta
- Analgyph yellow / blue
- Interlaced
- Checkerboard

I don't have "hardware based".
Reply
(2016-10-30, 10:27)Siutsch Wrote: Hmm.
What you mean with a "full HD 3D output" is 1920x1080 and with both movies (for both eyes) reduced to side by side (HSBS)?

I thought, both movies with full resolution can be send completely to the output device, like if you use a Bluray player or so.

But if I set "Decode the stereo stream from 3D files" in the settings, then I can choose only from hou, hsbs, analgyph and these things, so both available full hd movies within the MVC streams will always be reduced to one full hd movie.
Whether I choose this setting or not, my beamer don't recognize a 3D movie in auto mode, only with choosing this, I got a HSBS file and have to set to this setting manually.

Still I do not understand the bebefit of this special version.

Perhaps someone can explain this a bit more ...

Thanks.

First off I assume that you have a TV Display that is capable of displaying ALL 3D images sent to it through your HDMI input. That is you display can decode MVC, SBS, and TAB 3D formats and automatically sense and recognize when a 3D image is being sent to your HDMI input. And I assume your Windows Hardware is capable of processing 3D movie information.

In addition verify that under the Settings/Player/Videos Stereoscopic 3D setting the Playback mode of stereoscopic 3D videos is set to Preferred mode AND that the Decode the stereo stream from 3D files is ticked ON. Then verify under the Settings/System/Display Stereoscopic 3D setting the - Preferred mode is set to either Hardware based or same as movie (both these settings work for me).
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
(2016-10-30, 12:52)Siutsch Wrote:
(2016-10-30, 12:32)woronczak Wrote:
(2016-10-30, 10:27)Siutsch Wrote: Hmm.
What you mean with a "full HD 3D output" is 1920x1080 and with both movies (for both eyes) reduced to side by side (HSBS)?

I thought, both movies with full resolution can be send completely to the output device, like if you use a Bluray player or so.

But if I set "Decode the stereo stream from 3D files" in the settings, then I can choose only from hou, hsbs, analgyph and these things, so both available full hd movies within the MVC streams will always be reduced to one full hd movie.
Whether I choose this setting or not, my beamer don't recognize a 3D movie in auto mode, only with choosing this, I got a HSBS file and have to set to this setting manually.

Still I do not understand the bebefit of this special version.

Perhaps someone can explain this a bit more ...

Thanks.

Under Display > Stereoscopic 3D > Preferred Mode should be set to Hardware based (check you have everything set up like hdmkv's first post - the screen in question is the 11th picture in the imgur part). Make sure all the options are set up as in this post - it doesn't sound like you have everything set up correctly if it is asking you what format to use as if set up correctly, it should just output it properly without even asking you which format to use.

If you have all this set up properly, the video will play back in frame packing (not Top / Bottom or Side By Side or anything else where the resolution is less) just as it would from a bluray player (or your PS3).

Hope that helps

Thanks for that explnation. Smile

For prefered mode I only have:

- Same as movie
- Over / Under
- Side by side
- Analgyph red / cyan
- Analgyph green / magenta
- Analgyph yellow / blue
- Interlaced
- Checkerboard

I don't have "hardware based".

Usually that means that you don't have supported hardware.

What CPU is in your box?
You might have to fiddle with drivers if it is actually supported
Reply
(2016-10-30, 12:57)woronczak Wrote:
(2016-10-30, 12:52)Siutsch Wrote:
(2016-10-30, 12:32)woronczak Wrote: Under Display > Stereoscopic 3D > Preferred Mode should be set to Hardware based (check you have everything set up like hdmkv's first post - the screen in question is the 11th picture in the imgur part). Make sure all the options are set up as in this post - it doesn't sound like you have everything set up correctly if it is asking you what format to use as if set up correctly, it should just output it properly without even asking you which format to use.

If you have all this set up properly, the video will play back in frame packing (not Top / Bottom or Side By Side or anything else where the resolution is less) just as it would from a bluray player (or your PS3).

Hope that helps

Thanks for that explnation. Smile

For prefered mode I only have:

- Same as movie
- Over / Under
- Side by side
- Analgyph red / cyan
- Analgyph green / magenta
- Analgyph yellow / blue
- Interlaced
- Checkerboard

I don't have "hardware based".

Usually that means that you don't have supported hardware.

What CPU is in your box?
You might have to fiddle with drivers if it is actually supported

The Zotac ID92 has:

- Intel Core i5-4570T (dual core, 2.9 GHz up to 3.6 GHz)
- Intel H87 Chipset
- Intel HD Graphics 4600

What I could read is, that it is's OK for 3D.

I have installed latest Intel drivers and set all parameters like in the screenshots.

EDIT: I don't know, if that could be the problem, but my HTCP isn't connected directly to my beamer, because I have a TV (no 3D) an beamer (3D) an need a HDMI switch (4x2) for that (my amlifier hasn't HDMI switch).

But my PS3, who can play 3D Blurays can play them through the HDMI switch and my beamer detects 3D automatically if I use this, so I think, it must work with my HTPC too.
Reply
(2016-10-30, 13:13)Siutsch Wrote: EDIT: I don't know, if that could be the problem, but my HTCP isn't connected directly to my beamer, because I have a TV (no 3D) an beamer (3D) an need a HDMI switch (4x2) for that (my amlifier hasn't HDMI switch).

But my PS3, who can play 3D Blurays can play them through the HDMI switch and my beamer detects 3D automatically if I use this, so I think, it must work with my HTPC too.

Incorrect EDID data could be your problem. Your HTPC has to read your displays EDID in order to determine what resolutions can be displayed and whether or not your display is 3D Capable (and which 3D can it display). Unless you bought an HDFury Integral or HDFury 4K splitter (both can present an preset EDID to your HTPC even if your display has not completed its HDMI handshaking yet), your HDMI Switch has to pass the proper EDID to your HTPC or else Kodi will NOT send out the proper 3D signal. You may having timing issues, since first your HTPC has to complete HDMI handshaking with the active display (assuming it sees it correctly), than after Kodi starts it will ask Windows AGAIN for the EDID before proceeding. If that EDID is wrong or hasn't loaded, Kodi won't display 3D or even 1080p correctly (and certainly not 4K).

Try connecting your beamer (3D capable) directly to your HTPC and see if MVC 3D works. If it does, then it is a EDID misread that is causing your problem.
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
I would try connecting ur htpc directly to the projector, rebooting the computer and see if that works. could try different hdmi cable as well....
Reply
(2016-10-30, 14:50)woronczak Wrote: I would try connecting ur htpc directly to the projector, rebooting the computer and see if that works. could try different hdmi cable as well....

(2016-10-30, 13:13)Siutsch Wrote: But my PS3, who can play 3D Blurays can play them through the HDMI switch and my beamer detects 3D automatically if I use this, so I think, it must work with my HTPC too.

Also part of your problem may be a timing issue, so make sure the projector is on first before your computer reboots or turns on.
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
(2016-10-29, 23:23)ppoulos Wrote: Well, I just tried to install the 28-October-2016 Windows MVC Build. I can tell you that this build plays MVC 3D fine with appropriate HD Audio (Dolby Atmos, DTS-X, etc.). However I still have the problem where skipping through a 3D Movie with a Dolby Atmos Soundtrack only can slow up or hang up the movie (DTS-X and all other HD Soundtracks work fine). This problem is only with 3D movies with Atmos Soundtracks and I have only tested with 3D MKV files. It's the same problem I notice with the September 22nd Build.

I have just tested some more, and the problem I am having occurs mostly with MVC 3D .mkv files created by MakeMKV. When I tried playing back the original 3D .iso files with Dolby Atmos Soundtracks the playback was responsive, no longer delaying significantly when chapter skipping, restarting the movie, or fast forwarding or reversing. The downside of using .iso files is having to choose the proper title to run if the perceived main title is not the correct one. If you stop the movie then resume playback the perceived main title is again selected, not the actual one you originally had selected from the Simplified Bluray Menu. The only way I can reproduce the above playback issues with .iso files is to set Bluray Disc Playback to show the Bluray Menu. If the Bluray Menu is simple enough to actual work, and I select the title I want with Dolby Atmos Soundtracks, the playback will stutter and stop.

I have converted all my 3D .iso files into 3D .mkv files to eliminate having to select the proper title. In some instances I have also eliminated unneeded subtitle tracks and sometimes even upgraded the soundtrack (for example the 3D version of Goosebumps has a DTS-MA 7.1 Soundtrack, while the 2D version of Goosebumps has a Dolby Atmos soundtrack - I have remuxed my .mkv 3D version of Goosebumps to have a Dolby Atmos Soundtrack). So I assume but cannot verify that the problem lies with the current Kodi Windows MVC Build from September 22nd onward having problems playing back .mkv 3D MVC files and probably not related to the Graphic Drivers of my Intel NUC. Has anybody else seen this problem with playback?
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
(2016-10-30, 15:07)ppoulos Wrote:
(2016-10-30, 14:50)woronczak Wrote: I would try connecting ur htpc directly to the projector, rebooting the computer and see if that works. could try different hdmi cable as well....

(2016-10-30, 13:13)Siutsch Wrote: But my PS3, who can play 3D Blurays can play them through the HDMI switch and my beamer detects 3D automatically if I use this, so I think, it must work with my HTPC too.

Also part of your problem may be a timing issue, so make sure the projector is on first before your computer reboots or turns on.

Thank you both for these tips, I will try that and report back.
Reply
  •   
  • 1
  • 113
  • 114
  • 115(current)
  • 116
  • 117
  • 232
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
Intel HTPCs/NUCs & Kodi-native 3D MVC Playback4.310
This forum uses Lukasz Tkacz MyBB addons.