XBMC LiveUSB (formerly "LiveXBMC") V1: an USB disk image
For the braves only...

I have been playing recently with Ubuntu Mobile and Embedded toolkit, and finally managed to create a live USB disk booting a minimal Ubuntu distro with XBMC. Having an Intel 965 based PC, I preconfigured the image with Intel X drivers, but all the open source xorg drivers are included for anyone to play with it. Restricted drivers are not included, though, you you are on your own - apt-get will be your friend.

Some details:
* Requires 512 MB USB flash disk
* Default user: "xbmc" - password: "password" (no quotes)
* Live R/W image, all changes are saved to the USB disk
* Support for Intel GPUs - (XBMC requires high-end GPU)
* DHCP on eth0 enabled
* FTP and SSH servers automatically started, FTP not configured
* lircd included, not configured.
* ivman included (removable media auto-mounting)
* nice XBMC usplash theme (courtesy of Duduke)!!!

Bear in mind that:

* This is a PROOF-OF-CONCEPT only, it is not supported by all means neither by the TeamXBMC nor by myself! No
* it's not supposed to be working, it's a technology preview! Sad

Finally the download link: https://sourceforge.net/project/showfile..._id=571325

Oh my yes! will try and report my finds. Although I don't have Intel but nvidia but one must try!

Thank you!
I'm very curious how it works and such.. but I've never booted anything from an USB stick.. got a USB-stick but how exactly will i get the .IMG on the USB? cause i dont think CTRL+C CTRL+V would work Wink

ANy program to 'burn' the img to the USB? Smile

Thanks for the help
I recommend this method if you're using Linux:

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

It boots Smile

Although I get issues with the Xorg but that was to be expected as I'm using a nvidia, and quite a new one to.
Oh well, Keep up the good work!
anyone using Windows to prepare the flash disk? .. Wink
Google will retun a million of similar pages, but this one seems more accurate than others:



PS. if you remove-rename the file ext3fs.img you have a read-only system (changes are not kept when rebooting) with a pure X11+fluxbox shell.
yep using Windows to prepare the flash disk Wink

well tried a couple of ISO/IMG extracting programs, almost none seemed to handle the file (IsoBuster and MagicIso are a no-go).

Then i found a program 'undisker'.. it will copy directly from .IMG to your USB drive and format it for you.. (as far as I know atleast)

Just have to use Syslinux to make it bootable and then i'll try it..

PS. For Undisker see: http://www.undisker.com
On windows you can use hp usb disk storage format tool. It will take an image file and fix everything for you.

DOn't know the adress now but, hp.com maybe Smile
im having issues getting this on my flash drive....anyone have any pointers? I'm trying to set my drive up in windows....but I cant help but feel like I am missing something
I have the HP tool already, but it only gives formatting options for FAT32 and NTFS. Also, doesn't have any tools for IMG files, just says 'No dos files found'. Using x64.

I would love to use this, i bought a 4gig Flash Voyager (Corsair) yesterday JUST SPECIFICALLY to install Ubuntu and XBMC and saw this today, making it even easier to do. I did find this a little tricky. I have the live cd for now, but am not linux savvy AT ALL, as i'm sure a lot of people aren't. But willing to learn.

One point i read over in the Tom's Hardware forums, which is not good, and something (of ALL tutorials i've read of installing linux on USB) is that THEY said it's NOT recommended for a BIG reason, the average USB stick (gave pretty specific and highly detailed specs of why.) has an average of 10,000 writes, which for an OS, one would find a USB stick to start giving error's from wear and tear after a period of time quicker then one thinks. Thats bad news to hear. Anyone hear otherwise? I know Tom's Hardware is one of the most knowledgable and respected site on the net.

But either way, i still have a 300gig USB hardrive sitting around not using anyway, since i use my 500gig netdrive since then, and want to get this working still, whether on my USB stick, or my USB hard drive. I'd like to start getting used to Ubuntu, and XBMC linux. I'll be closely following this thread for sure, in excitement of this easier solution, for the linux newbs.
After formatting the usb drive with the hp software tool:

1. use the undisker tool to take apart the img file. copy the individual files to the usb drive. www.undisker.com

2. the use the Syslinux 3.11 software on this website http://www.althack.com/2006/03/10/ho...n-a-usb-drive/ following the instructions on that webpage.

3. Set your computer bios to boot from the usb drive and it should boot to xbmc.
I used that (BTW-the link isn't working, but used the one on previous page to find.) info and retried things. I unpacked everything the 1st time simply using UltraISO, and unizp'd all the same files as this method, but the version of HP format tools this time allowed me to format with FAT, whereas the other version only let me do FAT32 or NTFS, so maybe that's what fixed it.
But, it still doesn't boot into Ubuntu. What happens is, after a few seconds, it says "Enter name of boot, to boot .... Hit Enter, 2nd line BOOT:" so i hit enter, then it shows a bunch of lines for the next maybe 8-9 seconds, then goes and shows a barely readable screen (about 20 lines or less) which keeps blanking and redisplaying REALLY fast (per 1/2 sec.) constantly showing the same thing, and constantly refreshing infinately, with nothing ever progressing. I can barely read "XBMC Distrubution isn't responsible for....", and some other stuff.
The only thing i can seem to do is CTRL-ALT-DEL, which then says "CTRL-ALT-DEL Recognized, and will reboot" or SOMETHING like that. I did follow the instructions to a T.

-Formatted FAT system, 4gigs.
-Undisk'd the files from the 1st page main file over to the USB drive
-Grabbed syslinux file, unzip'd to C:\syslinux, CMD'd into that dir, and did said command "syslinux.exe -f I:" (I is my USB drive letter).
-Rebooted, and got the quickly constantly refreshing screen of info after it looks like it tried to boot a bunch of stuff up til that part.

The ONLY part i didn't do, since it seemed to partaining to Ubuntu install, is the unzipping of DSL files, since i'm using the ones from this main zip file. What could be causing this to happen? Did i still do something wrong by chance?

I am using AMD dual-core 4400, nvidia GF 7600 256MB video card.
It is only setup for intel graphics, so is probably the graphics not working.

If it boots it sounds like the whole USB writing thing went perfectly.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Awww, shucks. Guess i'll have to wait til an nvidia build, cause i know nothing about linux to make my own fix. Oh well, i think i might pull my 300gig usb drive out and put Ubuntu on it and start learning, along with getting used to building xbmc on it. Since no one is as interested in the pc builds, i might as well get used to ubuntu for the linux xbmc builds. Shame, i'm already using pc builds, and does everything i need it to do that my xbox can do, since i don't use visualizations much at all anyway, otherwise, it's doing what i need it to do. But i realize i'm still missing some things that isn't in pc builds yet in the HD area.

Thanks for you work making this image still. It'll be very usefull for the ATI users out there. Hopefully someone can make a nvidia build too though.
The URL that pike posted works flawlessly, The HP is good for dos boots, used it in my work. Didn't now if it worked with linux and it seems to be a bit troublesome to work as some here posted.

A little feedback to the author, I have issues with the boot process as it doesn't seem to search for the installation folder in more than 4 drives, I have more than 4 drives and this makes the boot not to work from time to time, This is because linux for some reason switch the /dev/sdxx for my drives from boot to boot (happens in ubuntu to, veeeery anoying). Other than that it seems to boot flawlessly (Not in X but this is because I don't have intel)

Great work!

Logout Mark Read Team Forum Stats Members Help
XBMC LiveUSB (formerly "LiveXBMC") V1: an USB disk image0
This forum uses Lukasz Tkacz MyBB addons.