•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 16
  •   
Release Control Kodi with your Google Home
Simple way to address Google Home is by using the keyword

(h)eygooge(e)

just pronounce the syllables that arent in brackets. Google Home should trigger (German language version does Wink ). Beats saying Hey, or OK and google all the time, which contain syllables that are harder to pronounce. Also is quicker. Smile
Reply
Hi,

Is this the only way to get Home integration set up as it seems a bit daunting? I thought there was talk of baking it into Kodi itself
Reply
(2020-02-09, 13:31)pinn Wrote: Hi,

Is this the only way to get Home integration set up as it seems a bit daunting? I thought there was talk of baking it into Kodi itself

It is not as hard as it seems. Smile

Use Glitch as your webserver (At first, if you are not hosting it on your own.).
Follow the tutorial on github.
Skip the optional steps at first.

Once the Glitch instance is set up, you will have a 'test' menu in the Glitch project to send out test commands. (Without having interfaced to Home yet) - use that to troubleshoot all your potential connection issues. Your port forwarding on your home router. Your dynamic DNS (if your IP (the one you get from your ISP) changes over time, to get one that doesnt change).

Once you have that working -

- try to wrap your head around what IFTTT does, and how it communicates to the glitch server. Smile

Ensuring that you have port forwarding on a port from your home router into the internet at large, and ensuring, that you have a static IP (via a dynamic DNS service, or because your ISP gives you one by default) is the hardest part. Smile


Also, to test if port forwarding works, use a mobile phone dialed into a cellular network (to surf to yourip:port - in any browser), and dont try to pull up the page on your local network. Port forwarding actually only forwards to WAN (the internet at large) and not within your home network. Smile (Took me ten minutes to wrap my head around at first.. Wink )
Reply
(2020-03-06, 02:02)harlekin Wrote:
(2020-02-09, 13:31)pinn Wrote: Hi,

Is this the only way to get Home integration set up as it seems a bit daunting? I thought there was talk of baking it into Kodi itself

It is not as hard as it seems. Smile

Use Glitch as your webserver (At first, if you are not hosting it on your own.).
Follow the tutorial on github.
Skip the optional steps at first.

Once the Glitch instance is set up, you will have a 'test' menu in the Glitch project to send out test commands. (Without having interfaced to Home yet) - use that to troubleshoot all your potential connection issues. Your port forwarding on your home router. Your dynamic DNS (if your IP (the one you get from your ISP) changes over time, to get one that doesnt change).

Once you have that working -

- try to wrap your head around what IFTTT does, and how it communicates to the glitch server. Smile

Ensuring that you have port forwarding on a port from your home router into the internet at large, and ensuring, that you have a static IP (via a dynamic DNS service, or because your ISP gives you one by default) is the hardest part. Smile


Also, to test if port forwarding works, use a mobile phone dialed into a cellular network (to surf to yourip:port - in any browser), and dont try to pull up the page on your local network. Port forwarding actually only forwards to WAN (the internet at large) and not within your home network. Smile (Took me ten minutes to wrap my head around at first.. Wink

Yep - have got it all working now with a bit of help from the members on github. Great program!
Reply
Hi,

Anyone get this command work : YOUR_NODE_SERVER/playepisode?q={{TextField}}&e= {{NumberField}}
It's to launch a specific episode.

On IFTTT got this : Unable to make web request. Your server returned a 500

Only this command doesn't work for me, all others works like a charm Smile
Thanks.
Reply
(2020-03-25, 18:21)kokoplex Wrote: Hi,

Anyone get this command work : YOUR_NODE_SERVER/playepisode?q={{TextField}}&e= {{NumberField}}
It's to launch a specific episode.

On IFTTT got this : Unable to make web request. Your server returned a 500

Only this command doesn't work for me, all others works like a charm Smile
Thanks.

Shouldn't it be: YOUR_NODE_SERVER/playtvshow?q={{TextField}} *delay
Reply
(2020-03-25, 19:01)pinn Wrote:
(2020-03-25, 18:21)kokoplex Wrote: Hi,

Anyone get this command work : YOUR_NODE_SERVER/playepisode?q={{TextField}}&e= {{NumberField}}
It's to launch a specific episode.

On IFTTT got this : Unable to make web request. Your server returned a 500

Only this command doesn't work for me, all others works like a charm Smile
Thanks.

Shouldn't it be: YOUR_NODE_SERVER/playtvshow?q={{TextField}} *delay 
This command play a random episode from a tv show.
I want to play a specific episode not random.
Reply
hi and thanks for this wonderful app

i have ONE problem though: has anybody got the STANDBYTV function working? I.e. turn OFF the TV via googlekodihome?

ACTIVATETV i.e. turning the TV on works like a charm but for some reason my LG won't react to the standbytv command.

i have configured Ifttt correctly and appended the config file as per instructions. ifttt recognizes the command and passes it on.
i even tested adding a process.env['STANDBY_TV'] = 'true'; at the end of the file but that didn't work either.
Reply
(2020-04-17, 19:56)theo08 Wrote: hi and thanks for this wonderful app

i have ONE problem though: has anybody got the STANDBYTV function working? I.e. turn OFF the TV via googlekodihome?

ACTIVATETV i.e. turning the TV on works like a charm but for some reason my LG won't react to the standbytv command.

i have configured Ifttt correctly and appended the config file as per instructions. ifttt recognizes the command and passes it on.
i even tested adding a process.env['STANDBY_TV'] = 'true'; at the end of the file but that didn't work either.
I don't think it is able to do this. I achieve this by using Harmony Hub which can switch tv on/off , ps4 etc..
Reply
thanks for the reply.

well in his documentation over at github omertu gives instructions on how to do this, so i suppose it should be possible.


as i said turning the tv ON works perfectly well



Image
Reply
Hi!
I don't want to open my server outside and I don't like IFTTT, because he know a lot about me Smile 
Is there any own hosted IFTTT alternateives which I can install on my own home Ubuntu server? I need webhooks for Kodi and some cli commands for server (like service motion stop). May be more later.
Reply
Am using ifttt and glitch. Was working wonderful but then ifttt started showing applet skipped. Test command from glitch comes through but nothing else will work. Any help appreciated

Get this on glitch log when I try updating from GitHub

Could not find node ^13.9.0, using 10
node v10.15.3, with pnpm
Reply
Same (similar) issue here, IFTTT webhooks dont trigger the glitch anymore. Any advice would be appreciated.

Error message in IFTTT is:

Unable to make web request. Your server returned a 403

edit: its glitch, see: https://github.com/OmerTu/GoogleHomeKodi/issues/305
Reply
Found a way to fix the glitch 403 issue, while still keep using glitch.

Register a free account with pipedream.com, click on workflows, create a new workflow
- first step http webhook
- second step node.js

make it look like that:
Image

In http webhook click on curl - and simply copy the url you see there at the bottom (see top of the screenshot). This is the new url that has to be entered in your ifttt options, you can leave the rest as is (in ifttt).

In the node.js step you simply copy/paste in this code:
Code:
const axios = require("axios");

// Make an HTTP GET request using axios
const resp = await axios({
method: "POST",
url: `https://jsonplaceholder.typicode.com/posts`,
headers: {
"Content-Type": "application/json"
},
data: { name: "Luke" }
});
src and better formating: https://docs.pipedream.com/workflows/ste...tp-headers Wink

Then replace the url with your glitch server url (including the /whatever) and { name: "Luke" } with your {"token":"tokenpassword"}


Thats it. Works. Smile

IFTTT now sends a json request to the pipedream url, that triggers a json request to your glitch server. That means that IFTTT isnt communicating with glitch directly anymore - hence no more 403 errors. Yay. Wink

edit: Or use a RaspPi to host OmerTus GoogleHomeKodi yourself, using docker. I went for the quicker fix -- with the downside, that the solution in this thread adds some additional delay. (Not outrageous, but noticeable.)
Reply
Do I make a new workflow for each command or can it be done on one. Sorry, not a coder at all
Reply
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 16
  •   



Logout Mark Read Team Forum Stats Members Help
Control Kodi with your Google Home4
This forum uses Lukasz Tkacz MyBB addons.