•   
  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 81
  •   
Release IPTV Recorder
Hello,

Thanks for this great addon. Have a problem though. I am using this on a Windows 7 machine and am able to record an IPTV stream if I choose the "Record Once" option. It doesn't seem to record though if I choose a show to record always. Is there a setting or something I may be missing? Should I be able to record always. I see where the IPTV recorder creates the JSON file for each show it should record, but it doesn't seem to work under this option.

Thanks,
Mark
Reply
(2018-12-26, 15:28)mwkurt Wrote: Hello,

Thanks for this great addon. Have a problem though. I am using this on a Windows 7 machine and am able to record an IPTV stream if I choose the "Record Once" option. It doesn't seem to record though if I choose a show to record always. Is there a setting or something I may be missing? Should I be able to record always. I see where the IPTV recorder creates the JSON file for each show it should record, but it doesn't seem to work under this option.

Thanks,
Mark
 It still works for me on Win7 Leia.
Is there an ERROR message in kodi.log?
Have a look in the jobs folder and see if everything looks ok in the .py files.
userdata\addon_data\plugin.video.iptv.recorder\jobs
You can post or pm me one if it has sensitive urls in it (passwords etc).
Reply
Is there a Youtube video someplace which shows how to use this add-on ?

I installed it from the Repo..  it opens..  I went into settings and set my record folder and path to ffmpeg..    

But I don't see in simple PVR how to pick a program to record..    and if I launch the IPTV Recorder add-on, I don't see how to surf to a stream to record in the future..  or at all.
Reply
(2018-12-26, 16:30)pmcnamara Wrote: Is there a Youtube video someplace which shows how to use this add-on ?

I installed it from the Repo..  it opens..  I went into settings and set my record folder and path to ffmpeg..    

But I don't see in simple PVR how to pick a program to record..    and if I launch the IPTV Recorder add-on, I don't see how to surf to a stream to record in the future..  or at all.
 I haven't made any videos.
The quickstart on the first post should be enough.

This addon doesn't integrate with the IPTV Simple Client PVR gui at all.
It just uses the xmltv and m3u links from IPTV Simple Client for the programmes and channel streams data.

Can you play channels and see programs in the normal Kodi PVR using IPTV Simple Client?
If you can then just restart Kodi and wait for the xmltv/m3u to be loaded into IPTV Recorder.
There is a default wait of 60 seconds in case IPTV Simple Client gets its data from a download from another addon.
The setting is in Settings\Service.

If that works check there are channels in Channel Groups and you can play a channel from the context menu.
If that works try Record Once.
Make sure the ffmpeg path is a full path and the recordings folder is writeable.

If not have a look in kodi.log for any ERROR messages and post them.
Reply
(2018-12-26, 15:42)primaeval Wrote:
(2018-12-26, 15:28)mwkurt Wrote: Hello,

Thanks for this great addon. Have a problem though. I am using this on a Windows 7 machine and am able to record an IPTV stream if I choose the "Record Once" option. It doesn't seem to record though if I choose a show to record always. Is there a setting or something I may be missing? Should I be able to record always. I see where the IPTV recorder creates the JSON file for each show it should record, but it doesn't seem to work under this option.

Thanks,
Mark
 It still works for me on Win7 Leia.
Is there an ERROR message in kodi.log?
Have a look in the jobs folder and see if everything looks ok in the .py files.
userdata\addon_data\plugin.video.iptv.recorder\jobs
You can post or pm me one if it has sensitive urls in it (passwords etc).  
Hello...I am still using Krypton 17.6.

Here is an error that I can see in the log:

ERROR: Exception in thread Thread-125:
                                            Traceback (most recent call last):
                                              File "C:\Program Files\Kodi\system\python\Lib\threading.py", line 801, in __bootstrap_inner
                                                self.run()
                                              File "C:\Program Files\Kodi\system\python\Lib\threading.py", line 754, in run
                                                self.__target(*self.__args, **self.__kwargs)
                                              File "C:\Users\Server\AppData\Roaming\Kodi\addons\plugin.video.iptv.recorder\main.py", line 502, in record_once_thread
                                                programme = cursor.execute('SELECT channelid, title, sub_title, start AS "start [TIMESTAMP]", stop AS "stop [TIMESTAMP]", date, description, episode, categories FROM programmes WHERE uid=? LIMIT 1', (programmeid, )).fetchone()
                                              File "C:\Program Files\Kodi\system\python\Lib\sqlite3\dbapi2.py", line 69, in convert_timestamp
                                                year, month, day = map(int, datepart.split("-"))
                                            TypeError: 'NoneType' object is not callable

If needed I can post the entire log file.


There is one file in the jobs folder that has a PID suffix. The rest are Py files.

Thanks for your help!
Mark
Reply
(2018-12-26, 18:02)mwkurt Wrote:
(2018-12-26, 15:42)primaeval Wrote:
(2018-12-26, 15:28)mwkurt Wrote: Hello,

Thanks for this great addon. Have a problem though. I am using this on a Windows 7 machine and am able to record an IPTV stream if I choose the "Record Once" option. It doesn't seem to record though if I choose a show to record always. Is there a setting or something I may be missing? Should I be able to record always. I see where the IPTV recorder creates the JSON file for each show it should record, but it doesn't seem to work under this option.

Thanks,
Mark
 It still works for me on Win7 Leia.
Is there an ERROR message in kodi.log?
Have a look in the jobs folder and see if everything looks ok in the .py files.
userdata\addon_data\plugin.video.iptv.recorder\jobs
You can post or pm me one if it has sensitive urls in it (passwords etc).  
Hello...I am still using Krypton 17.6.

Here is an error that I can see in the log:

ERROR: Exception in thread Thread-125:
                                            Traceback (most recent call last):
                                              File "C:\Program Files\Kodi\system\python\Lib\threading.py", line 801, in __bootstrap_inner
                                                self.run()
                                              File "C:\Program Files\Kodi\system\python\Lib\threading.py", line 754, in run
                                                self.__target(*self.__args, **self.__kwargs)
                                              File "C:\Users\Server\AppData\Roaming\Kodi\addons\plugin.video.iptv.recorder\main.py", line 502, in record_once_thread
                                                programme = cursor.execute('SELECT channelid, title, sub_title, start AS "start [TIMESTAMP]", stop AS "stop [TIMESTAMP]", date, description, episode, categories FROM programmes WHERE uid=? LIMIT 1', (programmeid, )).fetchone()
                                              File "C:\Program Files\Kodi\system\python\Lib\sqlite3\dbapi2.py", line 69, in convert_timestamp
                                                year, month, day = map(int, datepart.split("-"))
                                            TypeError: 'NoneType' object is not callable

If needed I can post the entire log file.

Thanks for your help!
Mark 
 I just did a fix for non-ascii names in version 0.0.79. Does that fix it?
I saw that error while I was fixing it but not now.
If not post the kodi.log or pm me if there is anything sensitive in it.
Reply
If full logs need to be supplied, please use the log uploader addon or manually paste to our pastebin site (paste.kodi.tv).

Full logs should not be uploaded directly here, as they unnecessarily bloat the forum database.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
Hello again,

Latest version didn't seem to work now either. IN fact, when I select a tv show to "Always Record" The json files are not made. ONly if I select record once is the json file made.

Attached is the log file: https://paste.ubuntu.com/p/K325n4nH4M/

Thanks,
Mark
Reply
(2018-12-26, 21:04)mwkurt Wrote: Hello again,

Latest version didn't seem to work now either. IN fact, when I select a tv show to "Always Record" The json files are not made. ONly if I select record once is the json file made.

Attached is the log file: https://paste.ubuntu.com/p/K325n4nH4M/

Thanks,
Mark
 Could you try a NUKE and see if it still does it.
Turn on "Settings\Debug\Debugging Menus"
then "Maintenance\NUKE".

I can't recreate that error in mine now but I might just be lucky.
Reply
Nuking now. Will let you know in a bit.

Thanks,
Mark

So I nuked it, 2 times, still having problems. I did get it to record one show using the "record all" selection, but it only recorded one show and there were two back to back. Could it be my before/after buffer times of 10 minutes? I am allowed 5 simultaneous connections and was only using using 2 at the time. Anyway...after the 2nd nuke, I tried adding some shows using "record all". Was able to select 2 and have the red "RECORD" label added to all of the episodes selected, however after the first two, the script wouldn't let me add any more. I have changed my before/after buffer to 1 minute. The log is attached: https://paste.ubuntu.com/p/XzMvBcDmDP/
Reply
(2018-12-26, 21:27)mwkurt Wrote: Nuking now. Will let you know in a bit.

Thanks,
Mark

So I nuked it, 2 times, still having problems. I did get it to record one show using the "record all" selection, but it only recorded one show and there were two back to back. Could it be my before/after buffer times of 10 minutes? I am allowed 5 simultaneous connections and was only using using 2 at the time. Anyway...after the 2nd nuke, I tried adding some shows using "record all". Was able to select 2 and have the red "RECORD" label added to all of the episodes selected, however after the first two, the script wouldn't let me add any more. I have changed my before/after buffer to 1 minute. The log is attached: https://paste.ubuntu.com/p/XzMvBcDmDP/
What was the first type of recording you tried: Record Always or Record Daily?
Did you update to version 0.0.79?
You need to give it time to load after a restart too.
There is a "database is locked" error message in there.
Reply
(2018-12-27, 00:15)primaeval Wrote:
(2018-12-26, 21:27)mwkurt Wrote: Nuking now. Will let you know in a bit.

Thanks,
Mark

So I nuked it, 2 times, still having problems. I did get it to record one show using the "record all" selection, but it only recorded one show and there were two back to back. Could it be my before/after buffer times of 10 minutes? I am allowed 5 simultaneous connections and was only using using 2 at the time. Anyway...after the 2nd nuke, I tried adding some shows using "record all". Was able to select 2 and have the red "RECORD" label added to all of the episodes selected, however after the first two, the script wouldn't let me add any more. I have changed my before/after buffer to 1 minute. The log is attached: https://paste.ubuntu.com/p/XzMvBcDmDP/
What was the first type of recording you tried: Record Always or Record Daily?
Did you update to version 0.0.79?
You need to give it time to load after a restart too.
There is a "database is locked" error message in there. 
I believe that I only used "Always Record". Could have chosen the other one by mistake. Yes I am on 0.0.79

Will try again tomorrow, but it just isn't working. I don't know what the "database is locked" message is about. Does that have to do with something other than the IPTV Recorder?

By "give it time to load after a restart", do you mean the 60 seconds it takes to start loading the xml/3mu data or something else? How much time should be given?

Thanks,
Mark
Reply
Hello,

Tried again. "Record Always". Didn't take the record command. Log file is here: https://paste.ubuntu.com/p/65XQJNJRtR/

Thanks,
Mark

If you can give me some specific things to do to help troubleshoot this, I can do that tomorrow.
Reply
(2018-12-27, 03:35)mwkurt Wrote: Hello,

Tried again. "Record Always". Didn't take the record command. Log file is here: https://paste.ubuntu.com/p/65XQJNJRtR/

Thanks,
Mark

If you can give me some specific things to do to help troubleshoot this, I can do that tomorrow.
Try 0.0.81.
It should have fixed a couple of bugs with "Daily Time Rules".
I thought you were using "Record Always" for programs so I didn't check the "Daily Time Rule".
Reply
(2018-12-27, 10:25)primaeval Wrote: 0.0.81
It should have fixed a couple of bugs with "Daily Time Rules".
I thought you were using "Record Always" for programs so I didn't check the "Daily Time Rule". 
 From your repo, the most recent version is 0.0.21
Reply
  •   
  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 81
  •   
 
Thread Rating:
  • 4 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
IPTV Recorder54
This forum uses Lukasz Tkacz MyBB addons.