Linux Kodi on lubuntu 18.04 using Nouveau Driver
Good evening,

I upgraded my computer to 18.04 and I was distraught to find out that my GeForce 6800 driver (nvidia-304) was no longer supported.  I had to revert to the nouveau driver in order to use my display.

Now, kodi gives me segmented fault error when running.

Can kodi run on the nouveau driver?  If yes, then what can be the problem?

Here is my kodi crash log:



System:    Host: PCJPLMTL Kernel: 4.15.0-20-generic i686 bits: 32 Console: tty 0 Distro: Ubuntu 18.04 LTS
Machine:   Device: desktop System: Dell product: Dimension 8400 serial: N/A
           Mobo: Dell model: 0U7077 serial: N/A BIOS: Dell v: A09 date: 07/07/2006
CPU:       Single core Intel Pentium 4 (-MT-) cache: 1024 KB
           clock speeds: max: 2992 MHz 1: 2992 MHz 2: 2992 MHz
Graphics:  Card: NVIDIA NV41 [GeForce 6800]
           Display Server: N/A drivers: nouveau (unloaded: modesetting)
           tty size: 238x68 Advanced Data: N/A out of X
Audio:     Card-1 Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series] driver: snd_ca0106
           Card-2 Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card: Broadcom Limited NetXtreme BCM5751 Gigabit Ethernet PCI Express driver: tg3
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:11:11:a2:e6:1a
Drives:    HDD Total Size: 250.0GB (37.8% used)
           ID-1: /dev/sda model: WDC_WD2500JD size: 250.0GB
Partition: ID-1: / size: 16G used: 8.6G (58%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 148G used: 77G (55%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 3.07GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 140 Uptime: 13 min Memory: 190.2/3024.3MB Init: systemd runlevel: 5
           Client: Shell (bash) inxi: 2.3.56
I'm not sure if Nouveau will work with Kodi, but I can't tell what's going on from that log. Can you install gdb (sudo apt install gdb) and enable debug logging: . This will provide more information about why it's crashing.

Your best course may be to revert to 16.04 LTS on that hardware. Ubuntu isn't shipping a 32-bit desktop CD image anymore either, so it's not well tested on 32-bit hardware. Nvidia dropped support for the 304 driver at the end of 2017, so it's not supported on the kernel that shipped with Ubuntu 18.04, and won't be updated for kernels or new X server ABIs going forward.

There is a patch floating around to get the 304 driver to work with Linux kernel 4.15, so you can possibly get it to work. The graphics-driver ppa has a 304 driver for 18.04, but I'm not sure if it has a patch for 4.15:

I ended up reverting to 17.10 for the time being.  I will probably have to revert way down to 16.04 before the end of the year.

Thanks for the tip on the 304 driver potential fix.  I will investigate.
I successfully installed nvidia-304 using the instructions contained in the link below. (even if it is 304-137 actually).

The installation did not work properly when I tried from the running computer (it complained that X was running and that it was lacking some privileges, among other things).  However, I successfully did it from the recovery console (as root, after making the partition writable using "mount -o rw, remount /").

I hope that this can help someone else!
Well, I might have been a little too quick there.  It seems that I indeed successfully installed the nvidia-304 drivers, but some part of OpenGL did not.

From the crash log, it seems that this is a graphics problem:

19:44:59.000 T:2997337920  NOTICE: Checking resolution 16
19:44:59.385 T:2997337920   ERROR: Failed to determine egl config for visual info
19:44:59.385 T:2997337920 WARNING: Visual 0x28 of the window is not suitable, looking for another one...
19:44:59.385 T:2997337920  NOTICE: Using visual 0x21
19:44:59.439 T:2997337920  NOTICE: Using visual 0x28
19:44:59.449 T:2997337920   ERROR: CWinSystemX11::XErrorHandler: BadValue (integer parameter out of range for operation), type:0, serial:111, error_code:2, request_code:155 minor_code:3
19:44:59.450 T:2997337920   ERROR: CWinSystemX11::XErrorHandler: GLXBadContext, type:0, serial:112, error_code:173, request_code:155 minor_code:5
19:44:59.450 T:2997337920   ERROR: CWinSystemX11::XErrorHandler: GLXBadContext, type:0, serial:112, error_code:173, request_code:155 minor_code:26

When I run kodi from the command line, I get:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libEGL warning: DRI2: failed to authenticate
Segmentation fault (core dumped)

inxi -G
Graphics:  Card: NVIDIA NV41 [GeForce 6800]
           Display Server: x11 (X.Org 1.19.6 ) driver: nvidia
           Resolution: [email protected]
           OpenGL: renderer: N/A version: N/A

sudo inxi -G
Graphics:  Card: NVIDIA NV41 [GeForce 6800]
           Display Server: X.Org 1.19.6 driver: nvidia
           Resolution: [email protected] Advanced Data: N/A for root

Does anyone have any idea what my problem is?

Good evening again!

It seems that reinstalling the nvidia driver (even though the DKMS option was selected during the initial installation) solved this problem.

This means that the DKMS option of the installer does not seem to stick in 18.04.

Again, I hope this will help someone out there!

Logout Mark Read Team Forum Stats Members Help
Kodi on lubuntu 18.04 using Nouveau Driver0
This forum uses Lukasz Tkacz MyBB addons.