•   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 26
  •   
WIP Ember Media Manager 1.5.x - Download & Discussion Thread
(2020-04-17, 23:04)bacardicola Wrote: Just one line of rating, but kodi (18.6) does not see it as an imdb rating. 
Because it could be any rating (IMDB, TMDb, TVDb...).
Reply
(2020-04-18, 19:16)DanCooper Wrote:
(2020-04-17, 19:22)ottix Wrote: I tried to change the language field under Settings -> Film -> Files and Sources, but unfortunately nothing changed.
The source languge setting is only for new movies/tv shows. After changed the source language you also have to select all movies and tv shows in your list and set the language via context menu to that language you want. 
Thank you Dan.
I will immediately try as you say.
Reply
(2020-04-19, 11:14)ottix Wrote:
(2020-04-18, 19:16)DanCooper Wrote:
(2020-04-17, 19:22)ottix Wrote: I tried to change the language field under Settings -> Film -> Files and Sources, but unfortunately nothing changed.
The source languge setting is only for new movies/tv shows. After changed the source language you also have to select all movies and tv shows in your list and set the language via context menu to that language you want.  
Thank you Dan.
I will immediately try as you say. 
I tried deleting one film, deleting also all the files in the folder, renaming the avi file.
Then I clicked on Update Library.
The system found the new file. I clicked on it and pressed CTRL+I
The file was correctly scraped but still in English Sad  
Plot in English and Title in English.
Reply
First time with 1.5 and found some little problems (dont know if present in previous versions).

The metadata load from video files (MKVs) just get one audio track, the "best" one (not always the first one). This way I can't see what movie is dubbed in my language or not until playing the real movie. The subs tracks are completely loaded, meanwhile. I don't see any option to change that or update mediainfo module. Is there something I can do to get all audio tracks?

Another problem I get its that with an EMM "default" configuration (without touching nothing at Kodi filenames template, using default) when I use Kodi interface to sync database I can update movie info, poster and fanart, but it seems that Kodi (I tried a few skins) dont load extra art as discart, clearart or clearlogo. Do I need to change any default option or value to achieve Kodi loads that extra art? I supossed that the default config would be the right one.

For last, but just as curiosity, not real problem: When I enable "real time sync" in Kodi interface, each time I update a movie it tries and fails in the sync. If I sync "manually" via menu option it does it correctly. Is a bug in that option or its just me?

Thanks in advance and sorry for my english!
Reply
(2020-04-19, 13:04)Cromseth Wrote: The metadata load from video files (MKVs) just get one audio track, the "best" one (not always the first one). This way I can't see what movie is dubbed in my language or not until playing the real movie. The subs tracks are completely loaded, meanwhile. I don't see any option to change that or update mediainfo module. Is there something I can do to get all audio tracks?
Ember reads always reads all streams and shows them as small language icon. As default the best audio stream will be displayed with a flag, but in Settings => Movies/TV Shows => General => Main Window => Show best audio ... you can enable that the best stream of a specific language should be displayed with a flag.
Image
 
(2020-04-19, 13:04)Cromseth Wrote: Another problem I get its that with an EMM "default" configuration (without touching nothing at Kodi filenames template, using default) when I use Kodi interface to sync database I can update movie info, poster and fanart, but it seems that Kodi (I tried a few skins) dont load extra art as discart, clearart or clearlogo. Do I need to change any default option or value to achieve Kodi loads that extra art? I supossed that the default config would be the right one.
The Kodi default skin does not support all of the additional image types. If you use the Kodi Interface to sync the images it not even important which file names you use because the Kodi Interface sends the image path and image type to the Kodi database, e.g.
Code:
poster=smb://SERVER/movies/Avatar/Avatar-poster.jpg
discart=smb://SERVER/movies/Avatar/Avatar-image-of-a-round-bluray.png
So any file name works because Kodi don't have to search for an image with a file name that corresponds to a known file name scheme.

You also can check if the sync has worked if you open the Information dialog on a movie in Kodi and select "Choose Art". In this list you should see all images and there type like:

Image

As "default" file name Ember alsways use <stacked-filename>-imagetype.ext like Kodi whould do if you export your Kodi database to separate files. "imagetype" is the same "name" as Kodi uses in the column "type" in the table "art" (with the exception VIDEO_TS or BDMV folder structures and tv shows), e.g. "clearart", "clearlogo", "landscape" and so on.
 
(2020-04-19, 13:04)Cromseth Wrote: For last, but just as curiosity, not real problem: When I enable "real time sync" in Kodi interface, each time I update a movie it tries and fails in the sync. If I sync "manually" via menu option it does it correctly. Is a bug in that option or its just me?
Thats the the exact same function with the only difference that one is called automatically and the other manually. So it can't be a different result.
Reply
(2020-04-19, 11:40)ottix Wrote:
(2020-04-19, 11:14)ottix Wrote:
(2020-04-18, 19:16)DanCooper Wrote: The source languge setting is only for new movies/tv shows. After changed the source language you also have to select all movies and tv shows in your list and set the language via context menu to that language you want.  
Thank you Dan.
I will immediately try as you say.  
I tried deleting one film, deleting also all the files in the folder, renaming the avi file.
Then I clicked on Update Library.
The system found the new file. I clicked on it and pressed CTRL+I
The file was correctly scraped but still in English Sad  
Plot in English and Title in English. 
Please check if the correct language for this movie is set (Context menu => Change Language, the correct language should already been pre-selected).
Please check that you've enabled a scraper that supports multi language (TMDb for movies, because IMDb is english only and all other scrapers are german only).
Please check that the TMDb scraper is on the top of the list.
Please check that your language is available for this movie on TMDb.
Reply
(2020-04-19, 14:08)DanCooper Wrote:
(2020-04-19, 13:04)Cromseth Wrote: The metadata load from video files (MKVs) just get one audio track, the "best" one (not always the first one). This way I can't see what movie is dubbed in my language or not until playing the real movie. The subs tracks are completely loaded, meanwhile. I don't see any option to change that or update mediainfo module. Is there something I can do to get all audio tracks?
Ember reads always reads all streams and shows them as small language icon. As default the best audio stream will be displayed with a flag, but in Settings => Movies/TV Shows => General => Main Window => Show best audio ... you can enable that the best stream of a specific language should be displayed with a flag.
Image 
It should be as you says, but it only gets one (the "best") track of the MKV. It happens with all of my movies (all MKVs). I post some images to show it:

Fist one: EMM shows just one audio track (subs are all indexed)
Image

Image 2: EMM shows just one audio track in metadata info.
Image

Image 3: Real Mediainfo from the file. It shows that the MKV has 3 audio tracks, not just one.
Image


It happens with all my movies and as that is the info exported to Kodi I cant see what movies are dubbed or not in spanish (my language). I guess that has to be a Mediainfo inbuilt option or bug in EMM. Any clue?
Reply
(2020-04-19, 15:16)Cromseth Wrote: Image 3: Real Mediainfo from the file. It shows that the MKV has 3 audio tracks, not just one.

Ok, indeen that's strange/wrong. Can you send me a snipped of this video, e.g. created with ffmpeg?
Code:
ffmpeg -ss 00:01:00 -i input.mp4 -to 00:02:00 -c copy output.mp4

-i: This specifies the input file. In that case, it is (input.mp4).
-ss: Used with -i, this seeks in the input file (input.mp4) to position.
00:01:00: This is the time your trimmed video will start with.
-to: This specifies duration from start (00:01:40) to end (00:02:12).
00:02:00: This is the time your trimmed video will end with.
-c copy: This is an option to trim via stream copy. (NB: Very fast)
The timing format is: hh:mmConfuseds
Reply
(2020-04-19, 16:47)DanCooper Wrote:
(2020-04-19, 15:16)Cromseth Wrote: Image 3: Real Mediainfo from the file. It shows that the MKV has 3 audio tracks, not just one.

Ok, indeen that's strange/wrong. Can you send me a snipped of this video, e.g. created with ffmpeg?
Code:
ffmpeg -ss 00:01:00 -i input.mp4 -to 00:02:00 -c copy output.mp4

-i: This specifies the input file. In that case, it is (input.mp4).
-ss: Used with -i, this seeks in the input file (input.mp4) to position.
00:01:00: This is the time your trimmed video will start with.
-to: This specifies duration from start (00:01:40) to end (00:02:12).
00:02:00: This is the time your trimmed video will end with.
-c copy: This is an option to trim via stream copy. (NB: Very fast)
The timing format is: hh:mmConfused

I fear I dont know how to use right ffmeg... Couldn't do it.

Image
Reply
Put quotes around the filename if there is a space in it.
Reply
(2020-04-19, 17:58)Boulder Wrote: Put quotes around the filename if there is a space in it.

Many thanks. I got it now.

The problem is that the new little MKV only has 1 video track, 1 audio track (the first) and 1 subs track (the first).

I guess that doesn't help.
Reply
(2020-04-19, 14:14)DanCooper Wrote:
(2020-04-19, 11:40)ottix Wrote:
(2020-04-19, 11:14)ottix Wrote: Thank you Dan.
I will immediately try as you say.  
I tried deleting one film, deleting also all the files in the folder, renaming the avi file.
Then I clicked on Update Library.
The system found the new file. I clicked on it and pressed CTRL+I
The file was correctly scraped but still in English Sad  
Plot in English and Title in English.  
Please check if the correct language for this movie is set (Context menu => Change Language, the correct language should already been pre-selected).
Please check that you've enabled a scraper that supports multi language (TMDb for movies, because IMDb is english only and all other scrapers are german only).
Please check that the TMDb scraper is on the top of the list.
Please check that your language is available for this movie on TMDb. 
Thank you Dan.
I will try it!
I love your software.
Reply
(2020-04-19, 14:08)DanCooper Wrote:
(2020-04-19, 13:04)Cromseth Wrote: Another problem I get its that with an EMM "default" configuration (without touching nothing at Kodi filenames template, using default) when I use Kodi interface to sync database I can update movie info, poster and fanart, but it seems that Kodi (I tried a few skins) dont load extra art as discart, clearart or clearlogo. Do I need to change any default option or value to achieve Kodi loads that extra art? I supossed that the default config would be the right one.
The Kodi default skin does not support all of the additional image types. If you use the Kodi Interface to sync the images it not even important which file names you use because the Kodi Interface sends the image path and image type to the Kodi database, e.g.
Code:
poster=smb://SERVER/movies/Avatar/Avatar-poster.jpg
discart=smb://SERVER/movies/Avatar/Avatar-image-of-a-round-bluray.png
So any file name works because Kodi don't have to search for an image with a file name that corresponds to a known file name scheme.

You also can check if the sync has worked if you open the Information dialog on a movie in Kodi and select "Choose Art". In this list you should see all images and there type like:

Image

As "default" file name Ember alsways use <stacked-filename>-imagetype.ext like Kodi whould do if you export your Kodi database to separate files. "imagetype" is the same "name" as Kodi uses in the column "type" in the table "art" (with the exception VIDEO_TS or BDMV folder structures and tv shows), e.g. "clearart", "clearlogo", "landscape" and so on.  

About that I think the problem is in the sync then... It says it was OK but the "extra" art don't get synchronized.

I use Aeon MQ 8 that uses that extra art, and in the "art selection" window (as you posted) there are only the poster, fanart and thumbnail. The others aren't there. The skin meanwhile seems to download and use that art but I dont have "control" over that files (they are not obviously in movie folder). It download and use his own "extra" artwork even when "use only local info" is enabled as scraper in Kodi source.

As you said the movie folders are as expected and with all art files got by EMM:
Image

Everything else is perfectly synchronized, but that "extra" artwork dont. I cant see where is the problem. The sync says it was ok and I didn't touch any option:
Image

and
Image

Is there something I have to enable or change in EMM config?


Edit: I add the Kodi interface module with all ok.
Image
Reply
(2020-04-19, 21:54)Cromseth Wrote: The skin meanwhile seems to download and use that art but I dont have "control" over that files (they are not obviously in movie folder).
Settings looks ok. I thin MQ uses ArtworkBeaf or ArtworkDownoader to get the additional images. Both addons shoud have an option like "use local images instead of downloading them".
Reply
(2020-04-19, 22:48)DanCooper Wrote:
(2020-04-19, 21:54)Cromseth Wrote: The skin meanwhile seems to download and use that art but I dont have "control" over that files (they are not obviously in movie folder).
Settings looks ok. I thin MQ uses ArtworkBeaf or ArtworkDownoader to get the additional images. Both addons shoud have an option like "use local images instead of downloading them". 

Ok. I will study if that is the cause. Its weird because I dont have any of that artwork addons installed, but maybe I can try installing and see what happens.

Just to be sure: if the sync was ok the "choose artwork" menu (as you posted) should index that extra artwork or is skin related? Can be that artwork "indexed" or "assigned" to the movie in that menu independently of its showed or not? Asking for trying to locate faster the problem.

Thanks!

EDIT: Any idea about the other issue in audio tracks? I did the ffmpeg "capture" you posted but the output mkv only use first audio and first subs tracks, not all of them.
Reply
  •   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 26
  •   



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.5.x - Download & Discussion Thread2
This forum uses Lukasz Tkacz MyBB addons.