• 1
  • 4
  • 5
  • 6
  • 7
  • 8(current)
ReplayTV: Help with streaming from a ReplayTV box?

If I am doing it correctly, the xbmc filemanager cannot access the RTVs over the LAN. This was going into "My Files" at the bottom of the home page. The only way I can see the listings of what is on the RTV is via the bookmark I made that shows up in My Videos. But I didn't see an option to copy the file via the pop up menu.

I haven't uploaded the file anywhere yet but will do it tonight. Would it be alright to copy the file from the RTV to my PC then ftp it to my xbox and then attempt to play it? I don't think that was what you were wanting to test but I think it may be the only way.
I copied a short file from my RTV to my PC and then FTP'd it to my xbox. I browsed the xbox using the filemanager and selected the file and it played without issue. I went ahead and entered the debug mode and the log can be found here:


In addition, I've uploaded the file (the clip is only 2 sec long but still came out to be just under 3MB) to this website (short clip of Seinfeld):

yea sadly i recieved the same report from another user. I somewhat suspected it, it only fails when the client is making odd small requests wich the filecopy rutine never does. will have to check the source once again.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

Has anyone tried any of the newer releases, and has the Replay issue been addressed at all?
Yes, actually I've gotten ReplayTV streaming to work from my ReplayTV 5040 box using one of the nightly builds (I don't know which, my brother compiled one the other day from the svn and sent it to me - I don't even know what svn is....)

I would choose "ReplayTV" from the My Videos section and the box would lock up, not doing anything. For some reason, XBMC was not able to auto-discover the Replay with the "rtv://*/" line in the sources.xml file. My bookmark now looks like this:


and for some reason, this lets it stream properly. I am able to use the default media player - just browse to the filename and click "select" on the remote, and after a few seconds of caching, the video plays.
Confirmed. I just installed the Jan, 16 2007 T3CH build and my ReplayTV streaming is back. This is the first time since the official 2.0 build was released.
I also have a ReplayTV 5040.
It did lock up on me if I used the rtv://* as the bookmark but once I put in a direct IP address it worked like a charm.
Ditto to AfterTen's comment.

Works like a charm for streaming from both ReplayTV boxes and DVArchives instances.

Also, as AfterTen mentioned, if you don't specify your RTVs by IP Address, then XBMC locks up but that was my fault as I forgot to update my sources.xml file.

Thanks for making the change to have all RTV requests play via the DVDPlayer.
Thanks to whoever figured out and fixed this.
I will try a newer build soon.
I've been following this thread avidly since updating to the latest version of XBMC. Since rtv streaming is my number one use of the xbox I was very frustrated when it was broken. While I'm grateful that it is working again, I have to say it's not nearly as elegant and seamless an experience as it was before. Perhaps because its now being handled by the dvdplayer instead of mplayer. I wish I had a little more coding savvy so I could help on the development side since for me this is THE coolest feature of XBMC. Many thanks to the devs looking into this. Any ideas what broke this in the first place?
While I did add my comments before that the streaming is working again there is one issue that has manifested itself. If one attempts to do a 30 second skip or fast forward, the video freezes and it takes a while for it to catch up - almost the same length of the skip (in other words, if you skip 30 seconds then the video freezes for about 30 seconds and starts playing again).

I usually use a harmony remote but had to start using the normal xbox controller where I could use the trigger to fast forward and found that if I held it to about 2x then it would FF at the 2x speed.

Again, I am grateful to have the streaming back but thought I'd just add the behavior I am seeing. Not sure if others are seeing the same.
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8(current)
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
ReplayTV: Help with streaming from a ReplayTV box?00
This forum uses Lukasz Tkacz MyBB addons.