•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 21
  •   
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted)
Thanks for bringing your site up again and new development on this tool. I've installed both 0.4 and your beta version, but the same issue keeps appearing. I have no pictures for my movies, and none of my tv shows are shown. When I click TV-shows, nothing happens...

The interface does work, when I click a movie, it does start, and I can control it.
Reply
GeniusCode Wrote:I suggest you to modify your script, in the meantime put in the first page the right information for setup correctly the php Big Grin

I will do.

About the thumbnails, I will look into that and create a fix.
Reply
yay! ^_ー
Reply
truly awesome! Thank you for this one. Much better than any iPhone XBMC remote.
Reply
samanoske Wrote:truly awesome! Thank you for this one. Much better than any iPhone XBMC remote.

Tnx, btw, next release will have a new wvga skin (tnx to tamago_quin). Hope to finish it this week (which will also fix the images).

By the way, can everyone test (with your phone):

http://m.denhaas.info/test.html

And give the following information:
- Resolution (of your phone)
- Device (HTC Touch, etc)
- Browser (Opera mobile, etc)

And the results of all the tests, please also check (if you can rotate your phone/browser) if the onresize function works (it will say: "working!" if it's working, else it is waiting for rotation).
Reply
http://m.denhaas.info/test.html

Using a Blackberry Storm2 9550

Blackberry Browser Portrait:
W=345 (all widths)
H=378 (all except Element2 which was "O")
OnResize Function = "Working"

Blackberry Browser Landscape:
W=465 (all widths)
H=258 (all except Element2 which was "O")
OnResize Function = "Working"


Opera Beta .5 Portrait:
W=347 (all widths)
H=430 (all except Element2 which was "O")
OnResize Function = "Waiting for rotation... (or not working)"

Opera Beta .5 Landscape:
W=467 (all widths)
H=310 (all except Element2 which was "O")
OnResize Function = "Waiting for rotation... (or not working)"
Reply
I've installed your web app on an Ubuntu Linux server, and the site loads and acts like it should be working, but the indexing page always lists 0 items for each category. The web interface for XBMC is working, and my library has lots of movies and TV shows in it, but the indexing page and the app just gives me blank lists. I'm running XBMC 9.11 Beta on OSX. The Linux web server running your app is Ubuntu 9.10, and I'm testing your web app using Firefox 3.5.5.

If I turn off the XBMC web server, your app tells me the XBMC machine is offline. So it IS seeing it, but it doesn't see any of my library. The 'Controls' section doesn't do anything, either. I have a username and password set for the XBMC web interface. Do I have to specify that in the configuration of your app somewhere? Is there any other relevant info I could provide to help diagnose the problem?

I haven't been able to try this remote yet, but it looks GREAT! I can't wait to get it working!
Reply
XiniX88 Wrote:http://m.denhaas.info/test.html

- Resolution : 480×320
- Device : iPhone 2G
- Browser : Safari

1)

Width / Height test
BodyElementWidth: 320
BodyElementHidth: 356

BodyWidth: 320
BodyHeight: 356

Element ClientWidth: 320
Element ClientHeight: 356

Element OffsetWidth: 320
Element OffsetHeight: 356

Element2 ClientWidth: 320
Element2 ClientHeight: 0

OnResize function: Working!

> After Rotation ...

Width / Height test
BodyElementWidth: 480
BodyElementHidth: 208

BodyWidth: 480
BodyHeight: 208

Element ClientWidth: 480
Element ClientHeight: 208

Element OffsetWidth: 480
Element OffsetHeight: 208

Element2 ClientWidth: 480
Element2 ClientHeight: 0

OnResize function: Working!
Reply
angeloloi Wrote:I.ve installed everything. Xammp works, but when i try to access from mine pda to xbmc i get the message access forbidden.
This is what i see in de apache log:
Sat Nov 28 15:09:56 2009] [error] [client 192.168.1.10] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /xbmc/%3C?__id=1 HTTP/1.1 to file, referer: http://192.168.1.14/xbmc/.
Any suggestions?

Having this exact same problem. Can anyone help?
Reply
Tnx for the results @dmets and @samanoske

Need those for my new scaleable interface. I couldn't use it 6 months ago, since Opera 9.5 was giving resolutions like 800x600, Is there someone using Windows Mobile + Opera 9.x who can also test http://m.denhaas.info/test.html ??

grantalope Wrote:Having this exact same problem. Can anyone help?

Your webserver doesn't know that localhost/xbmc/<nothing> belongs to index.php. So probably index.php isn't mapped as an index.

You can try http://192.168.1.14/xbmc/index.php?__id=1

If this is working, you haven't configured your server the right way, or your webbrowser is sending strange requests.


ShayneOSU Wrote:Is there any other relevant info I could provide to help diagnose the problem?!

Great post! First one who is giving me loads of info. Can you go to the web-page of XBMC itself (so localhost:8080 I guess) the same as you've configured in config.php, and check if that page is working, also check if the controls are working.

Else the XBMC HTTP API might be broken, or PHP won't send messages to the XBMC HTTP API. You can check the following URL:

http://localhost:8080/xbmcCmds/xbmcHttp?command=Stop()

while playing a video, this should stop the movie from playing. It will also display a message "Ok" or something like that.

If all those things are working, I guess your PHP is broken (running PHP in safe mode?)
Reply
XiniX88 Wrote:Can you go to the web-page of XBMC itself (so localhost:8080 I guess) the same as you've configured in config.php, and check if that page is working, also check if the controls are working.

Yes. The default XBMC site works well.

XiniX88 Wrote:You can check the following URL:
http://localhost:8080/xbmcCmds/xbmcHttp?command=Stop()
while playing a video, this should stop the movie from playing. It will also display a message "Ok" or something like that.

It prompted me for a username and password. When I used the username/password from the Network - Settings - Allow control of XBMC via HTTP settings area from XBMC, it then worked, stopping the movie and printing OK.

How does your application authenticate itself with the xbmcHttp server? Should I specify the login info that allows access to XBMC web server somewhere in your application's config files?

Quote:If all those things are working, I guess your PHP is broken (running PHP in safe mode?)

Is there a way I could test/change this?
Reply
Hi.

First of thanks XiniX88 for this interface it must have been lots of work.

I have tried many times now and read the redme file also many times but cant get it to work.

When i enter "http://192.168.10.70/XBMC" page i get these faults in the C:\xampplite\apache\logs\error.log:

[Thu Dec 03 12:12:04 2009] [error] [client 192.168.10.71] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /XBMC/%3C?=$template-%3Epath?%3E240/style.css HTTP/1.1 to file, referer: http://192.168.10.70/XBMC/
[Thu Dec 03 12:12:04 2009] [error] [client 192.168.10.71] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /XBMC/%3C?=$template-%3Epath?%3Escript.js HTTP/1.1 to file, referer: http://192.168.10.70/XBMC/

If i try the "http://192.168.10.70/xbmc/index.php?__id=1" i get:

[Thu Dec 03 12:15:13 2009] [error] [client 192.168.10.70] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /xbmc/%3C?=$template-%3Epath?%3E240/style.css HTTP/1.1 to file, referer: http://192.168.10.70/xbmc/index.php?__id=1
[Thu Dec 03 12:15:13 2009] [error] [client 192.168.10.70] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /xbmc/%3C?=$template-%3Epath?%3Escript.js HTTP/1.1 to file, referer: http://192.168.10.70/xbmc/index.php?__id=1

I have tried installing both xampplite and xampp on the PC with XBMC on and a standalone PC. Both running winxp sp2. In all 4 cases i can run the indexing sequense without faults whit the latest relese. I tried also opening from pc with firefox.


If i try as you sugjested for a other member:
PHP isn't working! Configure apache correctly... use: <?php phpinfo(); ?> to see if PHP is working (add it to a new file called testphp.php).

when i run the test.php file i get a page showing lots of info, what of it do you need?

I use a Nokia N97 with screen resolution of 640 x 360:

BodyElementWidth: 360
BodyElementHidth: 493

BodyWidth: 360
BodyHeight: 493

Element ClientWidth: 360
Element ClientHeight: 493

Element OffsetWidth: 360
Element OffsetHeight: 493

Element2 ClientWidth: 360
Element2 ClientHeight: 0

OnResize function: Working!

Hope that somone understands what the problem is so that we can fix it.

Please let me now if there is some more info you need.

Regards Linax
Reply
ShayneOSU Wrote:How does your application authenticate itself with the xbmcHttp server? Should I specify the login info that allows access to XBMC web server somewhere in your application's config files?

You have to disable the username and password, and XBMC HTTP-R will work Smile (settings => network => Servers, empty password, if fails, also empty username)

@Linax:

You need to open your php.ini file in xampp/php directory and modify short_open_tag to On

Btw, thanks for the testresults!

--------------
Is there someone with a Windows Mobile device who can test it?? Using IE and Opera...
Reply
- Resolution : 320x240
- Device : Blackberry 8350i
- Browser : Blackberry Default

Width / Height test
BodyElementWidth: undefined
BodyElementHidth: undefined

BodyWidth: undefined
BodyHeight: undefined

Element ClientWidth: undefined
Element ClientHeight: undefined

Element OffsetWidth: 305
Element OffsetHeight: 202

Element2 ClientWidth: undefined
Element2 ClientHeight: undefined

OnResize function: Waiting (or not working)



- Resolution : 320x240
- Device : Blackberry 8350i
- Browser : Bolt

Width / Height test
BodyElementWidth: 320
BodyElementHidth: 798

BodyWidth: 320
BodyHeight: 798

Element ClientWidth: 320
Element ClientHeight: 798

Element OffsetWidth: 320
Element OffsetHeight: 798

Element2 ClientWidth: 320
Element2 ClientHeight: 0

OnResize function: Waiting (or not working)


- Resolution : 320x240
- Device : Blackberry 8350i
- Browser : Opera Mini

Width / Height test
BodyElementWidth: 314
BodyElementHidth: 200

BodyWidth: 314
BodyHeight: 200

Element ClientWidth: 314
Element ClientHeight: 200

Element OffsetWidth: 314
Element OffsetHeight: 200

Element2 ClientWidth: 314
Element2 ClientHeight: 0

OnResize function: Waiting (or not working)
Reply
Hi! I've registered on this site after months of lurking to specifically provide you with some results, as I've been waiting with frustration for a decent XBMC controller for Windows Mobile! I can't believe, with thousands of users, that it hasn't been done (properly) before. Every other project died just when they got somewhere!

Anyway, thanks so much for continuing with HTTP-R - even if it took me a month to get it properly working, it's perfect!

Onto results:

http://m.denhaas.info/test.html
HTC BLACKSTONE (ALSO KNOWN AS TOUCH HD)

Resolution: 800x480 (WVGA)
Device: HTC Blackstone
Browser: Opera mobile 10 Beta
OS: Windows Mobile 6.5

Width / Height test
BodyElementWidth: 240
BodyElementHidth: 369

BodyWidth: 240
BodyHeight: 369

Element ClientWidth: 240
Element ClientHeight: 369

Element OffsetWidth: 240
Element OffsetHeight: 369

Element2 ClientWidth: 240
Element2 ClientHeight: 0

OnResize function: Working!

Regards, Edd
Reply
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 21
  •   



Logout Mark Read Team Forum Stats Members Help
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted)0
This forum uses Lukasz Tkacz MyBB addons.