[Linux] Antec Fusion Remote / Imon / MCE USB IR
Hi there

Now that xbmc works on my ubuntu htpc I would like to make the display of my case working. I searched the forum and found some threads regarding howto make a soundgraph VFD/IR work.

Unfortunately none of those descriptions worked in anyway. Means; no IR and no LCD functionality at all (using jaunty, most of the howto's were for hardy)

For the moment I use my old MCEUSB receiver which is working fine. But the LCD is still just turned on, showing non information.

I would really appreciate if someone could tell me what exactly I will have to do to make lirc work with the soundgraph hardware. When i install lirc there is this little setup tool where I can define the hardware i'd like to use. After setting this info it is written into the lirc.hardware.conf (or something like that) This is allready the start of my little dilemma ^^ because I have no Idea how to change this hardware.conf. After De- and reinstallation of lirc the setup is not coming up again and the lirc manual contents not a word of this hardware.conf file Sad

Btw. I installed lirc with this command: sudo apt-get install -y lirc. So i did not use the latest svn because as far as I understood the description my Soundgraph device should be supported by this version (0.8.3)

Thx a lot


Afaik you need lcdproc as well. As it's a rather common display you got, having a google about the hardware and lcdproc will surely bring up some howto about getting it to run with linux in general. xbmc is only feeding lcdproc IIRC.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
oh yes sorry forget about that. i installed lcdproc as well and i defined the driver imon. I think the problem is that i kind of need to load the device first before lcdproc is able to access it.

maybe thats also the reason why the IR receiver wasn't working.

to google for lirc in combination with lcdproc could probably deliver me a usefull input


Can you supply the lsusb output of your device please.

it is a tricky setup, If you are just going to use the LCD as your ir rcvr and the display then all is fine. If you plan on using both the M$ USB dongle and the LCD display and it's built in IR rcvr then it is a little more involved.

I did a how to on mythbuntu forums on how to set this all up and use the two devices together, the lcd to display data and receive commands and then the M$ dongle to trasmit only to sat rcvrs or cable boxes.

As I run myth and xbmc together I has to set it up this way.

another note about the lcd in the case, the only way to have the blue light completely go off is to have the pc suspend of which you need to create some pmutils scripts, The backlight with not shut off on power down of the pc.

There are some pre-defined scripts for this in the forums if you search those out. here are some links the first one is to get the display working follow that to the letter to step 10. Make sure that you have the same display device as listed in the thread. The second link is to a few how to tricks for irsending and setting up the mce remote after you have the display working.



hi dave

Its a Vendor=152c and ProdID=0038

i just tried to install lirc with imon drivers:

i installed and compiled lirc 0.8.4a

sudo apt-get source lirc

sudo apt-get build-dep lirc

cd lirc 0.8.4a

sudo ./setup.sh

choosed the soundgraph device from the list and clicked save and run configure

sudo make

sudo make install

then I ran the following command (as seen @ this place)

sudo dpkg-reconfigure lirc-modules-source

the result:

Error! Build of lirc_imon.ko failed for: 2.6.28-13-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/lirc/0.8.4a/build/ for more information.
Installing initial module

Error! Could not locate lirc_atiusb.ko for module lirc in the DKMS tree.
You must run a dkms build for kernel 2.6.28-13-generic (i686) first.

I found some fixes debdfiff patch files and downloaded this one

tried to apply the patch like this :S from the lirc 0.8.4a folder

sudo patch -p1 LP306346-jaunty-updated.debdiff

nothing happens.

any idea how I can get this working (or maybe just how to correctly apply the patch Big Grin)

I might have no idea what this last command should do. at the moment no driver is loaded for the hardware and i guess that without a proper run of the command I will not get the correct imon driver loaded.

thx a lot
That is not the LCD I have. I have the ffdc model. The 0038 device is a pain if i recall. you should look over at codeka.com and see what those guys have done. The basic setup is the same I think.

I never had to patch lirc I did install 4a at the time I set this all up. The links I supplied include the steps I took to make mine work.

I would spend some time on codeka I am sure they have it nailed down by now.

Follow this

I had fresh jaunty install running with "Vendor=152c and ProdID=0038 Remote Veris RM200" in 5 minutes.

Then LCD:
follow just the part about LCD

good luck
try this mate
good luck

it helps me
hi and thx for the links. I had no time to check it last weekend. but will try it as soon as possible and report if it was working Smile
guys guys

this lirc installation is drivin me insane Sad I screwed up the whole installation and now not even xbmc is running properly. at least i was able to see a clock on my display... jipiiee Sad i thought this might be a good sign that the correct driver has been loaded... guess I was wrong. Its really annoying. I tried the patches, the latest cvs but irw was not starting at all.

I definitly need a break now. my PCH will do the job for the next two days Big Grin gonna buy myself a family pack of snickers and continue my research on friday

but please, if you have any ideas why it won't run on my jaunty installation let me know.

greetz from switzerland
The display and remote work just fine with XBMC/Linux, I have the Fusion Remote myself.

On my (Gentoo) system I used the current CVS-version of lirc and lcdproc-0.5.3, with these versions I'm 100% sure that everything's supported properly.

Maybe this'll give you some hints on how to install.

First lirc:
[i]Select Driver Configuration -> USB-Devices -> Soundgraph iMON IR/LCD[/i]
make install

As soon as you do "modprobe lirc_imon" you should get /dev/lirc0 and /dev/lcd0

In the folder remotes/imon/ are sample lircd configs for this device.

One important thing remains - the usb device acts as a HID device, thus it's being handled by the Kernel's HID driver, you have to prevent that by adding
options usbhid quirks=0x15c2:0x0038:0x04
to /etc/modprobe.conf or wherever Ubuntu needs that.

Installing lcdproc isn't too hard either:
./configure --enable-drivers=imon,imonlcd
make install

The parts in LCDd.conf that may differ from the default:

LCDd is started with
/usr/local/sbin/LCDd -c /etc/LCDd.conf

The only thing I am now struggling with is scrolling speed on the display, the LCD is a little sluggish and xbmc (or LCDd?) scrolls so fast everything get's blurry, but adjusting the TitleSpeed value in LCDd.conf didn't help...

Good Luck!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[Linux] Antec Fusion Remote / Imon / MCE USB IR00
This forum uses Lukasz Tkacz MyBB addons.