Due to maintenance, our forum will be offline for a short while on Monday June 1st, around 22:00 UTC.

  •   
  • 1
  • 46
  • 47
  • 48(current)
  • 49
  • 50
  • 55
  •   
Win Yatse 2 : Open Source Media Center Remote Control App for Touch Screen
Thanks for the reply.

Where you say it doesn't detect a remote, do you mean a 'remote control'? I don't have one, I use a Rii mini keyboard to the control the HTPC.

I deleted the db. This has helped with the crashing, although it now crashes on the second screen (the options screen).

Otherwise, I've tried suggested changes and there doesn't appear to be any noticeable changes.

I've run it with both forceresolution as true and false. Here are the log files -
forceresolution - true -
http://pastebin.com/AdYewuDj
forceresolution - false -
http://pastebin.com/Fp1jww0H

When I then click on options to go the second screen, it produces a lot more data, but it exceeds the amount that I can put in pastebin.

I did try running your debug version but that kept on immediately crashing and have tried v.3.1 but it wouldn't boot to the initial blue screen.

Cheers,
bb69
Reply
Hmm.
The log seems to be from the debug version? I'm not sure what is crashing - as there is no exception thrown by Yatse2 in the log. When you say crashing what do you mean?

Make sure no other version is running - sometimes a thread left over if doesn't close probably. Check Task Manager and force close everything.

Start with a new fresh directory and use the latest 3.1 version. Delete the Log directory and delete the Yatse2.db and the Yatse2.xml file. eg. start a fresh.
Run the Yatse2.exe
Should go straight to settings screen - (as there is no xml) on the 2nd screen

If it crashes at this point - something is up with your 2nd screen.
If crashes -
Copy the following xml file - using this one in the directory:
https://github.com/Ghawken/Yatse2-1/rele...Yatse2.xml

This is the default settings - just not using the 2nd screen.

Hopefully this then runs as it should and we can then work on the 2nd screen issues.

The remote is the connection between Yatse2 and Kodi - this needs to be setup. By clicking on the Yatse2 wifi like button and connecting to a running kodi instance - ideally on the same machine.
Kodi needs to be running and the web control needs to be enabled and the ports need to be the same. Pays to set that up first. Should connect to the kodi instance.

Lets see if that goes okay - presume something is crashing when it tries to run it on your 2nd screen. Would suggest focus on getting it running on single/first screen and then trouble shoot the rest.

Edit:
I've just re-read your post and sorry didn't follow you before - when you say "second screen" - you mean enabled second screen in the options dialog? And then it crashes. It works okay on first screen with no crashes?
Probably do need that log data as that's why it's there - try to zip it and out on mediafire or something similar.

The unusual thing is your secondscreen is called framebuf - and seems to want a refreshrate of 1. Something is obviously up with the automatic detection of your screen, What motherboard and video driver is it?

Thanks
Reply
Hi Glenn, I really don't want to jinx myself; but, thought you would like to know... For the FIRST time, I am finally able to use DSPlayer without it locking up Kodi. Also, for the first time I'm able to "back-out" to Kodi's Main Menu during video playback (to run in a Window). I don't think this is by accident.

I'm currently using Yatse 3.01 with AlwaysMinimize & DisableResolutionDetection set to true. It wasn't necessary for me to make any other settings changes.

I'm crossing my fingers!!

PS: Is there a way to disable socket connections in Yatse?

(2015-06-24, 08:09)GlennNZ Wrote: re: DSPlayer Focus issues

Believe I have fixed Yatse and DsPlayer focus issues (believe it will also work with minimisealways - that was however slightly more problematic as restoring window should causes focus to follow)

https://github.com/Ghawken/Yatse2-1/releases

YatseSocket3.01.zip files- replacement Plugin folder and Yatse2.exe

Also need to set to true below -
Code:
<DisableResolutionDetection>true</DisableResolutionDetection>

This was 1/2 the problem - everytime the screen changes/refresh-rate changes - Yatse2 detects it and runs a check screenresolution - this always grabs focus. Hence above steps needed to change the xml file.

Glenn
Reply
Image
(2015-06-25, 13:41)GlennNZ Wrote: Start with a new fresh directory and use the latest 3.1 version. Delete the Log directory and delete the Yatse2.db and the Yatse2.xml file. eg. start a fresh.

OK, we've made quite a bit of progress! I've deleted the previous versions on my system and had done a clean install using the version 3.1.

That opens up at the 'settings screen' (sorry, it what I had previously called the second screen) and have been able to click on the wifi looking looking button and add my network details. As such Yatse is now connecting to Kodi and has downloaded the movies detail and fanart.

For some reason, it isn't downloading the content for the TV Shows and all of the audio and gives a "No Data. Please refresh your library first!" error message ?
The secondary screen - on my HTPC, it allows me several options to extend the secondary screen to the main screen; Right, Left, Above or Below. It also has the option to have a Mirror Image of the main screen.

When I start Yatse - with the secondary HTPC screen OFF - it takes up about half of the TV screen (Pic1-TV), Image when I then switch the secondary HTPC screen ON to mirror image mode, YATSE overfills both the the TV screen (Pic2-TV)
Image and the secondary screen.


However if I start Yatse - with the secondary HTPC screen OFF - and then click on the fanart followed by switching the secondary HTPC screen ON to mirror image mode, YATSE then correctly displays itself on the secondary HTPC screen (Pic3-Screen)
Image.

So providing that I open Kodi, followed by Yatse, then click on the fanart and then switch on the secondary screen to mirror image, it pretty much looks like it should do!

However from there, if I press the back arrow on Yatse whilst still in mirror image mode, it takes itself back to a full sized menu screen (Pic4-TV).
Image

One other thing I've noticed; the button to switch off YATSE doesn't seem to work (although the reboot button seems to work)?

The Mobo is a Gigabtye GA-Z87X-OC.I think that the video driver is DisplayLink Manager v.7.7.60366.0 with a display adapter of Intel HD Graphics 4400.

Many thanks.
bb69
Reply
(2015-06-25, 12:08)GlennNZ Wrote: Further to above:
Have updated github with another release 3.1
https://github.com/Ghawken/Yatse2-1/releases/tag/3.1

Added
<StartYatse2Server>true</StartYatse2Server>

If set to false - does not run listener thread waiting for yatse2.service from kodi to tell it browsing etc.
Effectively same as previous version - but can remain uptodate/use latest version.

Few changes to avoid stealing focus - with maximise/restore windows during playback, works well with my current setup of Dsplayer and MadVR exclusive mode.

More logging of 2nd screen problems.

Once working - turn off debug and trace logging!

Glenn
Mkanet:
You must have missed this - this is the newest version that includes setting as above to disable yatse2 server.
You will need to add it to Xml if copying over files.

Glad is all good, the miimisealways was somewhat painful to avoid stealing focus - dsplayer for me is now very stable.

Glenn
Reply
(2015-06-25, 19:28)billybob69 Wrote: OK, we've made quite a bit of progress! I've deleted the previous versions on my system and had done a clean install using the version 3.1.

That opens up at the 'settings screen' (sorry, it what I had previously called the second screen) and have been able to click on the wifi looking looking button and add my network details. As such Yatse is now connecting to Kodi and has downloaded the movies detail and fanart.

For some reason, it isn't downloading the content for the TV Shows and all of the audio and gives a "No Data. Please refresh your library first!" error message ?
The secondary screen - on my HTPC, it allows me several options to extend the secondary screen to the main screen; Right, Left, Above or Below. It also has the option to have a Mirror Image of the main screen.

When I start Yatse - with the secondary HTPC screen OFF - it takes up about half of the TV screen (Pic1-TV), when I then switch the secondary HTPC screen ON to mirror image mode, YATSE overfills both the the TV screen (Pic2-TV)
and the secondary screen.


However if I start Yatse - with the secondary HTPC screen OFF - and then click on the fanart followed by switching the secondary HTPC screen ON to mirror image mode, YATSE then correctly displays itself on the secondary HTPC screen (Pic3-Screen)

So providing that I open Kodi, followed by Yatse, then click on the fanart and then switch on the secondary screen to mirror image, it pretty much looks like it should do!

However from there, if I press the back arrow on Yatse whilst still in mirror image mode, it takes itself back to a full sized menu screen (Pic4-TV).

One other thing I've noticed; the button to switch off YATSE doesn't seem to work (although the reboot button seems to work)?

The Mobo is a Gigabtye GA-Z87X-OC.I think that the video driver is DisplayLink Manager v.7.7.60366.0 with a display adapter of Intel HD Graphics 4400.

Many thanks.
bb69

Bb69:
Okay progress.

Have looked at displaylink/and Hardware - presume this a usb connection to your second screen monitor?
I would presume this would work withYatse, however issue with setup.

Certainly cannot use mirror mode for Yatse or I'll be surprised much anything in the second screen. It needs to be a seperate monitor/screen. Mirror mode will affect dd9/dd11 video playback - don't use it! Mirror mode only has one screen which is mirrored - hence it can't find the screen.

Basically use Extend to desktop or left or right mode - really doesn't matter provided it's a completely separate incidence.

You want windows desktop extended to the small htpc monitor - ideally see mouse and drag open windows folders there whilst having Kodi fill up screen of TV.

Try those modes and post back (meanwhile I'll look at hardware aspects)

Also;
I note there is new displaylink software/driver here:
http://www.displaylink.com/downloads/downloads.php
The changelog discusses a number of fixes - some may apply.

Definitely want to extend desktop as per displaylink software. NOT mirror.

Glenn
Reply
Kodi with DSPlayer works stable now along with alwaysMinimize. In fact, PlayNow just pops up instantly on my 7" LCD (just as fast as video playback on my 55" TV). Timing, stability, performance, its all the way it should be now. It all works seamlessly even with my Rainmeter CPU Temp/Load plugin.

I'm still in disbelief that DSPlayer actually works stable now for me. It's one of those rare circumstances that the developer "Glenn" happens to share similar hardware/software HTPC configuration as mine; and, able to reproduce (and fix) every bug I had in two difference pieces of software.

Is there a way we can donate for all your latest contributions?

(2015-06-25, 23:15)GlennNZ Wrote:
(2015-06-25, 12:08)GlennNZ Wrote: Further to above:
Have updated github with another release 3.1
https://github.com/Ghawken/Yatse2-1/releases/tag/3.1

Added
<StartYatse2Server>true</StartYatse2Server>

If set to false - does not run listener thread waiting for yatse2.service from kodi to tell it browsing etc.
Effectively same as previous version - but can remain uptodate/use latest version.

Few changes to avoid stealing focus - with maximise/restore windows during playback, works well with my current setup of Dsplayer and MadVR exclusive mode.

More logging of 2nd screen problems.

Once working - turn off debug and trace logging!

Glenn
Mkanet:
You must have missed this - this is the newest version that includes setting as above to disable yatse2 server.
You will need to add it to Xml if copying over files.

Glad is all good, the miimisealways was somewhat painful to avoid stealing focus - dsplayer for me is now very stable.

Glenn
Reply
(2015-06-26, 04:29)MKANET Wrote: Kodi with DSPlayer works stable now along with alwaysMinimize. In fact, PlayNow just pops up instantly on my 7" LCD (just as fast as video playback on my 55" TV). Timing, stability, performance, its all the way it should be now. It all works seamlessly even with my Rainmeter CPU Temp/Load plugin.

I'm still in disbelief that DSPlayer actually works stable now for me. It's one of those rare circumstances that the developer "Glenn" happens to share similar hardware/software HTPC configuration as mine; and, able to reproduce (and fix) every bug I had in two difference pieces of software.

Is there a way we can donate for all your latest contributions?

Thanks for the vote of confidence. Still think you are missing out not using the browsing, approrpriate fanart!

Regarding donation - more than happy for you to redirect that towards DSplayer support & aracnoz - as without that - none of this would be worth doing/worthwhile.

Edit:

Have updated to setup files
https://github.com/Ghawken/Yatse2-1/releases/tag/3.1
& Setup Instructions:
https://github.com/Ghawken/Yatse2-1/rele...ctions.pdf

Version 3.1 Socket link as above
Minor changes to Yatse
- slight change to exception catching/error checking/kodi sources.xml (future use)
- But moved to setup.exe for both Yatse and Kodi Yatse2.service

Changes cache/log/Yatse Database to %appdata%\Yatse 3 Socket Directory
&
IMPORTANTLY
Changes Yatse.xml to %appdata%\Yatse 3 Socket Directory

Will enable settings/Database/Remote connections to remain intact between versions/or future upgrades !

Glenn
Reply
(2015-06-25, 23:21)GlennNZ Wrote: Definitely want to extend desktop as per displaylink software. NOT mirror.

Glenn

OK. Yet more progress!

Driver updated. After a bit of trial and error Yatse has now correctly detecting my secondary screen size as being 800x480 (if I have the secondary screen switched on when I open Yatse).

So when I switch on the HTPC / secondary screen to any of the 'Extend To' Left / Right / Up / Down modes, Yatse resizes itself to a correct length and width to correctly fill the HTPC / secondary screen.

However when Yatse resizes itself, the text, drop-down boxes etc don't resize themselves, leaving many of the options outside the screen (see Pic 1)
Image
Strangely when I click on the Fanart, this is correctly sized on the HTPC / secondary screen (Pic 2).
Image
I've tried force resolution on both 'true' and 'false', but this doesn't seem to force the text, drop down boxes etc to resize themselves.

Regarding Yatse not switching off when I press the buttons, I notice that when I press the off buttons, a DOS type screen pops up in the background and runs through something.

I attach a debug log, perhaps from that you can identify the shut down and failure to connect to audio fanart errors?
http://pastebin.com/kzLGPGzc

Thanks,

bb69
Reply
(2015-06-26, 15:13)billybob69 Wrote: [

OK. Yet more progress!

Driver updated. After a bit of trial and error Yatse has now correctly detecting my secondary screen size as being 800x480 (if I have the secondary screen switched on when I open Yatse).

So when I switch on the HTPC / secondary screen to any of the 'Extend To' Left / Right / Up / Down modes, Yatse resizes itself to a correct length and width to correctly fill the HTPC / secondary screen.

However when Yatse resizes itself, the text, drop-down boxes etc don't resize themselves, leaving many of the options outside the screen (see Pic 1)

Strangely when I click on the Fanart, this is correctly sized on the HTPC / secondary screen (Pic 2).

I've tried force resolution on both 'true' and 'false', but this doesn't seem to force the text, drop down boxes etc to resize themselves.

Regarding Yatse not switching off when I press the buttons, I notice that when I press the off buttons, a DOS type screen pops up in the background and runs through something.

I attach a debug log, perhaps from that you can identify the shut down and failure to connect to audio fanart errors?

Thanks,

bb69
Ok
Good that screen now working - how certain you are this screen is 800x480? Bc looks a bit smaller than that to me with layout etc. Could it be 640x480?
Text layout etc probably difficult to fix if indeed is quite small - but can have a look at it. No setting other than trialling Hack480 true and false will change that.

Power off button was my change - was testing the Taskbar icon at the time - so disabled it - have fixed that in 3.1 setup files as above. Probably pay to move to them to make updating much easier.

You also use local sources for movies etc - don't believe that will work with browsing currently - a fix is in progress for that though, hopefully not far away.

From Log:
You don't appear to have any images in artwork.downloader TvFanart directories? Either that or you don't have permissions for that folder (which would be unusual). Probably pay to change that to the MoviesFanart folder - given you don't have a TV source.

Kodi has no music found. This is via the JSON connection to Kodi - in log 13:58:59:4282. This has nothing to do with Yatse as this is what Kodi is telling it. You don't seem to have any music in the database?

Also don't seem to have yatse2.service installed (will give some more log info re folders)

Basically
1. Have a look at the size of you screen? Stick something on it and see if it's not misreporting the size. ?case/screen details available? Also have a look at screen resolution options changes either within displaylink/manager or within windows

Image]
This is a 800 x 480 Yatse Window

&
This is 640x480
Image


Yours seems even smallerHuh

This is closest I could get and is 560 by 380 wide
Image

2. Add some fanart to TvFanart folder or change reference to MovieFanart folder. If note there run artwork.downloader addon
3. Could install 3.1 setup version - fixes power button, and enables easier updates. NB on this version the settings xml file has moved to %appdata%\Yatse 3 Socket Directory. Will need to be changed there. This will enable updates to be a bit easier - as it keeps the xml and db intact between versions.
4. Once done and Yatses refresh Db over - could try browsing the music folders, artists and playing some music files - yatse should report what it's found via JSON in the log giving some idea as to why Kodi thinks you have no music files.

Glenn
Reply
Update to Yatse 3.1 Socket Build 110;

Install 3.1 setup first and below will update
https://github.com/Ghawken/Yatse2-1/rele...ld.110.exe

- Setup files on GitHub links as above
- Moves to using kodi source.xml for extrafanart locations (depth of directories setting not needed)
(Uses two directories after source to find extrafanart folder eg. Source is G:\Movies\ will look for extrafanart in G:\Movies\Interstellar\extrafanart, if source is smb://TV series/ will look in smb://TV series/tvseriesname/extrafanart etc.)
- Supports local directories for movies, video, images fanart
- Better image fanart handling/ support - eg. continues Yatse slideshow if Kodi slideshow ongoing
- Better error/exception handling
- Updated directory structure handling enables easier support for source other formats as requested
- More logging
Reply
(2015-06-26, 23:49)GlennNZ Wrote: Good that screen now working - how certain you are this screen is 800x480? Bc looks a bit smaller than that to me with layout etc. Could it be 640x480?
Text layout etc probably difficult to fix if indeed is quite small - but can have a look at it. No setting other than trialling Hack480 true and false will change that.

OK, yet more progress!

With regard to Yatse not being able to find the fanart data, hence giving the "No Data. Please refresh your library first!" error message, what I've found is that on my setup even though XBMC was recognising my albums in the library it was not recognising the albums on the home page and therefore was not showing the album fanart on the home page.
If there was no fanart showing on the home page of the different categories; Movies, TV Shows and Music etc in XBMC, then Yatse doesn't recognise that the fanart is there. I updated the file information in XBMC (by right click on the music menu and then clicking on 'scan item to library'. Now that I've done a rescan in XBMC, Yatse has found my album information.
Image

Regarding the Yatse window size, even if I set Yatse as being 800x480, when I start it (with the secondary HTPC screen OFF), it doesn't start up with a 800x480 window and starts with a larger window, which I think is around a 800x600.
Image

Strangely there isn't anything in the resolution drop down box.
Image

If I have the seconday / HTPC screen switched on when I open Yatse the fanart correctly shows itself on the secondary screen (See Pic 1), but the menu's are showing themselves incorrectly.
Image

EDIT: With regard to 3.1 setup version; I have downloaded and installed it, but it doesn't seem to properly. I can see it running in Task Manager, but it wasn't doing anything. Therefore I uninstalled it and carried on with my previous version.

I've checked under Display properties in Windows and it is definetly showing as being 800 x 480 (Samsung model) and the driver is up-to-date.

I've also tried manually changing the Display Frequency in the XML document to 23, but when I start Yatse (with the HTPC / secondary screen on) the only resolution that it detects is 800 x 480, 16 bits, 61 Hz.

Thanks,
bb69
Reply
Hi
Re: screen size
That screen size is not 800x480 - have a look at my example sizes. That is the problem you need to fix - as that doesn't relate to Yatse.
Also the Sony screen doesn't seem to be 1920x1080 given size of Yatse (no more than 800)
Eureka!Rofl
Do you have a zoom, or dpi or other setting enabled?
http://www.sevenforums.com/tutorials/443...hange.html

This would likely be the cause!
Fix change the dpi setting in Windows, or right click Yatse2.exe and change the compatibility settings as below;
Image

Re:3.1 setup version
Does move the files to %appdata%
But otherwise minimal change. Would mind seeing log which should still be at
%appdata%/Yatse 3 Socket/logs

Have made some further changes (now build 110) which supports local files (as yours) so will need to update to that once fix screen.

Glenn

Glenn
Reply
(2015-06-27, 23:31)GlennNZ Wrote: Eureka!Rofl
Do you have a zoom, or dpi or other setting enabled?

Eureka indeed!
Haven't had a chance to have a look at it yet, but that is almost certainly the problem, as I can remember now changing the visual settings when I first built the HTPC.

With regard to the new version, I've downloaded and installed both Yatse2.service.setup and Yatse 3.1.Socket.update.build.110. It appears to install fine. But when I open up the program, the initial Yatse flashes up, followed by a window with some text but that is it, nothing else happens. Although I notice that it showing up in task manager as running.
When I start Kodi a message pops up of "Yatse 2 Plugin Integration Started".

Here is the log file -
pastebin.com/aqYFzUub

Many thanks,
bb69
Reply
(2015-06-28, 19:39)billybob69 Wrote:
(2015-06-27, 23:31)GlennNZ Wrote: Eureka!Rofl
Do you have a zoom, or dpi or other setting enabled?

Eureka indeed!
Haven't had a chance to have a look at it yet, but that is almost certainly the problem, as I can remember now changing the visual settings when I first built the HTPC.

With regard to the new version, I've downloaded and installed both Yatse2.service.setup and Yatse 3.1.Socket.update.build.110.

When I start Kodi a message pops up of "Yatse 2 Plugin Integration Started".

Here is the log file -
pastebin.com/aqYFzUub

Many thanks,
bb69

You need to install the whole program setup file and the then update(s) over the top if needed/any. (Not just the 413kb update file as you appear to have done)

I have updated the files today - install the new complete 26mb setup file (build 121). I have also added a setup setting that will cause yatse exe to ignore the dpi settings. So all being well - just install this and all should be good.
https://github.com/Ghawken/Yatse2-1/releases/tag/v3.1

Glenn
Reply
  •   
  • 1
  • 46
  • 47
  • 48(current)
  • 49
  • 50
  • 55
  •   
 
Thread Rating:
  • 5 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Yatse 2 : Open Source Media Center Remote Control App for Touch Screen45
This forum uses Lukasz Tkacz MyBB addons.