•   
  • 1
  • 49
  • 50
  • 51(current)
  • 52
  • 53
  • 55
  •   
Win Yatse 2 : Open Source Media Center Remote Control App for Touch Screen
(2015-07-08, 19:45)Slurm Wrote: Thanks GlennNZ, it's working really great.

Is there a way to implement pvr into yatse? And is there a theme with bigger fonts?

Wasn't planning on adding PVR - what happens now? the Nowplaying screen when playback?
Fanart/Background I suspect would be issue - as to where to get these for for Pvr files lacking such.

What were your thoughts?
Reply
When starting pvr nothing happens to the now playing screen. When you change channel you see the information of the old channel. It would be great to see the actual channel information and the channel logo all the time. I don't care about fanart here, could be anything.
Reply
Thanks
What do you mean by information of the old channel? What does Yatse show?
{A full debug/trace log with browsing/using pvr from Yatse would be great/help to sort out the info Yatse already gets}
Reply
If I start with channel 1 I don't get any information, if I switch to channel 2 I see the information and logo from channel 1.

I will try to provide log files.
Reply
Here's the log. I started yatse and kodi and went directly to the first channel in pvr, then I waited shortly and switched to the second channel.

http://pastebin.com/c5MkZyET
Reply
Ok - Sorry taken a while as couldn't quite understand the log...

I wondered what was missing and taken a while to figure out - you need to turn both debug and trace on (you only had debug on not trace) - in the settings screen or via the xml.

Can you turn both on and do the same again.

I suspect may be a bit problematic (as don't use pvr hardware so hard to test) but should be able to hopefully get right channel display at the very least.

Glen
Reply
So, here's the log with trace enabled.

http://pastebin.com/s0vP5jjt
Reply
Thanks - have managed to install demoPVR software on my install - so have been able to test.

Build 145:
- First attempt at PVR NowPlaying support - fanart and thumbnail set to the channel thumbnail (seemingly the only art we get)

https://github.com/Ghawken/Yatse2-1/releases/tag/v3.1
Reply
(2015-07-11, 06:16)GlennNZ Wrote: Thanks - have managed to install demoPVR software on my install - so have been able to test.

Build 145:
- First attempt at PVR NowPlaying support - fanart and thumbnail set to the channel thumbnail (seemingly the only art we get)

https://github.com/Ghawken/Yatse2-1/releases/tag/v3.1

Tested it and it works great. Thanks for the update!
Reply
Hello,

why "Yatse2.Socket.Build.145.Complete.exe"? Is it not yatse3 ?
Reply
Hi
Just a typo will correct
build numbers most accurate, shown in log
Glenn
Reply
Hi Glenn,

I finally had time to spend on my music fanart issues. Since 99% of all my music playback is done via the Google Music plugin. I had to figure out where fanart information is stored (URL's are all embedded in artist.nfo, album.nfo, *.strm text files; cached in my Kodi Music Media folder hierarchy,

IE,

D:\Multimedia Files\Music\Korn\artist.nfo
Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<artist>
    <name>Korn</name>
    <thumb>http://lh3.googleusercontent.com/WMQUaCArVm8cf3wUeBFJjjjSkDFF24GYw97-gyajwaZVDsLLBNe2EkGuOl0IFtmWHrFpqNW_cw</thumb>
</artist>

D:\Multimedia Files\Music\Korn\Issues\2-Falling Away from Me.strm
Code:
plugin://plugin.audio.googlemusic.exp/?action=play_song&song_id=Thzzeumi3ibhfnwrq76e7bhv4ju&title=Falling Away from Me&artist=Korn&albumart=http://lh3.ggpht.com/S5FJLwE1-3z4BigC-9Vo1Yhvtu50HQ1TkWV_j_nAqzg7-3w6G1a_bXE8o8ua5_Vj9-rSQYrqow


Then, made PowerShell script to extract all relavant links from all these reference files; and, download them to Kodi-standard fanart directory structures. I can pretty much do anything using Powershell (especially with access to all .NET classes)!!
<FanartDirectoryMusic>D:\Multimedia Files\CD-Artwork\</FanartDirectoryMusic>

D:\Multimedia Files\CD-Artwork
...
├───Korn
│ │ fanart.jpg
│ │ folder.jpg
│ │
│ └───extrafanart
│ Korn.jpg

...

I finally enabled Yatse2 service with default settings on both Kodi and Yatse.

However, for whatever reason, the Yatse2 Service in Kodi doesn't seem to detect Yatse2 running on port 5000 (I've already confirmed that the socket is open and listening on localhost via port scanner). Hence, Yatse is STILL trying to only looks for fanart json tags from kodi's http server;

Glenn, could you please download my Kodi / Yatse debug logs from the zip package below? All relavant info should be in the zip file. If there's anything missing, please let me know!

Yatse-Socket-debug-MusicFanart

Thanks so much for all your time and support!!!!
Reply
(2015-07-12, 04:01)MKANET Wrote: Hi Glenn,

Ok....Where to start... (Please have a look at the below a few times as believe we have been covering same ground a couple of times)
Thanks for the zip file logs.

Basic Problem is that - Your Directory structure is completely wrong (but easily fixable) as per this past post 2043463 (post)

1. Fix Default Paths
MKANET Wrote:<FanartDirectoryMusic>D:\Multimedia Files\CD-Artwork\</FanartDirectoryMusic>
No this is incorrect -- Cannot be there.
Quote:
Default Directories if No Fanart in extrafanart folder (or if not using yatse2.service)
Defaults to artworker organizer defaults (to use these need to have artwork organiser addon added and run)
They must be within or created in %appdata%\Kodi\userdata\
eg.
Fullpath is %appdata%\Kodi\userdata\addon_data\script.artworkorganizer\ArtistFanart\ or on your install

C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.artworkorganizer\ArtistFanart\


The above are the DEFAULT - used if no extrafanart directories only. Should be a pile of images with no folders - when there is no artist specific fanart this is used.
ALSO: as per instructions (see pdf on github)
Code:
Defaults to artworker organizer defaults (to use these need to have artwork organiser addon added and run)
They must be within or created in %appdata%\Kodi\userdata\
http://kodi.wiki/view/Add-on:Artwork_Organizer
<FanartDirectoryTV>addon_data\script.artworkorganizer\TVShowFanart\</FanartDirectoryTV>
<FanartDirectoryMovie>addon_data\script.artworkorganizer\MovieFanart\</FanartDirectoryMovie>
<FanartDirectoryWeather>addon_data\skin.aeonmq5.extrapack\backgrounds_weather\</FanartDirectoryWeather>
<FanartDirectoryMusic>addon_data\script.artworkorganizer\ArtistFanart\</FanartDirectoryMusic>
<FanartDirectoryMyImages>addon_data\script.artworkorganizer\OwnFanart\</FanartDirectoryMyImages>
They must be within or created in %appdata%\Kodi\userdata\

MKANET Wrote:<FanartDirectoryMusic>D:\Multimedia Files\CD-Artwork\</FanartDirectoryMusic>
(on your setup from the log Yatse is looking here:
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\"D:\Multimedia Files\CD-Artwork\" clearly this doesn't exisit)

Need to fix this would suggest use artwork.organiser defaults as above and run artwork organizer

2. Move Artist/extrafanart directories to KodiMusicRoot

The Extrafanart folder is the only one used, other than cdart.png for local albums.
As mentioned a few times with your CdArtManager issues - the extrafanart directory needs to be
(see this post 2043463 (post))

:Kodi MUSIC Source
----/ArtistName Folder
----------/extrafanart/
---------------Images, Images, Images, Images (these are the ones used - if exist)

This is the default for CdArtManager when select download fanart all artists, which will download, create and fill all these extrafanarts.

From the log this is for your install

D:\Multimedia Files\Music\ARTISTNAME\extrafanart\ <--- artist images go herel, all of them...

For example you play Rev Theory song from googlemusic during the log. It tries to find artwork here:
"D:\Multimedia Files\Music\Rev Theory\extrafanart\"
This directory is checked for fanart images - none are found, so default used.
& later
no images in D:\Multimedia Files\Music\Rodney O\extrafanart\
etc.etc.

So:
Copy you Cd-Artwork tree to the Kodi Music Source folder which is D:\Multimedia Files\Music\ (will use the extrafanart folders)

3.Connection:
Actually the connection seems fine.
Connection - does connect and does send socket info without any problems in the Yatse log
Kodi shows one failure connection - but I believe Yatse was closed.
&

Finally - if not otherwise --
4. Music Fanart Rotation needs to be OFF (I should really disable it as can't see point)

So:

1. Hopefully can sort out path tree - only the extrafanart directory will be used - so welcome to copy all the relevant artist fanart there.
Then:
2. Default paths need to be changed in the xml (as above). These are for a collection of fanart from every artist, or every tvshow or every movie in your library (which is used when no fanart for any of these categories)
Again these are the defaults for artwork.organiser. Add-on:Artwork_Organizer (wiki) - install and run and will populate these fanart directories for you.
I would change the xml back to the defaults - and use artwork organizer to fill. Need to be within %appdata%/Kodi/userdata/ if using another directory of your choosing
3. Make sure music fanart rotation is off..

for more see the now updated pdf instructions
https://github.com/Ghawken/Yatse2-1/rele...ctions.pdf
Reply
Hi Glenn, thanks for the great reply.

Just an extra note: I did get the CD-ART addon to work. In fact, D:\Multimedia Files\CD-Artwork\ IS my CD-Art addon image directory (created by the CD-ART addon). My script just used the same directory structure, image file naming format as what the CD-ART plugin image outputs after successfully scanning my local mp3 files.

I'll look at script.artworkorganizer next, per your suggestions. Thanks again for all your time.
Reply
Glenn,

I tried two separate tests...

Test1: Solely depend on extrafanart
I placed the image file (as in below screenshot). The image was completely ignored when I started playback. Here's the logs:
extrafanart-debug-logs

Test2: Solely depend on images in:
C:\Users\MKANET\AppData\Roaming\Kodi\userdata\addon_data\script.artworkorganizer\ArtistFanart

Unfortunately, same symptoms as always... images are completely ingored when starting playback of respective strm file Here's the logs:
Artworkorganizer-debug-logs

Am I missing something still? I really dont want to use the socket service unless I really have to. I'm hoping you can find what I'm doing wrong.

BTW: What's the correct way to also include the respective thumbnail images to show up using both methods above? I saw you suggestion about cdart.png; but, only have thumbnails in jpg.. anyway, cdart.jpg was ingored when placed under Music\Artist\Album.

Image

Image
Reply
  •   
  • 1
  • 49
  • 50
  • 51(current)
  • 52
  • 53
  • 55
  •   
 
Thread Rating:
  • 5 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Yatse 2 : Open Source Media Center Remote Control App for Touch Screen45
This forum uses Lukasz Tkacz MyBB addons.