Generic xrandr / fglrxinfo question
#1
Hi there,

figured i needed to get writing access because i could not come up with the solution to my problem.

I have just gone through (after trying xbmc under windows) to get it working in its own Ubuntu minimal system.

All working fine, actually got the remote working, sound working, you get the idea.

The only situation i have is due to using an ATI card and its "preconfigured" underscan. Under windows you have a slider in the control center to adjust for that. My TV does not have any option to compensate so i am hunting up and down the forum to get a solution.

+++

Being on a minimal system i use the terminal (or lets say an SSH session) to configure the system. All working well except for the ati driver related tools like fglrxinfo or xrandr. Both keep saying they cannot access the display. Neither from the SSH session nor from a CTRL+F1 terminal on the xbmc system itself.


Is it right that i have to login via SSH with the xbmc user, which is running XBMC on the main display in order to get any readouts for fglrxinfo or xrandr?

Or is it necessary to "export the display", another solution i found here in the forums. Does XBMC have to be running(in main menu for example)?
Reply
#2
overscan can be set in xbmc in the settings. you'll find this a lot easier than messing with the graphics card directly.

the only way i managed to sort out overscanning with an nvidia card was through trial and error editing xorg.conf modelines, and it was a nightmare.

this was before i discovered xbmc and when i did on my next install, i simply went to settings > system > video calibration within xbmc

as an aside, xrandr etc doesnt work through ssh because its using its own session. again tty1 (or 0, or whatever alt+ctrl+f1 gives you) is using its own session too (one without xorg, again, so no xrandr and graphical settings tools).

i guess really the only thing you could do if you do want to deal with command line tools like xrandr is to use them from within the X (the graphical) session that xbmc intiates. if you install the launcher plugin in xbmc you could launch a terminal whilst within xbmc. it should appear above xbmc and you'll be able to use xrandr within the right X session.

this should all be irrelevant though because settings > system > video calibration within xbmc should do what you want
Reply
#3
Thanks, i will try the terminal inside xbmc.

Note ati somehow produces UNDERSCAN instead of overscan. This is not editable with the video calibration setting.

With overscan you could move the arrows more to the inside in order to have the picture fully on the display. Underscan however brings up a .5 inch black border around the entire screen and you cannot move the screen outside of this border.
Reply
#4
ahhh, i just assumed you'd mistyped as id never heard of it before!

if you still have problems you could always try installing a graphical environment do get to the ATI control panel. ive never used ATI cards though so i dont know if it'd be useful.

the smallest one to install whilst still giving you a workable environment would be openbox
Code:
sudo apt-get install openbox

it has a right-click menu, and from there you should be able to launch a terminal and install your ATI control panel, perhaps a gui text editor (like leafpad) and maybe a gui package manager (like synaptic)
Reply
#5
Thanks. I will consider this as well.

Good enough to know that i do not need to pull my leg because it is not working from ssh. Spent quite some time trying to get it working from the ssh session and thought it has to do with my equipment.

There are actually solutions for the underscan, both with the propietary drivers and with the opensource ones, from the command line. But as you confirmed it can only work while some other graphical interface is running. Otherwise both xrandr and flgrxinfo just recheck any commands you give
Reply
#6
hey alexandergoll,

I was working on the exact same issue last night with my ATI HD4200 (onboard) connected to my Denon Amp via HDMI.

I have gone through a number of things to try resolve it with xrandr / aticonfig / modding ModeLines in xorg.conf etc. but had no luck!

Hope we/you can find a solution! look forward to your test results
Reply
#7
well.. after some mucking around.. i have now installed Ubuntu 10.10 instead with the latest ATI Driver 10.10 which now has the overscan/underscan slide bar to adjust the screen.

I previously had massive problems with previous drivers so this is a good sign on Maverick and the ATI drivers.

If your not too fussed bout using XBMC Live strictly.. i suggest trying Ubuntu 10.10
Reply
#8
Well i want to setup an ubuntu minimal with just xbmc.

My current setup is totally messed up and i will start from sratch once again. All that driver messing corrupted something i think and its not revertable (for me)

I have found a way to start the control center from the terminal while XBMC(or the X session is running)

So if i get the slider in 10.10 drivers i will try to install those and see if it works.

I already tried to install the 10.10 drivers yesterday, as per information on screen it went on smoothly however xbmc always complains about missing OpenGL features.

Thanks for your input
Reply
#9
I'd like to post the resolution to the underscan problem running xbmc-live (or standalone on minimal ubuntu)

With the new 10.10 drivers i was able to start "amdcccle" using the xbmc launcher plugin.

I was then able to use the built-in slider in the ati control panel to remove the underscan (similar to windows)

Had to click "ignore internal scaling" (or similar, it is the tick box below the slider) to make the setting stick.

I am very happy now. Time to add movies now to the library
Reply



Logout Mark Read Team Forum Stats Members Help
Generic xrandr / fglrxinfo question0
This forum uses Lukasz Tkacz MyBB addons.