OpenELEC Testbuilds for RaspberryPi Part 2
#88
(2013-07-29, 05:32)MilhouseVH Wrote: I'm not sure what more I can add - I'm currently waiting for an R-Pi 512MB to come back to me that has for the second time in a matter of weeks stopped booting from it's 4GB Transcend SD card which only contains a single FAT partition, as /storage is mounted from NFS.

I'd already replaced one SD card a couple of weeks ago, now this Pi seems to have buggered up a second card (assuming it's the same problem). The first card will not even boot a different Pi, despite there being no filesystem errors and all boot files are present and correct - it's rather bizarre (and there are no flashes LEDs when booting, just a solid red power light).

Maybe it's a coincidence (although I am clutching at straws) but this has only been a problem since about 3.1.0-ish.

Can you try copying the files from FAT partition off the sdcard, formatting it (which should be safe, windows won't touch the ext partitions), and copying back on (and checking they are identical to expected ones).

EDIT: could you backup the sdcard (with dd/winimage) first. Just in case my suggestion fixes it, it may be interesting to analyse the FAT partition.
I have a suspicion that when FAT parition gets sufficiently defragmented it may provoke a bug in the bootcode that stops it booting - but that is not proven.


Messages In This Thread
RE: OpenELEC Testbuilds for RaspberryPi Part 2 - by popcornmix - 2013-07-29, 12:27
AW: RE: - by DieterLumpen - 2013-07-29, 20:50
include guires switch? - by hpbaxxter - 2013-08-01, 21:46
RE: dual audio?? - by pootler - 2013-08-03, 17:13
Help, watch 3D Film on Non 3D TV - by unix72 - 2013-08-09, 12:39
Remote Controllers - by tfft - 2013-08-14, 09:11
rbej repeatable crash - by RichG - 2013-08-19, 12:43
New Tester - by theneverstill - 2013-10-03, 17:16