Solved Linux What version of java is needed?
#17
Hello again. Well, I just kept using Java 1.6, but with today's update came a warning that this version will be unsupported. So I tried other Java versions... And *again* there was the problem of blank gray, screens.

I finally found how to solve this. Also see: https://awesome.naquadah.org/wiki/Problems_with_Java

It is really stupid, but apparently, the "problem" was that I am using xmonad. I'm not familiar with any of this, so I won't try to seem smart Tongue Just see this quote from the page:

Quote:Impersonate Another Window Manager

You may use the wmname utility to make the JVM believe you are running a different window manager. This utility is available in the suckless-tools package in Debian (and Ubuntu); this Portage tree provides wmname for Funtoo (and Gentoo).

Code:
$ wmname LG3D
(You must restart the application in question after issuing the wmname command.)

This works because the JVM contains a hard-coded list of known non-re-parenting window managers. For maximum irony, many users prefer to impersonate “LG3D,” the non-re-parenting window manager written by Sun, in Java.

So... first I do 'wmname LG3D' and then start up TMM. And voila. It works.

This is probably the most annoying and strange problem I have ever come across. But I wanted you to know about this, for if others get the same issues as I have had for many months.


Messages In This Thread
RE: Linux What version of java is needed? - by caffeineguy - 2015-05-15, 22:28


Logout Mark Read Team Forum Stats Members Help
Linux What version of java is needed?0
This forum uses Lukasz Tkacz MyBB addons.