XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares
#1
Ok, the short of it is that after upgrading my main PC to Win 10, all my HTPC's started reporting that my movie and TV shows were missing (and did I want to remove them from my library).

So I went to edit the source, navigated to SMB share, and realize it won't connect anymore. it occurs to me that Win 10 replaced my login name and password with my Microsoft Account (Windows Live ID). So I type in my Live login (email + password), and no luck. I then try my MS Account alias + password... no luck.

So I go into user settings and I disconnect windows from MS Live and convert my admin account to a local account.

Now, back at the HTPC, I can actually browse the shared folders when I select my PC through SMB. Yay, the connection is working! or is it...

I have 10 drive shares. 2 of the shared drives are internal (SATA connected) and the other 8 are in external drive bays (USB 3.0 connection). Oddly, the two internal drives seem to be able to connect perfectly fine. The 8 external drives (where my media is) refuse to connect. It tells me "Invalid Argument" when I select these drives.

Googling this leads to a few pages about registry edits. Granted, they are specifically for Win 8, but as there isn't much info for Win 10 these days, I tried them. The first entails popping the IRPStackSize up and the second revolved around enabling access to SMB without authorization. Neither seemed to make a difference.

In frustration I rolled back the Win 10 install to Win 7, and immediately all my drives were accessible via XBMC again.

Now, the extra details:
Yes, I am running Frodo 12.3, installed via OpenElec. I have not moved to Kodi as the skin I use, Aeon Nox, has had *many* features removed from it since the version I have. Until I can get a Kodi setup that doesn't require giving up features I used to have, I don't plan on upgrading. Either way, the problem appears to be windows rather than XBMC/Kodi.

I have a laptop running Win10, so when I have free time I plan to share a media folder on it and see if I can get any of my HTPC's to recognize it. That said, I'm not sure how good this plan is, as I *was* able to get internal drives to show up just fine in XBMC. I have no idea why every single drive in the external bay was having problems (the permissions and settings on those shares were identical to the internal drives).

I will likely have to continue messing with it on my main machine. I'm posting here in hopes of finding others who may have had similar problems. Thanks!
Reply


Messages In This Thread
XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares - by exoscoriae - 2015-08-18, 16:11


Logout Mark Read Team Forum Stats Members Help
XBMC 12.3 (Frodo) + Win 10: Broken SMB Shares0
This forum uses Lukasz Tkacz MyBB addons.