OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-01-08, 01:06)bill_orange Wrote:
(2016-01-08, 00:32)MikeKL Wrote:
(2016-01-07, 04:45)bill_orange Wrote: I concur. Music files play when accessed through FILES but not when accessed through ALBUMS.
@popcornmix and @Milhouse, that was quick just tested in build #0107 and playback working via music library options Cool

Almost fixed. You can navigate to ALBUMS and successfully play a track. However, while the track is playing, if you navigate to ARTISTS and try to navigate to an artist you get "couldn't connect to network server". I am not streaming music from a network server. The library is on a USB stick. I tried navigating to FILES and I got the same error. this behavior is new to this build.

Bill

I can confirm this sideeffect on my own newclock5 builds, reverting PR8797 (7ddad402) seems to fix this, but playing music from library is broken again then.

edit:
This happens if navigating through "main" options in home screen, eg select "videos" and try selecting "files".

Relevant errors from kodi.log:
Code:
01:20:55 5503.290039 T:1737487248   ERROR: GetDirectory - Error getting /usr/share/kodi/system/library/video/files.xml/
01:20:55 5503.290039 T:1737487248   ERROR: GetDirectory - Error getting special://xbmc/system/library/video/files.xml/
01:20:55 5503.290039 T:1942716416   ERROR: GetDirectory - Error getting library://video/files.xml/
01:20:55 5503.291504 T:1942716416   ERROR: CGUIMediaWindow::GetDirectory(library://video/files.xml/) failed

The errors are not present with PR reverted.


Messages In This Thread
RE: OpenELEC Testbuilds for RaspberryPi (Kodi 17.0) - by asavah - 2016-01-08, 01:34
RPI 3 no internet access on wifi - by b1m1 - 2016-03-09, 14:44


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)6
This forum uses Lukasz Tkacz MyBB addons.