Finaly got BBC Radio streams working again
#1
BBC radio streams used to work for me but recently they stopped working. They would play for about a minute or so and then stop. Well after searching around I couldn't find an answer.

In an attempt to fix it I upgraded to the latest T3CH build o XBMC which didn't help. In fact the latest build ended up breaking my ShoutCast steams too. Also with the new build my BBC streams wouldn't even try to play until I renamed my .PLS files to .STRM files. Then it would try to play but not even start buffering. I had a feeling the ShoutCast streams stopped working because of a user agent string change in this build. So I used a packet sniffer to figure out what winamp uses for it's user agent string. Then I changed the user agent string that XBMC uses.

To do this edit the mplayer.conf file which is located in:
/E/Apps/XBMC/system/players/mplayer/

Edit the user agent line to look like this:
user-agent=Winamp/5.35

I figured this would only fix my Shoutcast streams but it also fixed the BBC streams. I also set my Video Cache for internet to 256kb so that the BBC streams would buffer faster. BBC uses RealMedia which can be audio or video, this is why you have to change the video cache even though it is an audio only stream.

Not sure if it is necessary to run the latest XBMC build though. I think the real magic was in the user-agent string. So try that first. If it still doesn't work then try the latest build.

I hope this helps someone. I noticed a few threads where people where having problems with RA streams playing for 1:30 and then stopping but no solutions.
 
Thread Rating:
  • 0 Vote(s) - 0 Average


Messages In This Thread
Finaly got BBC Radio streams working again - by ermax - 2007-11-02, 03:49
[No subject] - by elupus - 2007-11-02, 11:04
[No subject] - by ermax - 2007-11-10, 18:38


Logout Mark Read Team Forum Stats Members Help
Finaly got BBC Radio streams working again00
This forum uses Lukasz Tkacz MyBB addons.