Video smoothness issue.
#1
For a while now (Kodi 16 had this too for me) I have had issues with playback stutters. It's not been terrible but annoying nevertheless.

In short:
- 23.976216 fps source. (according to VLC).
- Once every 5-10 seconds I notice a frame drop. It's (of course) much clearer when there is a horizontal pan
- Kodi's reported playback rate is 23.98hz according to xrandr and 23.976080 according to kodi.log
- SSD harddrive, gigabit ethernet, widely overdimensioned cpu (10% cpu load max during playback)

Here is my full debug kodi.log showing startup, and then playing back a video file for a minute or two.

The only thing I noticed in the kodi log is that it identified the available video mode as '23.976080' which is 0.000136 fps off the source framerate, but surely this means that there 'should be' some stutter once every 1/000136=7352 seconds, not every 5.

My control sample is a PS3, and it plays back stutter-free, so I have to conclude the 'kodi side of things' (perhaps kodi, perhaps ubuntu, perhaps player hardware) is at fault somehow?

FWIW some specs:
- Kodi 17 on Ubuntu 16.04.2 LTS
- Mac Mini (Intel Core i5, 2.3Ghz, Sandybridge, Intel HD3000 video) - dmesg output

Please let me know if I can provide more info or how to proceed to debug this?
System: Kodi on NVidia Shield 2015
Video: Panasonic AE3000 Projector / Samsung 46" LCD
Audio: Quad 2912 on Nord DM500Up with Marantz 7010 receiver.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average


Messages In This Thread
Video smoothness issue. - by puntloos - 2017-02-20, 02:23
RE: Video smoothness issue. - by FernetMenta - 2017-02-20, 11:42
RE: Video smoothness issue. - by puntloos - 2017-02-20, 17:11


Logout Mark Read Team Forum Stats Members Help
Video smoothness issue.00