Linux Schedules Direct Setup on Ubuntu Server
(2018-02-16, 16:38)rpcameron Wrote:
(2018-02-16, 09:38)tjay260476 Wrote: @rpcameron could you post instructions for that, so other users can have the option to do so, such like myself?

No offense, but if you need instructions on how to clone a repository and copy a single file into your $PATH, then you probably shouldn't be messing around on a command line with root privileges.

The repo is here:

I believe you will need a couple more Perl modules beyond what XMLTV requires. Off the top of my head they are:
  • DateTime::Format::SQLite
  • DBD::SQLite
  • File::Homedir
  • JSON
  • JSON::XS (not required, but makes things MUCH faster)
  • LWP:: Protocols::HTTPS
  • LWP::UserAgent:: Determined
That's not a comprehensive list, and some may be redundant. (On my system I create a base XMLTV that only includes the modules and utilities, but no grabbers, so my initial requirements are different.) If you go to run the grabber and it complains about a missing module, just install it from your OS's repo, then run it again. Keep repeating until it runs.

JSON::XS isn't a necessary module, but it makes a huge difference, so I highly recommend you install it.

(Damn auto-creating smilies ...)  
@rpcameron i'm interested in using tv_grab_zz_sdjson_sqlite, I've copied over the files to usr/bin and ran tv_grab_zz_sdjson_sqlite --manage-lineups the only thing it complained about was LWP::UserAgent:: Determined which I've managed to installed.

Using the hts user i run tv_grab_zz_sdjson_sqlite --manage-lineups and i initialize the the database, choose a name and then exit... when i run tv_grab_zz_sdjson_sqlite --configure, it will ask me for the database name i created, select a lineup and MythTV category processing. however once all selected it will then just jump back to the cmd prompt, i'm kind of thinking it shouldn't do that? and there should be more to configure process, am i right?

when i run tv_grab_zz_sdjson_sqlite it does seem to run ok and bring back data, however, when i run the internal grabber in TVH, i get:


2018-02-18 09:49:39.924 spawn: Executing "/usr/bin/tv_grab_zz_sdjson_sqlite"
2018-02-18 09:49:40.404 spawn: Opening the local database
2018-02-18 09:49:40.404 spawn: Can't call method "errstr" on an undefined value at /usr/bin/tv_grab_zz_sdjson_sqlite line 3897.
2018-02-18 09:49:40.411 xmltv: /usr/bin/tv_grab_zz_sdjson_sqlite: no output detected
2018-02-18 09:49:40.411 xmltv: /usr/bin/tv_grab_zz_sdjson_sqlite: grab returned no data

Which makes me think it cant open up the database, any pointers in working out whats wrong?

Messages In This Thread
RE: Schedules Direct Setup on Ubuntu Server - by AshG - 2018-02-18, 11:31

Logout Mark Read Team Forum Stats Members Help
Schedules Direct Setup on Ubuntu Server1
This forum uses Lukasz Tkacz MyBB addons.