Important Attn: Addon Devs - Python 3 compatible addons
#37
(2020-04-04, 08:02)Skipmode A1 Wrote: I was wondering why do i need to bump the dependencies?

If you mean library dependencies, the version attribute specified the minimal required version number and is actually optional.

BTW, I have updated my kodi-addon-submitter script that allows to automate addon submission using CI/CD pipelines like Travis CI or GitHub Actions. Now it supports parallel submissions of Python 2/3 addons to Matrix and lower branches. It means that if you submit a Python 2/3 compatible addon, for example, to Krypton branch, the script will automatically update addon.xml with proper version numbers  and create an additional pull request to Matrix branch.
Reply


Messages In This Thread
RE: Attn: Addon Devs - Python 3 compatible addons - by Roman_V_M - 2020-04-04, 15:35


Logout Mark Read Team Forum Stats Members Help
Attn: Addon Devs - Python 3 compatible addons0
This forum uses Lukasz Tkacz MyBB addons.