Opensubtitles by opensubtitles has stopped working since yesterday
#15
(2020-03-27, 13:59)jim_p Wrote: Maybe it was "some sort of issue which was resolved" this time, making my rant unjustified. What you may not know is that it has shown a similar behavior at least once in the past (2+ years ago) with a 503 error and at that time the "regular" addon was working as it should. This led to patches and forks from volunteers, but the issue was not on the addon itself but on the opensubtitles api, as the dev (or whoever has the username "opensubtitles" on github) admitted.

This time however, there was no error and there has been no statement of any sort for the issue, at least until today. What would you think as a user, if you say that I am just ranting with no reason? After all, what fueled the comments and my rant here was not the issue itself but my statement on denying to make credentials.
The only good thing that all those comments brought is the proof that other apps and scripts do use the api without credentials, thus making any statement like "you need a username and a password because of X reasons" completely invalid.

If an app kept working like you were saying when they had to close the door to anomymous API usage then it didn't use the API.
It's that simple.
When/if they have traffic issues again (maybe they have so much traffic now because of the corona-virus), the logical thing for them to do is to close the door to anomymous API usage and they have every right to "protect" their service.
I agree it's time to move on, but keep in mind that it can happen again, they don't owe us anything Smile


Messages In This Thread
RE: Opensubtitles by opensubtitles has stopped working since yesterday - by olympus - 2020-03-27, 14:43


Logout Mark Read Team Forum Stats Members Help
Opensubtitles by opensubtitles has stopped working since yesterday0
This forum uses Lukasz Tkacz MyBB addons.