XBMC Subtitles - Legendas.TV not working properly.
#16
Well, last sunday i faced the same problem... i tried to watch "kung fu panda" at xbmc eden rc 2... and it didn't connected to the xbmc subtitle add-on... then i watched it in vlc, subtitles downloaded...

well... today i downloaded the stable xbmc eden, installed and tried the kung fu panda 2 again... and worked well... connected to podnapisi.net... then i tried 127 hours... same connection problem...

so i logged i trying to watch 127 hours and trying to download the subtitles without success, then kung fu panda 2 with success and finally for few dollars more without success... 127 hours don't have any previous subtitle file, but kung fu panda 2 and for a few more dollars have previous subtitle files

http://pastebin.com/17PwfbUx
Reply
#17
Hi there. I'm also facing the same problem. First download works but after that it always fails. Restarting xbmc make it work again, but just for the first download again.

http://pastebin.com/VVpBXGQk

...::::EDIT::::....

It seems to work everytime while using only opensubtitle.org. Legendtas.tv seems to be the cause of the problem. After downloading the first time, it stops working and then even opensubtitle.org stops working too.
Reply
#18
(2012-04-01, 13:46)Killer-JoeBR Wrote: Hi there. I'm also facing the same problem. First download works but after that it always fails. Restarting xbmc make it work again, but just for the first download again.

http://pastebin.com/VVpBXGQk

...::::EDIT::::....

It seems to work everytime while using only opensubtitle.org. Legendtas.tv seems to be the cause of the problem. After downloading the first time, it stops working and then even opensubtitle.org stops working too.

it is somehow linked to .rar file that gets downloaded from LegendasTV ... I cannot reproduce to be able to fix.
Reply
#19
I disabled the automatic download on setup and now it's ok...
Reply
#20
(2012-04-01, 14:37)amet Wrote: it is somehow linked to .rar file that gets downloaded from LegendasTV ... I cannot reproduce to be able to fix.

You can't reproduce because you don't have an account at LegendasTV or because for you it woks flawsless?

Just wondering. Maybe it's related to OS? I'm using windows 7.


..:::EDIT:::..

Doing further tests, if i revert back the addon to a previous version it works for the first download again without needing to restart xbmc. Then it stops working after the first download, then if i updtate to the last version it works again one more time and so on.

Maybe a cache problem? Needs to clean cache or refresh? Anyway, hope this info helps. Thanks



Reply
#21
(2012-03-07, 09:10)amet Wrote: I have notified gfjardim who made this service, lets see if he can do something about it.

Sorry about the delay, I didn't saw the private message.
I found the bug to be related to the extract function of XBMC. If you try to remove the compressed file while it's handled by that function, it crashes and there's no coming back.
I built a workaround to this behavior and requested a pull at Github.
Reply
#22
(2012-04-02, 21:50)gfjardim Wrote:
(2012-03-07, 09:10)amet Wrote: I have notified gfjardim who made this service, lets see if he can do something about it.

Sorry about the delay, I didn't saw the private message.
I found the bug to be related to the extract function of XBMC. If you try to remove the compressed file while it's handled by that function, it crashes and there's no coming back.
I built a workaround to this behavior and requested a pull at Github.

thx a lot, I have pulled it in... will release to official repo soon
Reply
#23
Just wanted to say that it's working great now. THANK YOU!
Reply
#24
(2012-04-05, 16:07)Killer-JoeBR Wrote: Just wanted to say that it's working great now. THANK YOU!

How did you fix it ?

I am still having this issue.
Reply
#25
(2012-04-02, 21:50)gfjardim Wrote:
(2012-03-07, 09:10)amet Wrote: I have notified gfjardim who made this service, lets see if he can do something about it.

Sorry about the delay, I didn't saw the private message.
I found the bug to be related to the extract function of XBMC. If you try to remove the compressed file while it's handled by that function, it crashes and there's no coming back.
I built a workaround to this behavior and requested a pull at Github.

Thank you. It seems to work perfectly now.

Awesome!
Reply
#26
for does of you that cannot download subtitles make sure that

network > services > use proxy services > is set to off



Anthem MRX310 | XTZ 93.23 DIY 5.1 (Seas Jantzen Mundorf) | DXD808 | Oppo 103D | LG OLED 55EC930V | Nvidia Shield | ATV3





Reply
#27
Hey everyone,

I'm having problems downloading some subtitles from legendas.tv. I think the problem occurs with subtitles that have a dash "/" character in the name, like this one:
Smash.S01E11.HDTV.x264-LOL/2HD/AFG/DIMENSION/CtrlHD
http://legendas.tv/info.php?d=c102f3aa08...da442a2ff6


Here's the error from xbmc.log
Code:
00:03:10 T:2422770544   ERROR: Exception in python script callback execution
00:03:10 T:2422770544   ERROR: Traceback (most recent call last):
00:03:10 T:2422770544   ERROR:   File "/home/xbmc/.xbmc/addons/script.xbmc.subtitles/resources/lib/gui.py", line 494, in onClick
00:03:10 T:2422770544   ERROR: self.Download_Subtitles( self.getControl( SUBTITLES_LIST ).getSelectedPosition() )
00:03:10 T:2422770544   ERROR:   File "/home/xbmc/.xbmc/addons/script.xbmc.subtitles/resources/lib/gui.py", line 303, in Download_Subtitles
00:03:10 T:2422770544   ERROR: zipped, language, file = self.Service.download_subtitles(self.subtitles_list, pos, zip_subs, self.tmp_sub_dir, self.sub_folder,self.session_id)
00:03:10 T:2422770544   ERROR:   File "/home/xbmc/.xbmc/addons/script.xbmc.subtitles/resources/lib/services/LegendasTV/service.py", line 61, in download_subtitles
00:03:10 T:2422770544   ERROR: for root, dirs, files in os.walk(extract_path, topdown=False):
00:03:10 T:2422770544   ERROR:   File "/usr/lib/python2.7/os.py", line 284, in walk
00:03:10 T:2422770544   ERROR: if isdir(join(top, name)):
00:03:10 T:2422770544   ERROR:   File "/usr/lib/python2.7/posixpath.py", line 71, in join
00:03:10 T:2422770544   ERROR: path += '/' + b
00:03:10 T:2422770544   ERROR: UnicodeDecodeError
00:03:10 T:2422770544   ERROR: :
00:03:10 T:2422770544   ERROR: 'ascii' codec can't decode byte 0xa3 in position 6: ordinal not in range(128)
Reply
#28
(2012-04-22, 11:50)couto27 Wrote: for does of you that cannot download subtitles make sure that

network > services > use proxy services > is set to off

Thanks. i just downloaded a Nighty build and thought that the problem was here. but this solved the problem for me.

it make sense that proxy should be turned off. but don´t understand why opensubtitles can find the results but not download
Reply
#29
(2012-05-12, 15:41)Mock Wrote: ... but don´t understand why opensubtitles can find the results but not download

thats cos we search using xmlrpclib, and download using http
Reply
#30
(2012-04-26, 03:10)cidus Wrote: Hey everyone,

I'm having problems downloading some subtitles from legendas.tv. I think the problem occurs with subtitles that have a dash "/" character in the name, like this one:
Smash.S01E11.HDTV.x264-LOL/2HD/AFG/DIMENSION/CtrlHD
http://legendas.tv/info.php?d=c102f3aa08...da442a2ff6


Here's the error from xbmc.log
Code:
00:03:10 T:2422770544   ERROR: Exception in python script callback execution
00:03:10 T:2422770544   ERROR: Traceback (most recent call last):
00:03:10 T:2422770544   ERROR:   File "/home/xbmc/.xbmc/addons/script.xbmc.subtitles/resources/lib/gui.py", line 494, in onClick
00:03:10 T:2422770544   ERROR: self.Download_Subtitles( self.getControl( SUBTITLES_LIST ).getSelectedPosition() )
00:03:10 T:2422770544   ERROR:   File "/home/xbmc/.xbmc/addons/script.xbmc.subtitles/resources/lib/gui.py", line 303, in Download_Subtitles
00:03:10 T:2422770544   ERROR: zipped, language, file = self.Service.download_subtitles(self.subtitles_list, pos, zip_subs, self.tmp_sub_dir, self.sub_folder,self.session_id)
00:03:10 T:2422770544   ERROR:   File "/home/xbmc/.xbmc/addons/script.xbmc.subtitles/resources/lib/services/LegendasTV/service.py", line 61, in download_subtitles
00:03:10 T:2422770544   ERROR: for root, dirs, files in os.walk(extract_path, topdown=False):
00:03:10 T:2422770544   ERROR:   File "/usr/lib/python2.7/os.py", line 284, in walk
00:03:10 T:2422770544   ERROR: if isdir(join(top, name)):
00:03:10 T:2422770544   ERROR:   File "/usr/lib/python2.7/posixpath.py", line 71, in join
00:03:10 T:2422770544   ERROR: path += '/' + b
00:03:10 T:2422770544   ERROR: UnicodeDecodeError
00:03:10 T:2422770544   ERROR: :
00:03:10 T:2422770544   ERROR: 'ascii' codec can't decode byte 0xa3 in position 6: ordinal not in range(128)

Can you post your OS and version?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC Subtitles - Legendas.TV not working properly.00