Thread Rating:
  • 0 Vote(s) - 0 Average
Xbmc Shutdown
#1
When i want to shut down xbmc to desktop i click exit button on my control and the bar comes up with shutdown, restart and so on but can xbmc be set to just shutdown to desktop just by pressing the exit button.
Reply
#2
If I get it right, you want to see only the 'Exit' button and pressing which XBMC should exit to show the desktop. If you are using XBMC Eden with confluence skin, you can do this by editing the 'DialogButtonMenu.xml' file under 'C:\Program Files\XBMC\addons\skin.confluence\720p'. Set the visibility of the button controls you don't want to see to 'false' as in <visible>False</visible>
Reply
#3
Nope. He doesn't want to even see the exit button. He just wants it to exit when he presses a button, no pop-ups.

How are you controlling XBMC? If using EvenGhost that would be a snap. Otherwise you just need to make an edit to your remote keymap remote.xml file.

Change line 65:
Code:
<power>XBMC.ShutDown()</power>

to:
Code:
<power>XBMC.Quit</power>

You can find this file in the XBMC install folder\system\keymaps. Copy the remote.xml file to you userdata folder into the keymaps folder. Then edit as you need.
Read this before using these builds.
Changelog
Reply
#4
I use imon with the veris RM 200, the remote below and this is what i want to happen.

The power putton on my remote shuts down my htpc system which is what i want but i have the app exit button on the top left. If i click the app exit button the exit menu on xbmc comes up and i have to click exit but as you said kricker i just want xbmc to shut down to desktop without the menu.

Image
Reply
#5
Either do as I mentioned above, or in the iMon software map that button to quit XBMC. It has been a while since I setup an iMon remote, so I can't remember exactly how to do it. I remember something in the iMon where the different apps can have buttons assigned to whatever you want them to do. The one I last setup sent keyboard commands, which means instead of editing the remote.xml file you need to edit the keyboard.xml file.
Read this before using these builds.
Changelog
Reply
#6
I have a Mediagate remote and I assigned the following function via the remote registry edit for the "#" key on the remote so that it sends "alt-f4" to close XBMC.

Quote: 1C,00,00,00,04,04,3d,\ ; # - sends "alt-f4" (close xbmc)
Reply
#7
If possible you should send the XBMC command to quit. This will be a more graceful close than doing an Alt+f4.
Read this before using these builds.
Changelog
Reply
#8
Anyone got any links to learn how to do these things I'm quite new with htpc's and xbmc, i wouldn't know where to start.
Reply
#9
(2012-04-05, 18:23)kricker Wrote: If possible you should send the XBMC command to quit. This will be a more graceful close than doing an Alt+f4.

Thanks for the tip, I will look into this.
Reply
#10
(2012-04-05, 19:16)voyagerxp Wrote: Anyone got any links to learn how to do these things I'm quite new with htpc's and xbmc, i wouldn't know where to start.

I told you above how to do it. What step are you stuck at?
Read this before using these builds.
Changelog
Reply
#11
Thanks kricker, sorted it, its just temp as i'm buying a harmony one control soon to do away with this awful RM 200 remote.
Reply
#12
(2012-04-05, 18:23)kricker Wrote: If possible you should send the XBMC command to quit. This will be a more graceful close than doing an Alt+f4.

What is the command to Quit/Exit XBMC, I tried the following in my keyboard.xml file and it didn't work.

<three mod="ctrl,shift">XBMC.Quit</three>

I think this was the reason that I was using alt-f4, since that was the only way I had found to quit XBMC.
Reply
#13
That should be it.

http://wiki.xbmc.org/index.php?title=Lis..._functions

I edited my keyboard.xml file. In the global section I changed s to be XBMC.Quit and it worked perfectly.
Read this before using these builds.
Changelog
Reply
#14
(2012-04-06, 02:45)kricker Wrote: That should be it.

http://wiki.xbmc.org/index.php?title=Lis..._functions

I even tried Quit by itself and I tried XBMC.Quit(), but neither worked. This setting is under my <keymap>, <global>, <keyboard> section, maybe that is not the right section.
Reply
#15
Global is the proper section. I just edited my post above mentioning that. Have you tried it on a basic key without any key mods?
Read this before using these builds.
Changelog
Reply



Xbmc Shutdown00