•   
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  • 76
  •   
[WIP] PVR Client Addon for XBMC for EPG and full control of Dreambox and DBox2
(2012-04-07, 23:06)trans Wrote: Yes, each time the end of XBMC

see http://www.mediafire.com/?cxaaarfwrf5rdrl

(2012-04-10, 00:25)markus625 Wrote: Any of you guys have one of these Raspberry Pi's or maybe a CuBox thats running xbmc would be interested to know if the pvr client would run ok as i believe the Raspberry Pi has only 256Mb where as the CuBox has 1Gb memory but i believe they are both Arm processors, but I read on openelec that they have developed a port to Raspberry Pi.

For anyone that is interested and may have a CuBox lying around, solid run have released a ready to flash xbmc image,

I'm on preorder for the cubox now and I'm also planning on getting a r-pi - so I will at least try to get this work on them (shouldn't be too hard I guess).
VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
Reply
I have another error in the current git master branch.
After the enebled Live TV crashes XBMC. The settings are ok.
The last line of the logfile:
Code:
AddOnLog: VU+ Client: ADDON_Create - Creating VU+ PVR-Client
CAddonCallbacksAddon - ADDON::CAddonCallbacksAddon::GetAddonSetting - add-on 'VU+ Client' requests setting 'host'
CAddonCallbacksAddon - ADDON::CAddonCallbacksAddon::GetAddonSetting - add-on 'VU+ Client' requests setting 'user'


The German letter "Ü ü" in the settings are not displayed

Sorry for my english, I use google translate.
Reply
Seems that once I edit a file on my linux box it screws up the special characters (umlauts).

Also I can reproduce the segmentation fault - which is strange as I did only change the settings.xml...
VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
Reply
This fixes it - but I don't know really why. Did I use the seperators incorrectly?

Code:
diff --git a/addons/pvr.vuplus/resources/settings.xml b/addons/pvr.vuplus/resources/settings.xml
index 5e66c90..b0721b0 100644
--- a/addons/pvr.vuplus/resources/settings.xml
+++ b/addons/pvr.vuplus/resources/settings.xml
@@ -17,18 +17,13 @@

   <!-- Advanced -->
   <category label="30020">
-    <setting label="30021" type="lsep" />
-    <setting type="sep" />
     <setting id="streamport" type="number" label="30002" default="8001" />
     <setting id="webport" type="number" label="30012" default="80" />
     <setting id="user" type="text" label="30003" default="" />
     <setting id="pass" type="text" label="30004" option="hidden" default="" />
-    <setting label="30022" type="lsep" />
-    <setting type="sep" />
     <setting id="recordingpath" type="text" label="30023" default="" />
     <setting label="30017" type="bool" id="onlycurrent" default="false"/>
     <setting label="30009" type="bool" id="showcompleted" default="false"/>
     <setting label="30011" type="bool" id="timerlistcleanup" default="false"/>
-
   </category>
</settings>

Also pushed it to the fix to the master branch..

Code:
0.1.12 add: support to specify the folder for storing recordings
       fix: fix crash due to invalid settings.xml
VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
Reply
(2012-04-10, 19:28)jdembski Wrote: This fixes it - but I don't know really why. Did I use the seperators incorrectly?

Code:
diff --git a/addons/pvr.vuplus/resources/settings.xml b/addons/pvr.vuplus/resources/settings.xml
index 5e66c90..b0721b0 100644
--- a/addons/pvr.vuplus/resources/settings.xml
+++ b/addons/pvr.vuplus/resources/settings.xml
@@ -17,18 +17,13 @@

   <!-- Advanced -->
   <category label="30020">
-    <setting label="30021" type="lsep" />
-    <setting type="sep" />
     <setting id="streamport" type="number" label="30002" default="8001" />
     <setting id="webport" type="number" label="30012" default="80" />
     <setting id="user" type="text" label="30003" default="" />
     <setting id="pass" type="text" label="30004" option="hidden" default="" />
-    <setting label="30022" type="lsep" />
-    <setting type="sep" />
     <setting id="recordingpath" type="text" label="30023" default="" />
     <setting label="30017" type="bool" id="onlycurrent" default="false"/>
     <setting label="30009" type="bool" id="showcompleted" default="false"/>
     <setting label="30011" type="bool" id="timerlistcleanup" default="false"/>
-
   </category>
</settings>

Also pushed it to the fix to the master branch..

Code:
0.1.12 add: support to specify the folder for storing recordings
       fix: fix crash due to invalid settings.xml

ok, the fix works well

Sorry for my english, I use google translate.
Reply
Hi jdembski,

a note, under "add-on information", there is the menu item "change log" which is unfortunately empty.
If that is "chanegelog.txt" copied into the addon directory, it will be displayed under this menu point. Then everybody can see what changes.

Sorry for my english, I use google translate.
Reply
Is it possible to take the bouquets from the satbox to the Plugin in xbmc?
Image[Image: widget][Image: widget]
Reply
(2012-04-10, 21:41)sb206 Wrote: Is it possible to take the bouquets from the satbox to the Plugin in xbmc?

normally when you click on "TV channels" repeatedly to switch between the bouquets

Sorry for my english, I use google translate.
Reply
Now i See it. Thanks trans
Image[Image: widget][Image: widget]
Reply
Is there any plan to add more support to teletext? Now if i enable teletext sub, the xbmc skin it's in the way.
Reply
I'm currently (version 0.1.12) the vuplus-addon designed for installation "Install from zip file" for:

Windows http://www.mediafire.com/download.php?1c5w3yo9r2gbirb

Linux http://www.mediafire.com/download.php?z9i1pt1r525js93

Sorry for my english, I use google translate.
Reply
I'm on 0.1.12, and really happy with this addon! Thanks a lot jdembski, and all you others who has helped!

But I have noticed one issue; changing bouquets within the addon is not working all the time. That is, after the initial set up, channel scan, and EPG scan, everything is working fine. But after restarting XBMC, the switching between bouquets is not working anymore. To get it working again, I have to reset the EPG database. Then it is working fine until next restart of XBMC. Anyone else have this issue?

I'm running the windows version of the addon within Op den Kamp's pvr build 73, and Aeon MQ3 skin.

Reply
(2012-04-12, 14:02)Roocket Wrote: Is there any plan to add more support to teletext? Now if i enable teletext sub, the xbmc skin it's in the way.

You should address this to the maintainer of the PVR branch - this is nothing the addon can influence...
VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
Reply
(2012-04-12, 14:02)Roocket Wrote: Is there any plan to add more support to teletext? Now if i enable teletext sub, the xbmc skin it's in the way.

Just use shortcut "v" to enable teletext, then the skin wont bother you!
Reply
(2012-04-12, 20:55)trans Wrote: I'm currently (version 0.1.12) the vuplus-addon designed for installation "Install from zip file" for:

Windows http://www.mediafire.com/download.php?1c5w3yo9r2gbirb

Linux http://www.mediafire.com/download.php?z9i1pt1r525js93

Hello,

I installed my xbmc from
Quote:http://packages.pulse-eight.net/UbuntuInstall
then I downloaded the zip file to add the addon, it´s shown as installed add-on pvr-clients. I can configure it (IP, Port) but I get an error after restarting xbmc "Add-on could not be loaded. An unknown error has occurred"

In the Debug Log I see:
DEBUG: ADDON: cpluff: 'Suspicious plug-in descriptor content in /home/xbmcpc/.xbmc/addons/pvr.vuplus-0.1.10/addon.xml, line $
INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/xbmc/addons: No such file or directory'

DEBUG: Thread EPG updater 140055453103872 terminating
DEBUG: Thread PVR add-on updater start, auto delete: 0
DEBUG: PVR - ResetProperties - creating PVR add-on instance 'VU+ Client'
DEBUG: InitialiseClient - initialising add-on 'VU+ Client'
DEBUG: ADDON: Dll Initializing - VU+ Client
DEBUG: SECTION:LoadDLL(/home/xbmcpc/.xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr)
DEBUG: Loading: /home/xbmcpc/.xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr
ERROR: Unable to load /home/xbmcpc/.xbmc/addons/pvr.vuplus/XBMC_vuplus.pvr, reason: /home/xbmcpc/.xbmc/addons/pvr.vuplus/XBMC_$
DEBUG: PVR - ResetProperties - creating PVR add-on instance 'VU+ Client'
INFO: Called Add-on status handler for '4' of clientName:VU+ Client, clientID:pvr.vuplus (same Thread=no)
ERROR: PVR - InitialiseClient - can't initialise add-on 'VU+ Client'
DEBUG: Thread CAddonStatusHandler:pvr.vuplus start, auto delete: 1


So I think I have to compile the add-on.
If I open a terminal session do I have to change into a specific directory?
(I´m in the home directory of the current user right?)

Greetings


Its running :-)
I deleded XBMC and reinstalled it.
Great add-on thank you very much.
Reply
  •   
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  • 76
  •   
 
Thread Rating:
  • 17 Vote(s) - 4.47 Average



Logout Mark Read Team Forum Stats Members Help
[WIP] PVR Client Addon for XBMC for EPG and full control of Dreambox and DBox24.4717