MP video quality in XBMC ??
#1
Watching TV through XBMC (windows) seems to be lower quality than through mediaportal, most noticeably it feels like it has a lower frame rate (like when a camera pans it is much smoother and clearer in MP. i dunno if thats frame rate, but thats the visual effect). i also get some aliasing effect with lots of motion.
Its kind of annoying, and im wondering if thats just how it is at the moment for XBMC, or is there an earlier version that is more popular amongst XBMC users and has good quality and smoothness ??
i.e. i want the quality of mediaportal in XBMC !

Cheers.

Currently using -

latest mediaportal frontend

MP TVserver 1.2.3

25-03-2012: XBMC v11.0 Eden PVR

Download v1.2.2.112 (precompiled dll/exe): MediaPortal TVServer XBMC Server plugin (binaries) for MP 1.2.2

TSreader. but ffmpeg is the same.
Reply
#2
I face the same issue.

As far as I understand (I am a XBMC noob), this is due to fact that XBMC does not make use of directshow filters. So, you are not able to use e.g. LAV filters, which results in an excellent picture quality in my case.

There is a directshow version in development but so far, it doesn't support PVR Sad

G.
Reply
#3
Try the binaries from http://xbmc.opdenkamp.eu/

The build you are running ran at 9fps at times for me. The binary above works great.
Reply
#4
MUCH better. Thanks for the tip :-)
Reply
#5
ah its still the same for me, and it doesnt have the tsreader addon( no fast channel change). thanks though.

Will changing the version of MP or the TVplugin have any effect on this ??

the most annoying visual artifact im getting is this cross hatching effect when anything moves.
Reply
#6
Did you enable DXVA2 hardware acceleration?
Reply
#7
(2012-04-27, 12:12)thedoggy Wrote: ah its still the same for me, and it doesnt have the tsreader addon( no fast channel change). thanks though.

Will changing the version of MP or the TVplugin have any effect on this ??

the most annoying visual artifact im getting is this cross hatching effect when anything moves.

After reading your post about the fast channel change I decided to try margo's binaries again.
I had a spare hard drive so i did a fresh windows install. This time I installed the "XBMC Eden (11.0)" build, I had previously installed "XBMC master (pre Frodo 12.x)".

I have DXVA2, "Adjust display refresh rate to match video", and "Sync playback to display" turned on.
I have my desktop refresh rate to 59hz which for AMD means 59.94hz.

Playback is now flawless and channel changes are VERY fast. I still don't have fast channel switching enabled because I occasionally get the wrong position in the timeshift buffer after I change channels.

Reply
#8
i did enable DXVA2 HA, didnt help.


Boke, did you install the 25-03-2012 update of xbmc 11.0 ?

what tvserver version, and tvserver xbmc plugin version do you use ?

Cheers guys.
Reply
#9
(2012-04-28, 05:18)thedoggy Wrote: i did enable DXVA2 HA, didnt help.


Boke, did you install the 25-03-2012 update of xbmc 11.0 ?

what tvserver version, and tvserver xbmc plugin version do you use ?

Cheers guys.

Yes.

I used the server from the official MediaPortal 1.2.3 release.
tvserver xbmc plugin version is v1.2.2.112 .

Reply
#10
Hi,

I recently setup MediaPortal 1.2.3 TV Server on Windows 7 and connected it to the openelec XBMC mahine using the plugin and have been very dissapointed with the picture quality.

Please can someone point out either where I have gone wrong or what steps I need to take to improve the quality of the picture.

Thanks
Reply
#11
Hi,

completely agree, like many others this year, I come from Mediaportal and I found a poor video quality. The direct show version is a part of the solution (With the fabulous LAV codecs) but... without TV. I found also that the xbmc development is hard to understand, there is 2 audio patchs, the better seem to be not official, same for TV and most important for me I don't know if the direct show version have a future or not. Xbmc is on the way to be the better solution but there is some work to do to allow user decoders or a better internal quality.

Technick
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
MP video quality in XBMC ??00