Thread Closed
  •  Previous
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 72
  • Next 
 
Thread Rating:
  • 6 Vote(s) - 4.5 Average
[RELEASE] XBMC Subtitles - Addon Script
(2012-04-28, 19:39)necronomicon Wrote:
(2012-04-28, 18:29)amet Wrote: read the first page of this thread

I've just edited my post, adding the required full debug log: http://forum.xbmc.org/showthread.php?tid=126495&pid=1089270#pid1089270

since I cant see, does "smb://xbmc:[email protected]_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

try with this fix -> https://github.com/amet/script.xbmc.subt...a8262aba66
(2012-04-28, 19:55)amet Wrote:
(2012-04-28, 19:39)necronomicon Wrote:
(2012-04-28, 18:29)amet Wrote: read the first page of this thread

I've just edited my post, adding the required full debug log: http://forum.xbmc.org/showthread.php?tid=126495&pid=1089270#pid1089270

since I cant see, does "smb://xbmc:[email protected]_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.
(2012-04-28, 19:57)necronomicon Wrote:
(2012-04-28, 19:55)amet Wrote:
(2012-04-28, 19:39)necronomicon Wrote: I've just edited my post, adding the required full debug log: http://forum.xbmc.org/showthread.php?tid=126495&pid=1089270#pid1089270

since I cant see, does "smb://xbmc:[email protected]_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66
(2012-04-28, 20:07)amet Wrote:
(2012-04-28, 19:57)necronomicon Wrote:
(2012-04-28, 19:55)amet Wrote: since I cant see, does "smb://xbmc:[email protected]_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Yep, 100% ASCII. Let me try this and get back to you.
(2012-04-28, 20:09)necronomicon Wrote:
(2012-04-28, 20:07)amet Wrote:
(2012-04-28, 19:57)necronomicon Wrote: Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Yep, 100% ASCII. Let me try this and get back to you.

Ok, so this seems to be working in some cases, but not in all of them. Subtitles that are unzipped in the temp folder usually look like "New Girl 1x20 - Normal (Español (España)).srt" and are not successfully processed (so you are definitely narrowing down the encoding issue)
I'm using mainly two providers: OpenSubtitles.org and Subdivx (for Spanish subtitles both of them), and I've noticed that some filenames avoid non-ASCII characters and others don't.

Again, it seems you are going down the right path with the fix above... let me know if you want me to test any other modification.
(2012-04-28, 20:27)necronomicon Wrote:
(2012-04-28, 20:09)necronomicon Wrote:
(2012-04-28, 20:07)amet Wrote: only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Yep, 100% ASCII. Let me try this and get back to you.

Ok, so this seems to be working in some cases, but not in all of them. Subtitles that are unzipped in the temp folder usually look like "New Girl 1x20 - Normal (Español (España)).srt" and are not successfully processed (so you are definitely narrowing down the encoding issue)
I'm using mainly two providers: OpenSubtitles.org and Subdivx (for Spanish subtitles both of them), and I've noticed that some filenames avoid non-ASCII characters and others don't.

Again, it seems you are going down the right path with the fix above... let me know if you want me to test any other modification.

Would be interesting to see tha failure while using those files. It would help narrow down where it fails and fix it
(2012-04-28, 20:30)amet Wrote:
(2012-04-28, 20:27)necronomicon Wrote:
(2012-04-28, 20:09)necronomicon Wrote: Yep, 100% ASCII. Let me try this and get back to you.

Ok, so this seems to be working in some cases, but not in all of them. Subtitles that are unzipped in the temp folder usually look like "New Girl 1x20 - Normal (Español (España)).srt" and are not successfully processed (so you are definitely narrowing down the encoding issue)
I'm using mainly two providers: OpenSubtitles.org and Subdivx (for Spanish subtitles both of them), and I've noticed that some filenames avoid non-ASCII characters and others don't.

Again, it seems you are going down the right path with the fix above... let me know if you want me to test any other modification.

Would be interesting to see tha failure while using those files. It would help narrow down where it fails and fix it

Ok, let me try to see what I can do. The problem now is that I was able to download all of the missing subtitles using either "opensubtitles" or "subdivx" (alternating between both providers depending on whether one or the other was failing with the encoding issue...), so now I can't remember which one was giving me this headache Tongue

Let me get back to you as soon as I can catch an example.

[quickedit]
Something I did notice after applying your fix was that all of the sudden some of the subtitles that I had downloaded but failed to process where successfully processed without having to redownload.
[/quickedit]
(2012-04-28, 20:07)amet Wrote:
(2012-04-28, 19:57)necronomicon Wrote:
(2012-04-28, 19:55)amet Wrote: since I cant see, does "smb://xbmc:[email protected]_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Thank amet,
this fix resolve my problem with betaseries

@+
OS: LibreElec-7.95.beta6 kszaq - KODI Krypton-17.0 - TvHeadend 4.1.2415
SKIN: AeonMQ7 by MarcosQUI
AndroidBox: Bqeel M9C max
DVB-T2: August USB Freeview TV Receiver
NAS: D-Link DNS-325

(2012-04-28, 21:08)Rififi77 Wrote:
(2012-04-28, 20:07)amet Wrote:
(2012-04-28, 19:57)necronomicon Wrote: Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Thank amet,
this fix resolve my problem with betaseries

@+

good to know, thx for letting us know
(2012-04-28, 18:50)amet Wrote:
(2012-04-28, 18:48)ailingcoot Wrote:
(2012-04-28, 18:22)amet Wrote: [quote='Rififi77' pid='1089232' dateline='1335628027']
[quote='amet' pid='1089128' dateline='1335618879']

hey amet, for the shooters service connection problem(just freeze at that step.) http://pastebin.com/qaemTBxs
Anyway to fix that?

sure, but you need to read the first post of this thread again.. we need FULL debug log... its not optional
It is the complete log for the subtitle service since XBMC froze at that step and I had to force it to stop by the win system manager. Maybe you are talking about the previous computer hardware/software information? wait a minute , i would paste that now.


UPDATE: It is solved now, might due to the server busy or something. thanks though.
@Amet, latest translate strings for Portuguese (Brazil), please download here:

http://dl.dropbox.com/u/25170804/Subtitles/strings.xml

Thanks,

Wanilton
MediaBrazil forum - Youtube Channel
Windows 10 - Kodi 18 Leia - Aeon MQ8 - 0.8.0 - Aeon MQ Team
Wanilton Website - MarcosQui Website
(2012-04-28, 21:13)amet Wrote:
(2012-04-28, 21:08)Rififi77 Wrote:
(2012-04-28, 20:07)amet Wrote: only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Thank amet,
this fix resolve my problem with betaseries

@+

good to know, thx for letting us know

amet,

After running some tests with other TV shows, I can confirm the problem still persists in some scenarios. I was able to get the "zipsubs.zip" (provider: OpenSubtitles) and "subdivx.rar" (provider: SubDivx) for subtitles that are failing to be processed by the script (it's downloaded to the "sub_tmp" folder and extracted correctly, but the script fails to move it to the target folder together with the TV show video file)

The SRTs inside are "The Mentalist 4x21 - Ruby Slippers (Español (España)).srt" for OpenSubtitles and "The Mentalist 4x21 LOL Espa¤ol.srt" for SubDivx, but I think getting you the ZIP and RAR files will be more accurate since I'm not sure the characters will be conveyed to you correctly when posted here. What is the recommended way for sharing these sort of files in the forum?

Thanks.
(2012-04-29, 05:31)necronomicon Wrote:
(2012-04-28, 21:13)amet Wrote:
(2012-04-28, 21:08)Rififi77 Wrote: Thank amet,
this fix resolve my problem with betaseries

@+

good to know, thx for letting us know

amet,

After running some tests with other TV shows, I can confirm the problem still persists in some scenarios. I was able to get the "zipsubs.zip" (provider: OpenSubtitles) and "subdivx.rar" (provider: SubDivx) for subtitles that are failing to be processed by the script (it's downloaded to the "sub_tmp" folder and extracted correctly, but the script fails to move it to the target folder together with the TV show video file)

The SRTs inside are "The Mentalist 4x21 - Ruby Slippers (Español (España)).srt" for OpenSubtitles and "The Mentalist 4x21 LOL Espa¤ol.srt" for SubDivx, but I think getting you the ZIP and RAR files will be more accurate since I'm not sure the characters will be conveyed to you correctly when posted here. What is the recommended way for sharing these sort of files in the forum?

Thanks.

You have pm with my e-mail address, please send it there and I will look into it

Thx
Hi guys,

i need some help. Since I upgraded to Eden I'm no longer able to download subtitles.

Here's my log: http://pastebin.com/mvypur5A

Here's what's weird:
the log states: failed to get url 'http://api.bierdopje.com/369C2ED4261DE9C3/GetAllSubsFor/9203/5/22/nl' but if I copy/paste that url in my browser I get a nice response with a sweet xml like page containing several subtitles for the episode I want.

Hopfully someone here can give me a clue as to what's going on... Life is so much sweeter with a working subtitle addon.

Kind regards,

MicaH
(2012-05-01, 23:43)MicaH_Z Wrote: Hi guys,

i need some help. Since I upgraded to Eden I'm no longer able to download subtitles.

Here's my log: http://pastebin.com/mvypur5A

Here's what's weird:
the log states: failed to get url 'http://api.bierdopje.com/369C2ED4261DE9C3/GetAllSubsFor/9203/5/22/nl' but if I copy/paste that url in my browser I get a nice response with a sweet xml like page containing several subtitles for the episode I want.

Hopfully someone here can give me a clue as to what's going on... Life is so much sweeter with a working subtitle addon.

Kind regards,

MicaH

looks like xbmc can't connect to the internet
check if the proxy setting in xbmc isn't accidentally enabled.

Settings > Network > Internet Access > Use HTTP proxy...
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
  •  Previous
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 72
  • Next 
  Thread Closed



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XBMC Subtitles - Addon Script4.56