•  Previous
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 46
  • Next 
 
Thread Rating:
  • 11 Vote(s) - 4.91 Average
XBMC on Raspberry Pi - Wonder if this will work out? (Historical Discussion Thread)
Apologies if this is posted in the wrong place but I have been lucky enough to receive my board ahead of the estimated delivery date.

In order for me to help out the devs and provide some useful information, please advise me of the best way to test XBMC on RPi? There seems to be a few options on distributions - OpenELEC (have to compile) or Raspbmc (is it available?)

At the moment I have downloaded an image from rpi developers site - https://rpi-developers.com/projects/xbmc/

It's a bit unstable as expected so short of donating my board to a dev, how can I help?

Thanks.
----------------------------------------------------------------------------------------------------------
=)
----------------------------------------------------------------------------------------------------------
Reply
(2012-05-08, 16:27)jamie1984 Wrote: Apologies if this is posted in the wrong place but I have been lucky enough to receive my board ahead of the estimated delivery date.

In order for me to help out the devs and provide some useful information, please advise me of the best way to test XBMC on RPi? There seems to be a few options on distributions - OpenELEC (have to compile) or Raspbmc (is it available?)

At the moment I have downloaded an image from rpi developers site - https://rpi-developers.com/projects/xbmc/

It's a bit unstable as expected so short of donating my board to a dev, how can I help?

Thanks.


Tried the image you mentioned but not really stable. You could give openelec a try. Building openelec is quite easy as well.
Reply
If you don"t mind, can you answer the the following questions on your XBMC experience:


1) How is the UI ? Is it responsive ? How is CPU load going back and forth between menu ? To see cpu usage, you need to enable debugging under system settings.

2) How is media playback ? Flash ? Apple Trailers ? 1080p ? Any drops in frames ? Cpu usage ? You can see this information by pressing "o" during playback.

3) Have you tried any plugins ? Icefilms, NaviX, Youtube, etc

4) How is the video,music library feature on it ? Scanning content ? Going through different views ?



Here is couple of advanced settings that I use to make my Apple TV 2 XBMC experience a bit better:

Code:
<advancedsettings>
  <network>
    <cachemembuffersize>30242880</cachemembuffersize>
  </network>
  <fanartheight>560</fanartheight>
  <thumbsize>256</thumbsize>
  <gui>
    <algorithmdirtyregions>3</algorithmdirtyregions>
    <nofliptimeout>0</nofliptimeout>
  </gui>
  <bginfoloadermaxthreads>2</bginfoloadermaxthreads>
</advancedsettings>
The normal XBMC log IS NOT a debug log, to enable debug logging you must toggle it on under XBMC Settings - System or in advancedsettings.xml. Use XBMC Debug Log Addon to retrieve it.
Reply
1) Bit slow. CPU load is over 90% on home screen at idle and interesting drops to 40% at file manager as reported by top

2) H264 video files plays very nicely up to 720p. For 1080p h264 videos it pauses every 5 seconds or so. The cpu load when playing H264 720p video is about 60% and it goes over 90% when playing 1080p video. The fast forward and fast backwards does not yet work. Skip works fine but you got some grey screen initially when you do the skip.

3) Plugins are really slow as I mentioned which is likely due to high CPU load whilst idle. It took about 10 seconds for the plugin to execute

4) Have not tried.

Will try the advantaged setting tonight.

(2012-05-09, 15:20)CrashX Wrote: If you don"t mind, can you answer the the following questions on your XBMC experience:


1) How is the UI ? Is it responsive ? How is CPU load going back and forth between menu ? To see cpu usage, you need to enable debugging under system settings.

2) How is media playback ? Flash ? Apple Trailers ? 1080p ? Any drops in frames ? Cpu usage ? You can see this information by pressing "o" during playback.

3) Have you tried any plugins ? Icefilms, NaviX, Youtube, etc

4) How is the video,music library feature on it ? Scanning content ? Going through different views ?



Here is couple of advanced settings that I use to make my Apple TV 2 XBMC experience a bit better:

Code:
<advancedsettings>
  <network>
    <cachemembuffersize>30242880</cachemembuffersize>
  </network>
  <fanartheight>560</fanartheight>
  <thumbsize>256</thumbsize>
  <gui>
    <algorithmdirtyregions>3</algorithmdirtyregions>
    <nofliptimeout>0</nofliptimeout>
  </gui>
  <bginfoloadermaxthreads>2</bginfoloadermaxthreads>
</advancedsettings>

Reply
(2012-05-09, 16:54)s7mx1 Wrote: 1) Bit slow. CPU load is over 90% on home screen at idle and interesting drops to 40% at file manager as reported by top

2) H264 video files plays very nicely up to 720p. For 1080p h264 videos it pauses every 5 seconds or so. The cpu load when playing H264 720p video is about 60% and it goes over 90% when playing 1080p video. The fast forward and fast backwards does not yet work. Skip works fine but you got some grey screen initially when you do the skip.

3) Plugins are really slow as I mentioned which is likely due to high CPU load whilst idle. It took about 10 seconds for the plugin to execute

4) Have not tried.

Will try the advantaged setting tonight.

(2012-05-09, 15:20)CrashX Wrote: If you don"t mind, can you answer the the following questions on your XBMC experience:


1) How is the UI ? Is it responsive ? How is CPU load going back and forth between menu ? To see cpu usage, you need to enable debugging under system settings.

2) How is media playback ? Flash ? Apple Trailers ? 1080p ? Any drops in frames ? Cpu usage ? You can see this information by pressing "o" during playback.

3) Have you tried any plugins ? Icefilms, NaviX, Youtube, etc

4) How is the video,music library feature on it ? Scanning content ? Going through different views ?



Here is couple of advanced settings that I use to make my Apple TV 2 XBMC experience a bit better:

Code:
<advancedsettings>
  <network>
    <cachemembuffersize>30242880</cachemembuffersize>
  </network>
  <fanartheight>560</fanartheight>
  <thumbsize>256</thumbsize>
  <gui>
    <algorithmdirtyregions>3</algorithmdirtyregions>
    <nofliptimeout>0</nofliptimeout>
  </gui>
  <bginfoloadermaxthreads>2</bginfoloadermaxthreads>
</advancedsettings>

What skin are you using?
I have heard using the new confluence-lite skin improves the responsiveness. Can u pls try that as well.
What about any other ultra light skins.

Reply
I would first try <algorithmdirtyregions>1</algorithmdirtyregions> on the Pi. The ATV2 had some issues with modes 1 and 2, so three is used as a safe bet, but isn't the best mode (reduces CPU when the screen is idle, rather than reducing CPU while GPU is active, etc).
Reply
(2012-05-09, 18:06)Ned Scott Wrote: I would first try <algorithmdirtyregions>1</algorithmdirtyregions> on the Pi. The ATV2 had some issues with modes 1 and 2, so three is used as a safe bet, but isn't the best mode (reduces CPU when the screen is idle, rather than reducing CPU while GPU is active, etc).


Tried every possible mode according to wiki but same result: flicking black screen.
Using openelec with minimum software/services enabled: no samba, no lirc/remote etc. The skin used by openelec is already a light version. Any other light skin I can use?

(2012-05-09, 17:05)humla Wrote:
(2012-05-09, 16:54)s7mx1 Wrote: 1) Bit slow. CPU load is over 90% on home screen at idle and interesting drops to 40% at file manager as reported by top

2) H264 video files plays very nicely up to 720p. For 1080p h264 videos it pauses every 5 seconds or so. The cpu load when playing H264 720p video is about 60% and it goes over 90% when playing 1080p video. The fast forward and fast backwards does not yet work. Skip works fine but you got some grey screen initially when you do the skip.

3) Plugins are really slow as I mentioned which is likely due to high CPU load whilst idle. It took about 10 seconds for the plugin to execute

4) Have not tried.

Will try the advantaged setting tonight.

(2012-05-09, 15:20)CrashX Wrote: If you don"t mind, can you answer the the following questions on your XBMC experience:


1) How is the UI ? Is it responsive ? How is CPU load going back and forth between menu ? To see cpu usage, you need to enable debugging under system settings.

2) How is media playback ? Flash ? Apple Trailers ? 1080p ? Any drops in frames ? Cpu usage ? You can see this information by pressing "o" during playback.

3) Have you tried any plugins ? Icefilms, NaviX, Youtube, etc

4) How is the video,music library feature on it ? Scanning content ? Going through different views ?



Here is couple of advanced settings that I use to make my Apple TV 2 XBMC experience a bit better:

Code:
<advancedsettings>
  <network>
    <cachemembuffersize>30242880</cachemembuffersize>
  </network>
  <fanartheight>560</fanartheight>
  <thumbsize>256</thumbsize>
  <gui>
    <algorithmdirtyregions>3</algorithmdirtyregions>
    <nofliptimeout>0</nofliptimeout>
  </gui>
  <bginfoloadermaxthreads>2</bginfoloadermaxthreads>
</advancedsettings>

What skin are you using?
I have heard using the new confluence-lite skin improves the responsiveness. Can u pls try that as well.
What about any other ultra light skins.

Reply
Welo is a really light weight skin, it runs faster than most skins on my old laptop so maybe try that?
Reply
maybe try PM3.
Reply
Tried your suggestion for dirty region settings and it seems to made a difference. Now xbmc on raspberry pi idle at around 25% CPU usage. GUI seems bit responsive but still not smooth. Going through sub menus still take a bit time.

Addon still takes ages to load: iPlayer took 17 seconds.

Maybe python should stay in memory all the time to speed up the execution of the addon.


(2012-05-09, 15:20)CrashX Wrote: If you don"t mind, can you answer the the following questions on your XBMC experience:


1) How is the UI ? Is it responsive ? How is CPU load going back and forth between menu ? To see cpu usage, you need to enable debugging under system settings.

2) How is media playback ? Flash ? Apple Trailers ? 1080p ? Any drops in frames ? Cpu usage ? You can see this information by pressing "o" during playback.

3) Have you tried any plugins ? Icefilms, NaviX, Youtube, etc

4) How is the video,music library feature on it ? Scanning content ? Going through different views ?



Here is couple of advanced settings that I use to make my Apple TV 2 XBMC experience a bit better:

Code:
<advancedsettings>
  <network>
    <cachemembuffersize>30242880</cachemembuffersize>
  </network>
  <fanartheight>560</fanartheight>
  <thumbsize>256</thumbsize>
  <gui>
    <algorithmdirtyregions>3</algorithmdirtyregions>
    <nofliptimeout>0</nofliptimeout>
  </gui>
  <bginfoloadermaxthreads>2</bginfoloadermaxthreads>
</advancedsettings>

Reply
(2012-05-09, 20:48)humla Wrote: maybe try PM3.

Tried PM3 as well as welo and no noticeable difference.
Reply
(2012-05-09, 16:54)s7mx1 Wrote: 1) Bit slow. CPU load is over 90% on home screen at idle and interesting drops to 40% at file manager as reported by top

2) H264 video files plays very nicely up to 720p. For 1080p h264 videos it pauses every 5 seconds or so. The cpu load when playing H264 720p video is about 60% and it goes over 90% when playing 1080p video. The fast forward and fast backwards does not yet work. Skip works fine but you got some grey screen initially when you do the skip.

3) Plugins are really slow as I mentioned which is likely due to high CPU load whilst idle. It took about 10 seconds for the plugin to execute

4) Have not tried.

Will try the advantaged setting tonight.
I can pretty much agree with this and has been my experience as well on all points. I have managed to get the ui a little better by basically removng all the cover art, fanart, background video and viz but it still lags a little on scrolling. It could be because I'm only using a class 4 SD card but I purchased a class 6 one the other day only to find out that it doesn't work ( quite a big list here http://elinux.org/RPi_VerifiedPeripheral...m_SD_Cards as a found out too late )
Another thing needed is to turn off the background generation of video thumbnails and meta data in video settings it really slows it down too.
Also maybe a network library might be of advantage here but I've not bothered to set that up
Also TheUni has been working on a better internal thumbnail loader for jpg images that may help as well in the long run for loading the covers
Reply
Remember, it took iOS the better part of 4-6 months to pickup speed, this platform I expect will be similar.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
(2012-05-09, 23:54)Jezz_X Wrote:
(2012-05-09, 16:54)s7mx1 Wrote: 1) Bit slow. CPU load is over 90% on home screen at idle and interesting drops to 40% at file manager as reported by top

2) H264 video files plays very nicely up to 720p. For 1080p h264 videos it pauses every 5 seconds or so. The cpu load when playing H264 720p video is about 60% and it goes over 90% when playing 1080p video. The fast forward and fast backwards does not yet work. Skip works fine but you got some grey screen initially when you do the skip.

3) Plugins are really slow as I mentioned which is likely due to high CPU load whilst idle. It took about 10 seconds for the plugin to execute

4) Have not tried.

Will try the advantaged setting tonight.
I can pretty much agree with this and has been my experience as well on all points. I have managed to get the ui a little better by basically removng all the cover art, fanart, background video and viz but it still lags a little on scrolling. It could be because I'm only using a class 4 SD card but I purchased a class 6 one the other day only to find out that it doesn't work ( quite a big list here http://elinux.org/RPi_VerifiedPeripheral...m_SD_Cards as a found out too late )
Another thing needed is to turn off the background generation of video thumbnails and meta data in video settings it really slows it down too.
Also maybe a network library might be of advantage here but I've not bothered to set that up
Also TheUni has been working on a better internal thumbnail loader for jpg images that may help as well in the long run for loading the covers


Maybe its time to create a micro skin instead of lite. A faster SD card may or may not help and to me it more looks like cpu is the bottleneck.


Personally I am not too bothered about smooth skin. The biggest show stopper is the (video) addon. Python is running very slow (at least on openelec). I think instead of calling python every time when an addon lauches it should be loaded into memory at boot and only load additional modules if needed.

(2012-05-10, 00:05)davilla Wrote: Remember, it took iOS the better part of 4-6 months to pickup speed, this platform I expect will be similar.

Thanks for the info. Will wait patiently.

One thing I cannot get answer anywhere is will raspberry pi's GPU requires 128MB memory with xbmc running? From my experience I can only get xbmc work with 128MB memory allocated to GPU.
Reply
(2012-05-10, 00:05)davilla Wrote: Remember, it took iOS the better part of 4-6 months to pickup speed, this platform I expect will be similar.
Oh I'm sure it probably will get better Big Grin I'm just saying what I as basically an end user experience now so other people don't go rushing into it thinking its all roses and then bitch because its not (currently)
Reply
  •  Previous
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 46
  • Next 



XBMC on Raspberry Pi - Wonder if this will work out? (Historical Discussion Thread)4.9111