•  Previous
  • 1
  • 67
  • 68
  • 69(current)
  • 70
  • 71
  • 120
  • Next 
 
Thread Rating:
  • 11 Vote(s) - 4.64 Average
[RELEASE] Pneumatic
(2012-04-27, 14:41)albwhitehead Wrote: Awesome plugin! many thanks.

So am I right in thinking if I had the first and last rar of each nzb I've added to my library as a stream already downloaded, I could possibly cut out the wait time and items would play immediately as if they were locally stored? I dont mind waiting the 10-30 seconds it takes for them to start playing, just thinking it would be sweet if that would work. Smile

Or you could get a faster connection ;D ... It sounds like a cool idea but would require quite some work. First you would have to get just the first and last
stored together with the strm and then when playing, copy these to sabs incomplete and get the rest. You have a good excuse to learn python now Big Grin
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
I might just do that.
Reply
i simply cannot get this to work;
ive downloaded pneumatic, and the nzbmatrix addon; installed an configured both. i can browse nzbmatrix, and pneumatic can speak with sabnzbd just fine. sabnzbd is on a another pc, in my local network.

when i select a movie to watch in nzbmatrix menu, on xbmc, it says; "request to sabnzbd succeeded, waiting for nzb download"
it never starts playing the movie. the time just keeps going and going; i did notice that eventually sabnzbd (or is it pneumatic) throttles the download speed to 0

my remote sabnzbd incomplete folder is mounted automatically in a folder locally at "/storage/sabnzbd-remote-temp" with autostart.sh (mount -t nfs 192.168.2.104:/export/nzb_temp_data /storage/sabnzbd-remote-temp -o rw,timeo=600,rsize=32768,wsize=32768,async,intr,nolock,soft,noatime,bg)

the old nzbs.org version 0.20 works just fine ! but pneumatic+nzbmatrix addon seems to not be aware of the remote incomplete files Huh

what have i done wrong here ?
Reply
What about appending /incomplete to your path? Logs are good...
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
(2012-04-27, 21:33)Popeye Wrote: What about appending /incomplete to your path? Logs are good...

the xbmc.log file tells me nothing helpful at all;
is there another log i should be looking at ?
Reply
(2012-04-28, 01:17)ericab Wrote:
(2012-04-27, 21:33)Popeye Wrote: What about appending /incomplete to your path? Logs are good...

the xbmc.log file tells me nothing helpful at all;
is there another log i should be looking at ?

Permissions are ok? You dont have any automatic renaming of nzb's? In some way pneumatic fails to read the incomplete folder and find the rar's. Have you manually checked the downloads are show up in incomplete and their naming is the exact same as the nzb?

Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
There seems to be a problem with the Incomplete folder on OSX. Parsing the directory breaks if there is a .DS_Store file. Can you exclude that file?

Code:
11:58:36 T:2959249408   ERROR: Traceback (most recent call last):
                                              File "/Users/atmorell/Library/Application Support/XBMC/addons/plugin.program.pneumatic/default.py", line 791, in <module>
                                                incomplete()
                                              File "/Users/atmorell/Library/Application Support/XBMC/addons/plugin.program.pneumatic/default.py", line 638, in incomplete
                                                utils.dir_exists(os.path.join(INCOMPLETE_FOLDER, row[0]), None)
                                              File "/Users/atmorell/Library/Application Support/XBMC/addons/plugin.program.pneumatic/utils.py", line 146, in dir_exists
                                                dir_list = os.listdir(folder)
                                            OSError: (20, 'Not a directory', '/Users/atmorell/Downloads/incomplete/.DS_Store')

Maybe just do something like
try:
dir_list = os.listdir(folder)
except OSError:
Print "Not a dir, so going to next item"
Reply
hi Popeye;

in sabnzbd on the remote box; ive got these renaming options checked.

Enable folder rename
Replace Spaces in Foldername
Replace Illegal Characters in Folder Names

other then that there isn't any other renaming going on...

do i need to create a category for Pneumatic maybe and try to disable post-processing ?
Reply
(2012-05-01, 03:49)ericab Wrote: hi Popeye;

in sabnzbd on the remote box; ive got these renaming options checked.

Enable folder rename
Replace Spaces in Foldername
Replace Illegal Characters in Folder Names

other then that there isn't any other renaming going on...

do i need to create a category for Pneumatic maybe and try to disable post-processing ?

Can you try disabling the folder renaming and see if that helps? Post processing has nothing to do with the problem you have...
(2012-04-30, 12:03)atmorell Wrote: There seems to be a problem with the Incomplete folder on OSX. Parsing the directory breaks if there is a .DS_Store file. Can you exclude that file?

Code:
11:58:36 T:2959249408   ERROR: Traceback (most recent call last):
                                              File "/Users/atmorell/Library/Application Support/XBMC/addons/plugin.program.pneumatic/default.py", line 791, in <module>
                                                incomplete()
                                              File "/Users/atmorell/Library/Application Support/XBMC/addons/plugin.program.pneumatic/default.py", line 638, in incomplete
                                                utils.dir_exists(os.path.join(INCOMPLETE_FOLDER, row[0]), None)
                                              File "/Users/atmorell/Library/Application Support/XBMC/addons/plugin.program.pneumatic/utils.py", line 146, in dir_exists
                                                dir_list = os.listdir(folder)
                                            OSError: (20, 'Not a directory', '/Users/atmorell/Downloads/incomplete/.DS_Store')

Maybe just do something like
try:
dir_list = os.listdir(folder)
except OSError:
Print "Not a dir, so going to next item"

Thanks! I'll add it to the next release .
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
I've been out of the loop for a while. I thought NZBS.org was shutting down, when instead it just dropped the old site and then beta.nzbs.org became nzbs.org. I've added nzbs.org back into Newznab, but when clicking on any category it just gives me an error about malformed result. Have I missed something in the past 20-30 pages of posts?
Read this before using these builds.
Changelog
Reply
Has it changed name? I still use beta...
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
From what I tried tonight, beta.nzbs.org just takes you to nzbs.org.
Read this before using these builds.
Changelog
Reply
(2012-05-04, 03:33)kricker Wrote: I've been out of the loop for a while. I thought NZBS.org was shutting down, when instead it just dropped the old site and then beta.nzbs.org became nzbs.org. I've added nzbs.org back into Newznab, but when clicking on any category it just gives me an error about malformed result. Have I missed something in the past 20-30 pages of posts?

Since it now looks like the just use the newznab engine, I would like to get an invite from someone. p.steenbergen(at)j1nx.nl Angel
Reply
Popeys;

using the newznab plugin w pneumatic, i can see that sabnzbd is not downloading the first and last rar, but instead, downloading sequentially like normal....
this must be why nothing plays ! but why is this ?


**edit

after manually moving the last nzb to the top of the queue after the first 5 rars downloaded, it still doesnt play the video.
the only confirmation i have is in the upper corner saying "Pneumatic: Request to SABnzbd succeded"


** edit 2
again; the *original* NZB's addon works; and its pointing to the same location, and using sab (with the same sab options) on the same computer that pneumatic uses.
Reply
(2012-05-04, 13:50)j1nx Wrote:
(2012-05-04, 03:33)kricker Wrote: I've been out of the loop for a while. I thought NZBS.org was shutting down, when instead it just dropped the old site and then beta.nzbs.org became nzbs.org. I've added nzbs.org back into Newznab, but when clicking on any category it just gives me an error about malformed result. Have I missed something in the past 20-30 pages of posts?

Since it now looks like the just use the newznab engine, I would like to get an invite from someone. p.steenbergen(at)j1nx.nl Angel

I would send you one, but it appears I have none to send.
Read this before using these builds.
Changelog
Reply
  •  Previous
  • 1
  • 67
  • 68
  • 69(current)
  • 70
  • 71
  • 120
  • Next 



[RELEASE] Pneumatic4.6411