•   
  • 1
  • 149
  • 150
  • 151(current)
  • 152
  • 153
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
(2012-08-13, 12:31)dh3lix Wrote:
(2012-08-10, 08:51)NaDs Wrote:
(2012-08-07, 18:05)ced64k Wrote: Same error with my playlists -> script failed

Same problem also.. Any ideas??

same here ... dumping for great justice ^^
error appeared here today... has anyone had the time to take a look at it?
(2012-08-11, 19:51)abusharif Wrote: Not sure if its already mentioned but Search function seems to be "broken". Tested with 3.0.0 and 3.1.0, latest nightlies on OSX
Every time you choose "Search", Search window where you put the keyword will pop-up, but at the same time "Loading..." window shows up on top of it and nothing happens. After clicking Cancel in the Loading window, search one is still there but after entering keyword it doesnt return any search results.
Confirmed here. I just built a new version the other night, does the same thing. My build process is as follows :
Code:
cd ~/Builds
git clone git://github.com/xbmc/xbmc.git
cd xbmc
./bootstrap
./configure --prefix=/usr --enable-vaapi --enable-libbluray --enable-airplay
make -j4
sudo make install
All previous searches are still there, and they all work. It's just searching for something new that breaks.

Hrm - interesting. Does the same thing with the Vimeo plugin. So it might not be local to the youtube plugin ...

D.
Confirmed again. Anywhere you can do a Search it does the same thing. So it's not just the youtube plugin, it's something more core to XBMC. Where should this be reported ?
(2012-08-19, 11:54)lind Wrote:
(2012-08-13, 12:31)dh3lix Wrote:
(2012-08-10, 08:51)NaDs Wrote: Same problem also.. Any ideas??

same here ... dumping for great justice ^^
error appeared here today... has anyone had the time to take a look at it?
For all those receiving the script error, try this. I did it, and it worked for me!


1. Uninstall the YouTube app from XBMC.

2. Download this, it is the 2.7.0 YouTube for XBMC. here

3. Install that add-on in XBMC from a .zip file

4. You should be able to update from the 2.7.0 YouTube app to 3.1.0 UPDATE!

5. Test out the app, and see if it works.

If it doesn't work, I would suggest going into your XBMC folder, deleting anything related to that Youtube app, and then installing. I am running 32 bit Windows Vista on my box, XBMC 11 Eden, if that helps. Good luck!
(2012-08-22, 22:47)schott12521 Wrote:
(2012-08-19, 11:54)lind Wrote:
(2012-08-13, 12:31)dh3lix Wrote: same here ... dumping for great justice ^^
error appeared here today... has anyone had the time to take a look at it?
For all those receiving the script error, try this. I did it, and it worked for me!

No chance - still bailing out with that scripterror .. root of the problem should be this after checking debugging logs :

08:57:51 T:3336 ERROR: Error Type: <type 'exceptions.TypeError'>
08:57:51 T:3336 ERROR: Error Contents: an integer is required
08:57:51 T:3336 ERROR: Traceback (most recent call last):
File "C:\Users\mpu\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 106, in <module>
navigation.executeAction(params)
File "C:\Users\mpu\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeNavigation.py", line 155, in executeAction
self.playlist.playAll(params)
File "C:\Users\mpu\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubePlaylistControl.py", line 91, in playAll
listitem = self.xbmcgui.ListItem(label=video("Title"), iconImage=video("thumbnail"), thumbnailImage=video("thumbnail"))
TypeError: an integer is required

No idea whats causing that for the moment O_o

EDIT: just to let you know that the problem does not comes up with the plugin in version 3.0.0

I couldnt find version 3.0. Do you have a link?
(2012-08-28, 10:57)Jarak Wrote: I couldnt find version 3.0. Do you have a link?

I used the rollback function from xbmc itself to revert to version 3.00 - if you had it installed also before just go to the addon menu and check the addon options for the plugin to "blacklist 3.10" and rollback to any version you had previously installed.

if this not helps i have rar'ed the addon folder of 3.00 here -> https://www.dropbox.com/s/jwiedja2b7f2oc...outube.rar

Thanks a lot, i only had 2.7.0 installed before. I will try it later
(2012-08-16, 19:51)AddonScriptorDE Wrote: Hi,
I have problems playing youtube videos the last days. They sometimes only start at the second attempt.
The stream url seems not to be correctly resolved: When the video wont play, the url starts with "=http" instead of "http".

Here is a log with a not working video.
After trying to play the same video again, everything is fine...

Its not always. I just played more then 10 videos fine, when I suddenly got this mysterious behavior again.
Am I the only one with this problem?

Thanks,
asde

Same problem. While this is slightly annoying for streaming it's a big pain if you queue up some downloads because when the error is encountered it will jam up the downloader until the commoncache.db file is deleted. I just hacked the downloader script to strip the leading "=" character but I got an HTTP 403 error with the resulting URL.

Hmm the playback bug is new, and a fix is incoming, we're looking into issues with the downloader but youtube changed something so it's gonna be a while..

(2012-09-01, 16:11)wmansir Wrote:
(2012-08-16, 19:51)AddonScriptorDE Wrote: Hi,
I have problems playing youtube videos the last days. They sometimes only start at the second attempt.
The stream url seems not to be correctly resolved: When the video wont play, the url starts with "=http" instead of "http".

Here is a log with a not working video.
After trying to play the same video again, everything is fine...

Its not always. I just played more then 10 videos fine, when I suddenly got this mysterious behavior again.
Am I the only one with this problem?

Thanks,
asde

Same problem. While this is slightly annoying for streaming it's a big pain if you queue up some downloads because when the error is encountered it will jam up the downloader until the commoncache.db file is deleted. I just hacked the downloader script to strip the leading "=" character but I got an HTTP 403 error with the resulting URL.

Is anyone else having issues with the sort order in "New Subscription Videos" in "My Subscriptions"?

I would assume that the video order should match the ordering on the subscription view on youtube.com, but for me it doesn't.

Frequently i see new videos, which are not at the top of the list, causing me to miss them initially.
I have had so many problems with this plugin. Only thing I am able to do reliably is search and play videos. I have taken to using Navi-X to browse youtube otherwise, since it works flawlessly.
(2012-09-02, 21:24)HenrikDK Wrote: Hmm the playback bug is new, and a fix is incoming, we're looking into issues with the downloader but youtube changed something so it's gonna be a while...
A downloader that has graceful fault handling would be nice, but on this particular issue I think it's just being fed a bad URL. I tried the URL from the log that AddonScriptorDE posted and after removing the leading "=" it too gave a 403 error. I tried comparing it to a known good video URL but I'm not familiar enough with Youtube's URL scheme to see the issue.
My Youtube plugin (v 3.1.0) was similarly broken on search and browse. I managed to fix the issue and am now happily watching videos. First, the fix, then the logs (for those of you who think you might have the same problem). This appears to have already been fixed upstream.

The Fix:

Change line 841 of YouTubeCore.py (addons/plugin.video.youtube/YouTubeCore.py):

Old:
if res[i]:
New:
if (len(res) > i) and res[i]:

For the diff-inclined among you:

--- YouTubeCore.py.old 2012-09-05 00:25:26.473877693 -0700
+++ YouTubeCore.py 2012-09-05 00:25:35.279077502 -0700
@@ -838,7 +838,7 @@
i = 0
for item in ytobjects:
if "videoid" in item:
- if res[i]:
+ if (len(res) > i) and res[i]:
item["Overlay"] = res[i]
i += 1 # This can NOT be enumerated because there might be missing videoids
return ytobjects


The Logs (xbmc.log):

00:06:17 T:1276322912 NOTICE: [YouTube-3.1.0] getYTCache : 'Length mismatch:'' -['dMH0bHeiRNg', 'inLBPVG8oEU', '2laujomh0JY', '7bP06EJniVs', 'yHRk2v5MtE4', 'MOiQy9koW20', 'fTPWtYqaHl4', 'DC76VwKtz4M', 'LIckScLy
00:06:17 T:1276322912 INFO: -->Python script returned the following error<--
00:06:17 T:1276322912 ERROR: Error Type: <type 'exceptions.IndexError'>
00:06:17 T:1276322912 ERROR: Error Contents: string index out of range
00:06:17 T:1276322912 ERROR: Traceback (most recent call last):
File "/storage/.xbmc/addons/plugin.video.youtube/default.py", line 108, in <module>
navigation.listMenu(params)
File "/storage/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 108, in listMenu
return self.list(params)
File "/storage/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 191, in list
(results, status) = self.feeds.list(params)
File "/storage/.xbmc/addons/plugin.video.youtube/YouTubeFeeds.py", line 157, in list
videos = self.core.getVideoInfo(result["content"], params)
File "/storage/.xbmc/addons/plugin.video.youtube/YouTubeCore.py", line 962, in getVideoInfo
self.getYTCache("vidstatus-", ytobjects, "Overlay")
File "/storage/.xbmc/addons/plugin.video.youtube/YouTubeCore.py", line 841, in getYTCache
if res[i]:
IndexError: string index out of range
(2012-09-04, 19:40)dkplayaclub Wrote: I have had so many problems with this plugin. Only thing I am able to do reliably is search and play videos. I have taken to using Navi-X to browse youtube otherwise, since it works flawlessly.


I've been using my iPad to search then using AirPlay to display them on my tv
  •   
  • 1
  • 149
  • 150
  • 151(current)
  • 152
  • 153
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428