•   
  • 1
  • 180
  • 181
  • 182(current)
  • 183
  • 184
  • 393
  •   
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs
@truthlesshero: you should tick "Run emulator in solo mode" under "Launch options" in your ROM collection. That will cause XBMC to be closed while the emulator is running so it doesn't hog any resources.
Reply
(2012-10-21, 11:49)negge Wrote: @truthlesshero: you should tick "Run emulator in solo mode" under "Launch options" in your ROM collection. That will cause XBMC to be closed while the emulator is running so it doesn't hog any resources.

thanks..i'll test it out!
Reply
@versus: Thanks for the hint, it worked like a charm!
Reply
Hi ya fellas,

Im running AEON MQ4 and I can't seem to get Dolphin (Gamecube) to launch correctly for the life of me. Every time I try to launch a game a command window pops up with a help dialog box containing usage dialogs and "Unexpected parameter 'H:\Programs\Emulators\GameCube\Roms\Mario Kart.iso <or whatever game title>.

If anybody has any ideas or suggestions I would greatly appreciate the help.

thanks
Reply
(2012-10-23, 02:35)megaskywarp Wrote: Hi ya fellas,

Im running AEON MQ4 and I can't seem to get Dolphin (Gamecube) to launch correctly for the life of me. Every time I try to launch a game a command window pops up with a help dialog box containing usage dialogs and "Unexpected parameter 'H:\Programs\Emulators\GameCube\Roms\Mario Kart.iso <or whatever game title>.

If anybody has any ideas or suggestions I would greatly appreciate the help.

thanks

try putting the /e switch before the %rom% parameter in RCB
Reply
versus - you're a king! Thanks so much!
Reply
All of my roms are on a network share, and I took the advice here to change the format in the config.xml to use \\server\share... instead of smb://server/share... I changed this for both <romPath> and <mediaPath>.

This let RCB successfully scrape my roms and download images for them. However, when I browse them, the images do not show up. In the .nfo next to the rom and in MyGames.db, the images exist and have the correct path (\\server\share\...), but RCB does not load them. There are also no errors in XBMC's debug log.

Any hints on how to fix or debug this?
XBMC.MyLibrary (add anything to the library)
ForTheLibrary (Argus TV & XBMC Library PVR Integration)
SageTV & XBMC PVR Integration
Reply
(2012-10-24, 19:23)bradvido88 Wrote: All of my roms are on a network share, and I took the advice here to change the format in the config.xml to use \\server\share... instead of smb://server/share... I changed this for both <romPath> and <mediaPath>.

This let RCB successfully scrape my roms and download images for them. However, when I browse them, the images do not show up. In the .nfo next to the rom and in MyGames.db, the images exist and have the correct path (\\server\share\...), but RCB does not load them. There are also no errors in XBMC's debug log.

Any hints on how to fix or debug this?

So I've figured out that the problem is when you scrape the games the <mediaPath> needs to use the \\server\share syntax. However, once they are scraped, RCB/XBMC needs them in the smb:// path to find the images.
The problem is that they get stored in MyGames.db using the scraped path of \\server\share.
RCB should automatically convert this path to the XBMC convention of smb:// when it's added to the database.

I fixed MyGames.db by executing:
Code:
UPDATE file SET name = REPLACE(name, "\\", "smb://") WHERE fileTypeId IN(1,2,3,4,5);
UPDATE file SET name = REPLACE(name, "\", "/") WHERE fileTypeId IN(1,2,3,4,5);
XBMC.MyLibrary (add anything to the library)
ForTheLibrary (Argus TV & XBMC Library PVR Integration)
SageTV & XBMC PVR Integration
Reply
versus Wrote:To fix properly it needs to be changed to something like this.

xbmc.executeJSONRPC {"jsonrpc":"2.0","method":"GUI.SetFullscreen","params": "fullscreen"}

I have no faintest idea about coding so this may be completely wrong. Could someone suggest proper replacement?
This exact line will not work but Angelscry found out another way to use this feature with the json API. I did not yet try it myself but I am sure this should work. I will adopt this in next release (coming soon).


bradvido88 Wrote:So I've figured out that the problem is when you scrape the games the <mediaPath> needs to use the \\server\share syntax. However, once they are scraped, RCB/XBMC needs them in the smb:// path to find the images.
The problem is that they get stored in MyGames.db using the scraped path of \\server\share.
RCB should automatically convert this path to the XBMC convention of smb:// when it's added to the database.
Thanks for sharing. We are exactly working on this issue atm. This should also be fixed in next release.
Reply
Im having some problems when im trying to run 7zip files with NES roms inside (no problem with .zip files at all). Does RCB really have support for 7zip with multiple roms inside? Im running XBMC in windows 7... if someone can give me a little help here i appreciate. Thanks in advance.
Reply
Hello, I read a few post that some have the psxreload emulator working. I unfortunately can't get it working properly. It starts but the game doesn't start just the emu. If someone who has it working correctly can help me out it be great. I'm using windows 7
Image
Reply
(2012-10-20, 19:18)versus Wrote:
(2012-10-20, 18:10)negge Wrote: Just for the record, I just experienced the same thing as @versus. Will revert back to alpha2 for now.

You can go with higher version (until 15.10 nightly, not sure) if you remove FALSE in both statements that appear twice in gui.py located at

C:\Users\xxxx\AppData\Roaming\XBMC\addons\script.games.rom.collection.browser\resources\lib

self.addItem(item, False)

Neither self.addItem(item,) or self.addItem(item) fixes the display of scraped roms for me. Am I doing this wrong?
Reply
I have RCB running on XBMC 12 on my pi -- it imports the games in the progress bar, and the various manufacturers and such show up in the filter, but no games actually show up in the items list.

Any ideas?
Reply
(2012-10-27, 19:19)The Angry One Wrote:
(2012-10-20, 19:18)versus Wrote:
(2012-10-20, 18:10)negge Wrote: Just for the record, I just experienced the same thing as @versus. Will revert back to alpha2 for now.

You can go with higher version (until 15.10 nightly, not sure) if you remove FALSE in both statements that appear twice in gui.py located at

C:\Users\xxxx\AppData\Roaming\XBMC\addons\script.games.rom.collection.browser\resources\lib

self.addItem(item, False)

Neither self.addItem(item,) or self.addItem(item) fixes the display of scraped roms for me. Am I doing this wrong?

Have you changed both instances. there are 2 of them.
Reply
(2012-10-27, 22:09)DeliriumTremens Wrote: I have RCB running on XBMC 12 on my pi -- it imports the games in the progress bar, and the various manufacturers and such show up in the filter, but no games actually show up in the items list.

Any ideas?
Try looking at this post
http://forum.xbmc.org/showthread.php?pid...pid1218525

Reply
  •   
  • 1
  • 180
  • 181
  • 182(current)
  • 183
  • 184
  • 393
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs20
This forum uses Lukasz Tkacz MyBB addons.