•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  •   
Linux HOW-TO setup XBMC and Linux with correct resolution (xorg.conf)
I still haven't resolved this, can anyone help from my last post please?

Thanks
Reply
@Finchy, try:

sudo service lightdm stop

to stop XBMC and

sudo service lightdm start

to start it again.
Reply
Dear users

I followed all of these steps but the problem remains the same, no visual on the screen. I think I did everything fine so here is my xorg.conf and xlog file hoping you guys could take a look at it.

Much appreciated
Joris

xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 304.60 ([email protected]) Sun Oct 14 21:19:18 PDT 2012

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
Option "ExactModeTimingsDVI" "TRUE"
HorizSync 30 - 83
VertRefresh 58 - 62
ModeLine "1280x720" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync InterLace
SubSection
modes "1280x720"
EndSubSection
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "ModeValidation" "NoEdidModes"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


xlog.txt
This is a very long file, I uploaded it here:
http://users.telenet.be/clem.vanhouche/xlog.txt


Much appreciated
Joris
Reply
@Moddieman

remove Option "ModeValidation" "NoEdidModes"

remove SubSection
modes "1280x720"
EndSubSection

Under device add

Option "ModeDebug" "true"

Then I would like you to reboot and get me your /var/logs/xorg.0.log in a pastebing and I will calculate your modelines and do you a proper xorg...The old one is useless I want edid modes to show up pls on log.

uNi
Reply
@ Moddieman
@ Finchy

Use this xorg, and follow my link to properly configure xbmc for 23/24p

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.60  ([email protected])  Sun Oct 14 21:19:18 PDT 2012
# Tweaked by uNiversal


Section "Device"
    Identifier            "Device0"
    Driver                "nvidia"
    VendorName            "NVIDIA Corporation"
    Option                "NoLogo"                "true"
    Option                "DynamicTwinView"        "false"
    Option                "NoFlip"                "false"
    Option                "ConnectToAcpid"        "0"
    Option                "ModeValidation"        "NoVesaModes, NoXServerModes"
    Option                "UseDisplayDevice"        "DFP-1"
    Option                "ConnectedMonitor"        "DFP-1"
    Option                "ModeDebug"                "true"
    Option                "HWCursor"                "false"
    Option                "SWCursor"                "false"
    Option                "RenderAccel"            "1"
EndSection


Section "Screen"
    Identifier            "Screen0"
    Device                "Device0"
    Monitor                "Monitor0"
    DefaultDepth        24
    Option                "ColorRange"            "Full"
    Option                "ColorSpace"            "RGB"
    Option                "ExactModeTimingsDVI"    "True"
    SubSection            "Display"
        Depth            24
    EndSubSection
EndSection


Section "Monitor"
    Identifier        "Monitor0"
    VendorName        "Unknown"
    ModelName        "Unknown"
    HorizSync        30.0 - 83.0
    VertRefresh        58.0 - 62.0
    # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
    Modeline        "1920x1080_60"       148.50 1920  2008  2052  2200  1080  1084 1089  1125 +hsync +vsync
    ModeLine        "1920x1080_23.976"   74.175 1920  2558  2602  2750  1080  1084 1089  1125 +hsync +vsync
    ModeLine        "1920x1080_24"       74.250 1920  2558  2602  2750  1080  1084 1089  1125 +hsync +vsync
    Option            "DPI" "96 x 96"
EndSection


Section "Extensions"
    Option                 "Composite" "Disable"
EndSection

And that should give you pretty precise modes with nVidia 304.60

+1

uNi
Reply
Thanks so much! I used the xorg you provided and everything works like an absolute charm. The only thing left do do for me is fixing the sound through hdmi but there is lots of documentation for this so i know this won't be a problem.


Thanks for the help, I really appreciate it!

Moddieman
Reply
(2012-10-31, 15:19)Moddieman Wrote: Thanks so much! I used the xorg you provided and everything works like an absolute charm. The only thing left do do for me is fixing the sound through hdmi but there is lots of documentation for this so i know this won't be a problem.


Thanks for the help, I really appreciate it!

Moddieman
Your welcome +1

uNi
Reply
This computer home theater software I have not tried it, I was very interested.
Reply
(2012-10-31, 05:46)uNiversal Wrote: @ Moddieman
@ Finchy

Use this xorg, and follow my link to properly configure xbmc for 23/24p

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.60  ([email protected])  Sun Oct 14 21:19:18 PDT 2012
# Tweaked by uNiversal


Section "Device"
    Identifier            "Device0"
    Driver                "nvidia"
    VendorName            "NVIDIA Corporation"
    Option                "NoLogo"                "true"
    Option                "DynamicTwinView"        "false"
    Option                "NoFlip"                "false"
    Option                "ConnectToAcpid"        "0"
    Option                "ModeValidation"        "NoVesaModes, NoXServerModes"
    Option                "UseDisplayDevice"        "DFP-1"
    Option                "ConnectedMonitor"        "DFP-1"
    Option                "ModeDebug"                "true"
    Option                "HWCursor"                "false"
    Option                "SWCursor"                "false"
    Option                "RenderAccel"            "1"
EndSection


Section "Screen"
    Identifier            "Screen0"
    Device                "Device0"
    Monitor                "Monitor0"
    DefaultDepth        24
    Option                "ColorRange"            "Full"
    Option                "ColorSpace"            "RGB"
    Option                "ExactModeTimingsDVI"    "True"
    SubSection            "Display"
        Depth            24
    EndSubSection
EndSection


Section "Monitor"
    Identifier        "Monitor0"
    VendorName        "Unknown"
    ModelName        "Unknown"
    HorizSync        30.0 - 83.0
    VertRefresh        58.0 - 62.0
    # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
    Modeline        "1920x1080_60"       148.50 1920  2008  2052  2200  1080  1084 1089  1125 +hsync +vsync
    ModeLine        "1920x1080_23.976"   74.175 1920  2558  2602  2750  1080  1084 1089  1125 +hsync +vsync
    ModeLine        "1920x1080_24"       74.250 1920  2558  2602  2750  1080  1084 1089  1125 +hsync +vsync
    Option            "DPI" "96 x 96"
EndSection


Section "Extensions"
    Option                 "Composite" "Disable"
EndSection

And that should give you pretty precise modes with nVidia 304.60

+1

uNi

Hi Universal

How do I get that into the Xorg file? When I try to paste it in via WinSCP it says action denied. I'm not very familiar with Linux editing, etc.

I'm running XBMCBuntu and my TV is a Panasonic 42PX60 btw.
Reply
You have do it via ssh (since your scp doesnt have permissions to create files everywhere then
Code:
sudo nano /etc/X11/xorg.conf
and paste the contents then press ctrl+o to save file and ctrl+x to exit back

Telling me what your tv brand and model is doenst help at all, as I cant see your /var/log/xorg.0.log and I dont have access to your Tv/system

This xorg is using DFP-1 since idk if your output is using DFP-0 or DFP-1 this may have to be modified to your system (you can find out by looking at /var/log/xorg.0.log instructions are on first post)

I also pimped the xorg to use Moddieman refresh rate for his TV. If you want a similar one you have to post the info he posted.

uNi
Reply
Ah, thanks. I've updated the xorg.conf as you've said, but it still only gives me the resolution of up to 720p in XBMCBuntu.

I've uploaded my xorg.o.log file (copied into a .txt file) to https://dl.dropbox.com/u/11513453/Xorg.o.log.txt if you wouldn't mind having a look.

Many thanks
Reply
Ah ok, first off, its as I suspected, your TV and most like all tv's are DFP-0

Use this for your TV specific. Ive corrected the xorg to match your TV including
HorizSync : 15.000-46.000 kHz
VertRefresh : 48.000-61.000 Hz


Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.60  ([email protected]-rhel47-13)  Sun Oct 14 21:19:18 PDT 2012
# Tweaked by uNiversal


Section "Device"
    Identifier            "Device0"
    Driver                "nvidia"
    VendorName            "NVIDIA Corporation"
    Option                "NoLogo"                       "true"
    Option                "DynamicTwinView"        "false"
    Option                "NoFlip"                         "false"
    Option                "ConnectToAcpid"           "0"
    Option                "ModeValidation"            "NoVesaModes, NoXServerModes"
    Option                "UseDisplayDevice"        "DFP-0"
    Option                "ConnectedMonitor"        "DFP-0"
    Option                "ModeDebug"                 "true"
    Option                "HWCursor"                   "false"
    Option                "SWCursor"                   "false"
    Option                "RenderAccel"               "1"
EndSection


Section "Screen"
    Identifier             "Screen0"
    Device                "Device0"
    Monitor               "Monitor0"
    Option                "VertRefresh"                "DFP-0: 15-36"
    Option                "HorizSync"                  "DFP-0: 48-61"
    DefaultDepth        24
    Option                "ColorRange"                "Full"
    Option                "ColorSpace"                "RGB"
    Option                "ExactModeTimingsDVI"    "True"
    SubSection            "Display"
        Depth            24
    EndSubSection
EndSection


Section "Monitor"
    Identifier              "Monitor0"
    VendorName        "Unknown"
    ModelName         "Unknown"
    HorizSync           15 - 36
    VertRefresh         48 - 61
    # 1920x1080p 50Hz to 23.976Hz (EIA/CEA-861B)
    Modeline         "1920x1080_50"        74.25    1920  2448  2492  2640  1080  1084 1089  1124 +hsync +vsync
    ModeLine        "1920x1080_23.976"   74.175  1920  2558  2602  2750  1080  1084 1089  1125 +hsync +vsync
    ModeLine        "1920x1080_24"          74.250 1920  2558  2602  2750  1080  1084 1089  1125 +hsync +vsync
    Option            "DPI" "96 x 96"
EndSection


Section "Extensions"
    Option                 "Composite" "Disable"
EndSection

As for 1920x1080 Your Tv supports @60Hz interlaced only @50Hz non interlaced which @50Hz is what I defined.
your xorg complains

Code:
[    20.480] (II) NVIDIA(0):   Validating Mode "1920x1080":
[    20.480] (II) NVIDIA(0):     1920 x 1080 @ 60 Hz
[    20.481] (II) NVIDIA(0):     Mode Source: EDID
[    20.481] (II) NVIDIA(0):       Pixel Clock      : 74.18 MHz
[    20.481] (II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
[    20.481] (II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
[    20.481] (II) NVIDIA(0):       VRes, VSyncStart : 1080, 1084
[    20.481] (II) NVIDIA(0):       VSyncEnd, VTotal : 1094, 1124
[    20.481] (II) NVIDIA(0):       H/V Polarity     : +/+
[    20.481] (II) NVIDIA(0):       Extra            : Interlace
[    20.481] (II) NVIDIA(0):     Mode (1920 x 1080) is too large for DFP Native Resolution
[    20.481] (II) NVIDIA(0):         (Max: 1280 x 720); mode will not be allowed to scale
[    20.481] (II) NVIDIA(0):         to the DFP's native resolution.
[    20.481] (II) NVIDIA(GPU-0):     BestFit Scaled and BestFit AspectScaled are identical;
[    20.481] (II) NVIDIA(GPU-0):         collapsing BestFit AspectScaled.
[    20.481] (II) NVIDIA(GPU-0):     BestFit Centered and BestFit Scaled are identical;
[    20.481] (II) NVIDIA(GPU-0):         collapsing BestFit Scaled.
[    20.482] (II) NVIDIA(GPU-0):     BestFit Centered         1920x1080
[    20.482] (II) NVIDIA(GPU-0):       Horizontal Taps        0
[    20.482] (II) NVIDIA(GPU-0):       Vertical Taps          0
[    20.482] (II) NVIDIA(GPU-0):       Base SuperSample       x4
[    20.482] (II) NVIDIA(GPU-0):       Base Depth             32
[    20.482] (II) NVIDIA(GPU-0):       Distributed Rendering  1
[    20.482] (II) NVIDIA(GPU-0):       Overlay Depth          32
[    20.482] (II) NVIDIA(0):     Mode is valid.

If the xorg above doesnt set your TV to correct 1920x1080 we may have to replace this

Code:
Modeline         "1920x1080_50"         74.25    1920  2448  2492  2640  1080  1084 1089  1125 +hsync +vsync

with this

Code:
[code]Modeline         "1920x1080_60i"         74.18    1920  2008  2052  2200  1080  1084 1089  1124 +hsync +vsync

You will need to reboot after each xorg modification for safe measure.

If it still doesn't work we can comment out

Code:
Option                "ExactModeTimingsDVI"    "True"
put a # before -Option-

I cant be sure that it fixes it but it could be your TV is very picky (it is) and has a crap upscaler

You could also upgrade your video drivers to 304.60 if you haven't already done that. (xswat ppa)

uNi
Reply
Great, thanks, I'll have a go!

So does my telly support 1080p at 50hz?! I always thought it was 720p or 1080i.

How do I update my drivers (or find out what I have)?
Reply
OK, so I've updated the Xorg file but there's a problem. I get visuals until XBMC starts to load, but then I just get a black screen. I suspect it's because my telly doesn't support 1080p. I've just changed it back to the original (backup) one for the time being. Would you mind amending it to allow both 720p and 1080i please?
Reply
Replace the modeline as I said use the one I posted last except you want to replace

Code:
Modeline         "1920x1080_50"         74.25    1920  2448  2492  2640  1080  1084 1089  1125 +hsync +vsync

With

Code:
Modeline         "1920x1080_60i"         74.18    1920  2008  2052  2200  1080  1084 1089  1124 +hsync +vsync

As for drivers its in xbmc.log

updating follow http://hometheatersalsa.com/updated-linu...a-drivers/

According to xorg.0.log the Tv supports 1080p @50Hz or 1080i interlaced @ 60Hz but xorg.log complains about 1080 modes in ANY interlaced or non interlaced. but try to replace the modelines as I instructed on both posts.

uNi
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  •   



Logout Mark Read Team Forum Stats Members Help
HOW-TO setup XBMC and Linux with correct resolution (xorg.conf)6
This forum uses Lukasz Tkacz MyBB addons.